Shopware Backend Suche sehr langsam

Hallo zusammen,

ich habe schon länger das Problem, dass die Backend Suche sehr langsam ist. Es dauert ca. 3-5 Sekunden, bis ich eine Antwort vom Server erhalte. Hier einmal ein Beispiel von der Backend Suche (blaues Suchfeld):

Meine Serverkonfiguration sieht folgendermaßen aus:

Habt ihr eine Idee, wo ich noch schauen kann?

 

Liebe Grüße
Pascal 

Hallöchen,

probier mal folgendes als ersten Ansatz: Shopware Backed > Einstellungen > Benutzerverwaltung > “Deinen” Benutzer editieren > Häkchen bei “Backend-Cache deaktivieren” entfernen. Gib mir dann gerne mal Rückmeldung.

LG, Marcel

1 Like

Hey,

danke für die zügige Antwort. Bei mir war gar kein Haken drin. Ich habe den testweise mal aktiviert. Leider ist das Problem immer noch da. 

 

LG
Pascal 

Hallo ich muss das Thema leider noch mal ansprechen. Das Problem ist leider immer noch da. Mir ist aufgefallen, dass wenn ich die Kunden Datenbank leere die Suche wieder normal funktioniert. Wir haben derzeit knapp 100.000 Kunden. Kann es daran irgendwie liegen?

Von welcher Suche ist überhaupt die Rede? Die ganz oben im blauen Kopf oder die beim Kundenfeld?

Die Suche oben im blauen Feld (also im Backend Kopfbereich) ist recht umfangreich. Was habt ihr hier erwartet? Diese Suche ist für alles mögliche gedacht! Logisch, dass die etwas länger braucht, wenn die Suche in Kunden, Bestellungen, Artikel etc. suchen muss.

Ja genau die Suche im oberen Kopfbereich. 

Für mich stellt sich nur die Frage. Ist die Suchdauer von 5 Sekunden normal oder nicht. Für mich erscheint das schon relativ lange. 

Ist die Suchdauer von 5 Sekunden normal oder nicht

Durchaus normal. Wie schon erwähnt, diese Suche sucht nach allen möglichen Dingen in unzähligen Datenbank Spalten. Wenn sich tausenden Einträge bei Kunden, Artikeln, Bestellungen etc… befinden, muss dort die Suche alles durchgehen. Am Ende muss die Suche millionen Einträge durchgehen. Jetzt beantworte dir die Frage selber :slight_smile:

In diesem Fall ist es sinnvoller die Suche direkt im Kundenfenster zu benutzen, da diese auch nur nach Kunden sucht.

Danke für die Info dann ist das hiermit erledigt. Danke :slight_smile:

Vielleicht kannst du beim Hoster was drehen? Welchen Hoster und Paket hast du?

Würde sich empfehlen: wenn du bei Kunden was suchst vorher bei Kunden ins Backend zu gehen. Dort gibt’s ja auch eine Suchleiste.