Shopware 6.5 Release Candidate

Hallo,

gibt es irgendwo einen vernünftigen Leitfaden wie man den aktuellen Release Candiate Version 6.5 installiert? Alle bisherigen Versuche über die Composer Methode sind fehlgeschlagen und ehrlicher Weise ist das sehr frustrierend, dass es hier keine einfache und gut dokumentierte Möglichkeit gibt an den neuen Release zu kommen.

Liebe Grüße

Mich würde interessieren ab wann man das Update im Backend auswählen kann.

Ich habe die Zip hochgeladen, entpackt und während der Installation kam bei mir folgender Fehler:

Warning: require_once(/home/XXXX/public_html_sites/YYYY/shops/sw65/public/…/vendor/autoload_runtime.php): Failed to open stream: No such file or directory in /home/XXXX/public_html_sites/YYYY/shops/sw65/public/index.php on line 12

Fatal error: Uncaught Error: Failed opening required ‚/home/XXXX/public_html_sites/YYYY/shops/sw65/public/…/vendor/autoload_runtime.php‘ (include_path=‚.:/opt/alt/php81/usr/share/pear:/opt/alt/php81/usr/share/php:/usr/share/pear:/usr/share/php‘) in /home/XXXX/public_html_sites/YYYY/shops/sw65/public/index.php:12 Stack trace: #0 {main} thrown in /home/XXXX/public_html_sites/YYYY/shops/sw65/public/index.php on line 12

Gleiche Problem.
Keine Installation möglich

Interessiert sich bei Shopware niemand für das Problem mit dem RC6.5?

1 Like

hab meistens das gefühl, dass sich Shopware für garnichts interessiert außer fürs Geld :smiley:

Immerhin bin ich nicht der Einzige mit Schwierigkeiten - wenn ihr möchtet das die Entwickler Ihre Extensions adaptieren, dann sollte ein funktionierender RC mit einer ordentlichen Dokumentation zur Verfügung stehen.

Im übrigen lässt meiner Meinung nach insgesamt die Doku-Mentalität zu wünschen übrig, zu viele Dinge sind gar nicht, unzureichend oder an der falschen Stelle dokumentiert. Das sorgt regelmäßig für diese Art Frust und Stunden Recherche, denn ich habe das Gefühl vieles Shopware-Spezifisches muss man einfach wissen weil es so schlecht dokumentiert ist. Wenn man Glück hat findet man jemanden mit dem gleichen Problem im Forum.

Guten Abend,
PHP 8.1 habt ihr aktiv?
Ich empfehle euch dockware.io zu nutzen. Somit bekommt ihr in 5 Minuten lokal eine SW6.5

Vielen Dank für den Tipp, hat zu dem Zeitpunkt nur leider nichts gebracht da es noch kein 6.5 Image gab - es kann doch nicht sein, dass wir jedes mal auf externe Dienstleister warten müssen weil der Hersteller selbst keine ordentliche Version zur Verfügung stellen kann.

Wie gesagt, der Fehler kommt meiner Meinung nach bzgl. einer falschen PHP Version.
Daher auch die Frage, ob du 8.1 aktiv hast,

PHP 8.1 ist bei mir aktiv

Fehlermeldung beim Aufruf der index.php

  1. No such file or directory: vendor/autoload_runtime.php

es gibt nur einen ordner vendor-bin

Meldet sich mal jemand aus dem Turm zu Schöppingen?

Shopware 6.5 ist keine fertige Production mehr, die man einfach entpackt und dann funktioniert. Ab Shopware 6.5 wird composer benötigt.

Mit dem Download überspringt man lediglich composer create-project shopware/production:dev-flex

Alternativ auf die ZIP verzichten und …

Mit composer create-project shopware/production:6.5.0.0-dev bekommst du die aktuellste RC.

1 Like

Schaut schon ganz interessant aus der RC, insbesondere die Bestellverwaltung hat sich deutlich verbessert.

@Shopware
Gibt es später die Möglichkeit den RC auf die „Finale“ Version upzudaten?

Nein, es wird keinen Update Pfad von RC zu 6.5.0.0 geben. Die RC solltest du auch definitiv -nicht- produktiv verwenden.

Viele Grüße