Shopware 6.5 Neuer Installer shopware-installer.phar.php funktioniert nicht

Hallo, wurde der neue Installer in Shopware 6.5 überhaupt getestet?

Ich habe es noch nicht geschafft, Shopware 6.5 zu installieren.

  1. Ich starte den Installer: https://domain/shopware-installer.phar.php
  2. Ich wähle meine Sprache und klicke auf „weiter“
  3. Ich träge den Pfad zu meiner „PHP-Ausführungsdatei“ ein und klicke auf „Konfiguration“ speichern
  4. Ich wähle die Shopware-Version „Shopware-Version“ 6.5.0.0 und klicke auf „Herunterladen“
  5. PENG:
    [critical] Error thrown while running command „install -d ‚/var/www/shopware6.5‘ --no-interaction --no-ansi -v“. Message: "Command „install“ is not defined.

Did you mean this?
assets:install"

In Application.php line 702:

[Symfony\Component\Console\Exception\CommandNotFoundException]
Command „install“ is not defined.

Did you mean this?
assets:install

Wollte auch mal mit 6.5 spielen. Selbes Problem.
Vermutlich ein composer Problem? Bin mal gespannt ob jemand was dazu sagen kann.

Was ich nun wirklich nicht verstehe warum man Dinge immer gleich endgültig machen muss anstatt parallel Dinge anzubieten. Ist ja schön, dass das ganze über ein Onefile funktionieren soll - nur doof wenns dann nicht klappt und man keine andere Alternative hat. Oder was bleibt jetzt um 6.5 zu installieren wenn man darauf setzen will? Github? Kann jetzt auch nicht wirklich eine Alternative sein.

Grüße

1 Like

Bei mir kommt gleichmal das hier:

**Fatal error** : Uncaught PharException: phar "/shopware/sw6/public/shopware-installer.phar.php" SHA1 signature could not be verified: broken signature in /shopware/sw6/public/shopware-installer.phar.php:79 Stack trace: #0 /shopware/sw6/public/shopware-installer.phar.php(79): Phar::webPhar(NULL, '...', NULL, Array, '...') #1 {main} thrown in **/shopware/sw6/public/shopware-installer.phar.php** on line **79**

Ich kann also garnicht installieren.

So neue Version versucht 6.5.1.0 immer noch das selbe Problem… Ich habe es jetzt auf 3 verschiednen Servern versucht, auf allen 3 das selbe Problem!

Ich hab das Upgrade gestern auch versucht, ging voll in die Hose, trotz Backup hat mich das stunden gekostet alles wieder wiederherzustellen.

Eine richtige Fehlermeldung bekam ich nicht, nur das der Upgradevorgang fehlgeschlagen ist, aus dem Log werde ich nicht wirklich schlau …

Wem es interessiert: https://www.e-hahn.de/temp/sw64to5log.txt

Mir gelingt es auch nicht mit der neuen Lösung eine neue Installation zu bewerkstelligen. Ein Update funktioniert auch nicht. Wurde das Script shopware-installer.phar.php von Shopware getestet?

Gibt es vielleicht irgendwo eine .zip Datei mit der aktuellen 6er Version? Das hat bislang immer funktioniert.

Ich habe alle Updates von der Version 6.4.20.2 → 6.5.0.0 → 6.5.1.0 → 6.5.1.1 → 6.5.2.0 und 6.5.2.1 ohne Probleme durchgeführt. Allerdings als Update über /shopware-installer.phar.php.

Hallo RAShop, na, das hört sich ja gut an. Wo hostest Du denn Deinen Shop?

Ich kann nur von meiner Erfahrung sagen, da ich auch immer wieder Probleme mit verschiedenen Providern hatte mit unterschiedlichen Hostern. Einmal war der Vertrag mit Leistungen für Shared Hosting nicht erfüllt, aber kosten günstig sollte es auch sein.

Ich habe zu IONOS gewechselt und dort den guten Support schätze.

Ich habe mich für ein Virtual Server Cloud vCore XXL entschieden.

Klingt interessant, ist aber kein managed oder ?
Würde bei mir leider schon an der Auswahl des Systems scheitern :smiley:

Sind auch bei Ionos, 6.4.20 kein Problem, aber bei 6.5 ist auch alles beim letzten oder vorletzten Step auseinandergeflogen.
Plugins nur Paypal und eigenes Template drin und halt den Shopware-Store.

Unser VPS: $ttps://www.ionos.de/server/vps
Wir haben 23 Plugins und bei keinem Probleme.

Auf 6.5 hat sich ja auch einiges geändert. Mal alles durch Checken!

Ok hier saß der Fehler zwischen den Ohren.
Seine Name sei Ungeduld. Auch wenn der Installer Inaktiv und fertig ausschaut einfach laufen lassen.
Dann klappt es auch mit den Update.

Hallo tobiashe,
hast Du das Problem lösen können?
Bei uns tritt derselbe Fehler auf.

Nein… Ich habe es auf verschiedenen Ubuntu Servern und einem Arch Linux Server versucht. Auf beiden mit Apache und nginx. Überall das selbe Problem!

Nicht das, was ich mir erhofft hatte, aber danke für die Info.

Hallo, Ich habe für das Problem eine Lösung gefunden. Wenn ich in dem Verzeichnis in dem die shopware-installer.phar.php liegt, ein Symlink auf die composer setze, funktioniert die Installation.
z.b. „ln -s /usr/bin/composer /var/www/shopware/composer“

2 Likes

Vielen Dank für diesen wertvollen Hinweis!

Wäre nur zu schön, wenn sich Shopware auch mal um dieses Problem kümmern würde.

@tobiashe Danke für den Hinweis!

Zur Info: Ich war mal so frei und habe hierfür am 27.06. ein issue erstellt: Shopware Issuetracker

1 Like

@tobiashe Bin wegen Urlaubs erst jetzt dazu gekommen, das auszuprobieren. Es hat geklappt! Vielen Dank für den entscheidenden Hinweis.