Shopware 5.2 Theme

Hallo zusammen,

wir haben das Update auf Shopware 5.2 vollzogen, leider haben wir jetzt das Problem das die Einkaufswelten nicht mehr korrekt angezeigt werden.

Ich habe bereit mit FirePHP und dem Debugger nach irgendwelchen Auffäligkeiten geschaut, leider ohne Erfolg. Auch die Logs scheinen sauber.

Wir benutzen ein eigenes Theme, die Einkaufswelten funktionieren mit dem Standard Responsive Theme. Kennt jemand das Problem? 

Viele Grüße,

 

@timmeyy schrieb:

Hallo zusammen,

wir haben das Update auf Shopware 5.2 vollzogen, leider haben wir jetzt das Problem das die Einkaufswelten nicht mehr korrekt angezeigt werden.

Ich habe bereit mit FirePHP und dem Debugger nach irgendwelchen Auffäligkeiten geschaut, leider ohne Erfolg. Auch die Logs scheinen sauber.

Wir benutzen ein eigenes Theme, die Einkaufswelten funktionieren mit dem Standard Responsive Theme. Kennt jemand das Problem? 

Viele Grüße,

Hallo,

hast du dir vor dem Update einfach mal den Changelog angesehen (die ersten 10 Einträge betreffen ja die Einkaufswelten): http://community.shopware.com/Downloads_cat_448.html . Bei Version 5.2.0 gibt es ja einige Sachen, die die neuen Einkaufswelten betreffen (bestes Thema: Masonry fällt komplett weg).

Wahrscheinlich hast du bei dem eigenen Theme einfach Sachen (im Code) verwendet, die unter Shopware Version 5.2.0 so nicht mehr vorhanden sind.

Beste Grüße

Sebastian

 Darf ich mich bezüglich 5.2 nochmals kurz einhaken? Bin grad auch dabei das Update durchzufüren und bekomme als Fehlermeldung. 

 {"valid":false,"errorMsg":"Could not apply migration: Undefined offset: 1"}

 

 

@timmeyy schrieb:

Hallo zusammen,

wir haben das Update auf Shopware 5.2 vollzogen, leider haben wir jetzt das Problem das die Einkaufswelten nicht mehr korrekt angezeigt werden.

Ich habe bereit mit FirePHP und dem Debugger nach irgendwelchen Auffäligkeiten geschaut, leider ohne Erfolg. Auch die Logs scheinen sauber.

Wir benutzen ein eigenes Theme, die Einkaufswelten funktionieren mit dem Standard Responsive Theme. Kennt jemand das Problem? 

Viele Grüße,

Hallo,

sicher hilft dir das Thema weiter: https://forum.shopware.com/discussion/38495/einkaufswelten-in-shopware-5-2 .

 

@Matze2305 schrieb:

Darf ich mich bezüglich 5.2 nochmals kurz einhaken? Bin grad auch dabei das Update durchzufüren und bekomme als Fehlermeldung.

{“valid”:false,“errorMsg”:“Could not apply migration: Undefined offset: 1”}

 

Das Thema hier hat mit deinem Problem überhaupt nichts zu tun. Alternativ würde ich probieren, einfach ein Backup einzuspielen und das Update neu durchzuführen.

Beste Grüße

Sebastian

1 Like

Hi, bei mir genau das selbe. Einkaufswelten funzen nicht mehr und auch mein selbst programmiertes Template spinnt rum nach dem update auf 5.2.1. Das offcanvas Menü scheinen sie ebenfalls verändert zu haben, denn auch dort zeigt sich nach dem update keinerlei funktion mehr. Das heisst jetzt wieder die nächsten Tage auf Fehlersuche gehen =(( Hab das ganze zum Glück erstmal lokal getestet. Was passiert denn wenn man nicht auf 5.2 updatet? Werden Sicherheitpaches etc. auch noch weiterhin für die 5.1.x angeboten?

Habe gerade einen Eintrag gefunden der mich auf die richtige Spur gebracht hat: 

https://forum.shopware.com/discussion/38504/update-5-2-keine-einkaufwelten-mehr

Es lag bei mir ebenfalls an dem fehlenden Script in meiner angepassten index.tpl 

var csrfConfig = csrfConfig || {ldelim}
                'generateUrl': '{url controller="csrftoken" fullPath=false}',
                'baseUrl': '{$Shop->getBaseUrl()}',
                'shopId': '{$Shop->getId()}'
            {rdelim};

 

1 Like

Hallo zusammen,

danke für eure Antworten. Bei uns scheint es an themes/Frontend/Responsive/frontend/_public/src/js/jquery.emotion.js zu liegen.

Wenn wir diese in unserer Theme.php auskommentieren funktionieren die Einkaufswelten. Komischerweise haben wir darin nur eine Anpassung gemacht, auch wenn ich diese Rückgänig mache besteht der Fehler dennoch. Kennt jemand dieses Problem? 

Wie gesagt ich bekomme keinerlei Fehler über die Konsole/Firebug/Logger.

Danke und VG,

Hallo,

also irgendwie ist das Update nicht sauber durchglaufen. Ich habe mir mal die Sourcen der emotion.js auf github angeschaut, bei uns wurde diese überaupt nicht geupdatet.

Mit der Version von github läufts unser Theme jetzt korrekt. 

 

VG,

war bei mir ähnlich, nach manueller Neusinstallation und migration der alten DB läuft der Shop wieder.

1 Like