Shopseiten als Tabs im Hauptmenü

Entweder suche ich falsch oder es ist so einfach, dass einfach keiner außer mir diese Frage hat:  Undecided
Ich nutze das Responsive Template und möchte ganz einfach im Hauptmenü oben (also nicht auf der Artikel-Detailseite!) neue Tabs anlegen. Einerseits soll da “Über uns” hin (die Seite ist ja auch unten schon vorhanden), aber auch neue Seiten, die Text und Bilder enthalten (keine Produkte).

Ich habe nun als erstes Shopseiten angelegt (sofern nicht bereits vorhanden, wie “Über uns”). 
Dann habe ich im Backend bei den Kategorien unter “Deutsch” neue Kategorien entsprechend meiner Seitennamen angelegt. Diese habe ich dann jeweils auf eine “externe Seite”, nämlich die entsprechende Shop-Seite, verlinkt. Anders als mit Kategorien wusste ich mir nicht zu hefen, die Links oben hin zu bekommen. Obwohl Kategorien ja eigentlich für Artkel gedacht sind.
So weit, so gut, die Links mit den korrekten Seitennamen erscheinen schon mal oben im Menü. Aber erstens springt der Tab nicht auf die Seite, wenn man drauf klickt und zweitens sehe ich auf den Shopseiten nicht den eingegeben Text, sondern das Produkt, wie auf der Home-Seite (Einkaufswelt). 

Hier der Link zum Shop: http://milchfilter.com/

Danke und viele Grüße, Hajo

Hallo,

ich hab das auch schon versucht. Mit den Shopseiten hab ich es nicht geschafft. Letztenendes habe ich je eine Einkaufswelt angelegt als großes Html-Feld und den Text und die Bilder eingefügt. Begeistert bin ich davon nicht. weil ich davon ausgehe, dass der ganze Text von google in der Einkaufswelt nicht so gewürdigt wird, als wenn er auf einer Shopseite stehen würde.

LG

Wenn Ihr den Tab „higlight“ haben möchtet, hängt mal an den Link noch ein „?c=xx“ wobei xx die ID der Link-Kategorie ist. Hab das gerade mal per Direkteingabe bei mir ausprobiert - dann hat der Tab einen „highlight“ (werde das gleich mal feste verdrahten)

1 Like

Hajo scheint auf eine Lösung gefunden zu haben. Ich nutze das Plugin Einfaches Ausklappmenü und hätte die Shopseiten gerne in den Untermenüpunkten. Es handelt sich allerdings auch nicht um die „Service“-Seiten wie Über uns z.B. bei denen dann links der Block mit den weiteren Shopseiten angezeigt wird.

Bei mir müssten Links die Produktkategorien und unterkategorien stehen…

Nachtrag: Ich habs jetzt gerade nochmal versucht. Shopseite angelegt, Haupt- und Unterkategorie angelegt je mit externem Link zur Shopseite. Es funktioniert, jedoch habe ich dann links das falsche Menü stehen.

Gibt es dafür auch noch eine Lösung?

Hallo sonic, 

tausend Dank, dass mit den Tabs hat super geklappt. 

Aber auch nach torics Antwort habe ich für die Seiten, auf dene ich Text ohne Produkte haben möchte, noch immer keine richtige Lösung. Wenn ich eine neue Seite anlege, erscheint auf dieser immer das Produkt. Ich sehe aber unter “Shopseiten” bei den Einstellungen keinen Unterschied zu Seiten, wie z.B. “Über uns”, die schon vorher da war und bei der der Text erscheint. 
Und außerdem (zweites Problem) muss dann auch noch links das Menü weg, welches noch bei “Über uns” erscheint. 

Irgendwo muss da doch noch eine Einstellung sein, die ich noch nicht gefunden habe, bei der man definieren kann, was auf der Seite angezeigt wird (Text oder Produkt) und welches Menü?!

Ich verstehe das Problem nicht.
Was für ein Produkt?
Du definierst eine Kategorie als “Link” und trägst den relativen (seo) Pfad dort ein, speicherst die Kategorie und leerst den Cache. Dann ein Reload. Wenn Du nun auf den TAB klickst, kommt die Seite als ganz normale statische Seite?!?!?

crymas.de => “über uns”

Hallo,

das Problem mit dem Menü links hatte ich ja erwähnt. Wo bei dir jetzt der Artikel her kommen soll, kann ich nicht ganz verstehen. Sind es die Artikel, die du auf der Startseite hast?

Du hast also eine neue Shopseite angelegt und mit Text gefüllt. Möglicherweise auch in ein eigenes neues Verzeichnis bei den Shopseiten eingefügt. Jetzt musst du die URL herausfinden und in der Kategorie einfügen.

Ist ein Fehler in dieser URL, landest du immer wieder auf der Startseite.

Vielleicht schiebst du die Shopseite zunächst in eine Rubrik, die im Footer angezeigt wird und kopierst dir von dort den Link. Dann kannst du sie später immer noch in andere Verzeichnisse schieben.

LG

@sonic‍ ich vermute, durch einen Fehler im Link landet er auf der Startseite.

Gut, sofern er die Seite z.B. in “in Bearbeitung” abgelegt hat, ist die Url ja noch nirgends eingebunden (footer, “Links”) und damit ggf. noch nicht die Url erzeugt.
Da hilft dann wirklich Dein Rat

Vielleicht schiebst du die Shopseite zunächst in eine Rubrik, die im Footer angezeigt wird und kopierst dir von dort den Link. Dann kannst du sie später immer noch in andere Verzeichnisse schieben.

weiter - oder wahlweise SEO-Index aufbauen und den richtigen Link “erraten” Wearing-Sunglasses 

@toric

Du hast Recht, es muss an dem Link liegen. Trotz der korrekten URl zeigt er die Startseite. 

Bei http://milchfilter.com/kostenlose-muster?c=8 funktioniert es, bei http://milchfilter.com/der-filter?c=11 nicht. Wie Du sehen kannst, hatte ich den Link bereits in den Footer (2. Spalte) kopiert und von dort genommen. Trotzdem klappt es nicht. Habe gerade nochmal die Kategorie gelöscht und neu angelegt aber das hat auch nichts gebracht… 

zugewiesene Gruppen der Seite “Der Filter” sind nur “Links” und “Unten (Spalte 2)”, also nicht “in Beabeitung”

mich verwirrt etwas, dass die Seiten inhaltlich fast gleich sind. Da fällt kaum auf, wenn man über zwei Links die gleiche Seite aufruft. Ich würde dir Empfehlen, zumindest eine Überschrift mit dem Kategorienamen vorübergehend einzubauen.

“Der Filter” muss einen Fehler in der URL haben, denn im Footer ist der Aufruf auch nicht richtig.

Cache schon geleert? Für alles weitere kenne ich  mich auch zu wenig aus.

Was mir sonst noch gelegentlich Probleme bereitet hat, sind gleiche Seitennamen/URL. Hast du Der Filter an mehreren Stellen verwendet oder bei SEO-URLs. Dann wird die SEO-URL nicht generiert und die Seite ist nur unter der “unschönen” aufrufbar. Versuch doch mal die Original-URL.

„Der Filter“ funktioniert ja nirgens! Und springt IMMER auf die Startseite *seltsam*

Generiere den SEO-Index neu und lösche den Cache bitte mal.

Naja, die Seiten sind ja unterschiedlich. Jetzt habe ich die Original-URL genommen (http://milchfilter.com/custom/index/sCustom/46) und die Seite wird korrekt angezeigt. Injkl. Überschrift und Text.
Wenn ich aber unter Link-Adresse “der-filter” eingebe, funktioniert es nicht. 

Danke auf jeden Fall schon mal sehr für Eure Hilfe. 

*Fehler* :wink:

Unter „Link-Adresse“ wird einfach ein Link auf eine (ggf. externe) andere Seite eingetragen - und kein alternativer Link. Wenn Du da etwas einträgst, ist das ein willkürlicher Link nach nirgendwo in Deinem Fall :wink:

Die „Langurl“ bekommst Du mit SEO-Index aufbauen und Cache Leeren weg - dann kommt später die SEO-Url

Ich bin ziemlich neu bei Shopware, wie generiere ich denn den SEO-Index neu? 

Einstellungen => Cache Performance => Tab “Einstellungen” => SEO
Dann werden erst die Kurz-URLs gebaut

1 Like

Großartig! Das war’s!!! Tausend Dank!!! Ich wußte gar nicht, dass unter Cashes / Performances noch eine Seite zu finden ist.

Tja, dann beschäftige ich mich jetzt mal mit dem Thema, wie ich das Menü links auf der Seite angepasst bekomme, da hatte toric ja schon was zu geschrieben. 
Ich nehme an, komplett entfernen kann ich das nicht so einfach?! Komisch jedenfalls, das da bei den eigenen Seiten “Der Filter” und “Kostenlose Muster” nicht die oberste Ebene angezeigt wird, obwohl sich die Kategorien in derselbene Ebene befinden, wie “Bestellen”.

Ich hatte nur geschrieben, dass es nicht passt. Eine Lösung hatte ich nicht gefunden - bin da kein Experte. Deshalb hab ich die Texte noch in den Einkaufswelten.

Da muss mit Sicherheit irgendwo im Template was geändert werden.

Für Kategorien könnte man es „ganz“ durch eine eigene listing/index.tpl rausschmeissen, wenn man den Block „{block name=‚frontend_index_content_left‘}“ leer überschreibt. Wie das geht => Devdocs / Doku  Wearing-Sunglasses

ABER: Das ganze Layout - inkl. Einkaufswelten - basiert auf der Breite mit der Sidebar. Wenn die Sidebar rausgeschmissen wird, wird die Contentbox zwangsweise breiter, und das ganze Layout könnte zerschossen werden. Ich würde - gerade Dir als Neuling - raten, das „Entfernen der Sidebar“ ganz weit nach hinten auf die ToTo-Liste zu verschieben. Wink