Shop lässt sich nicht Validieren

Hallo,

Ich möchte gerne einen neuen Shop Validieren. Eine HTML Datei sw-domain-hash.html und der angezeigte Schlüssel wurde im Shopware Hauptverzeichniss erstellt.

leider schlägt die registierung der Domain immer fehl.

Was kann ich tun ?

 

Bitte um Hilfe

Mit freundlichen Grüßen

Mathias Bischof

Kannst Du die Datei im Browser aufrufen?

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

ja das geht, kann den Link öffnen und der Schlüssel wird angezeigt

Ist das Shopware Hauptverzeichnis auch das DocumentRoot?

Sprich: Kannst du die Datei auch mit 

dein-shop.de aufrufen und NICHT dein-shop.de?

Viele Grüße

Gleiches Problem hier.

Anderswo gelesen, dass es Probleme mit dem SSL geben könnte, also auch das erst noch wieder deaktiviert… brachte hier aber nichts.

Validierung weiterhin nicht möglich. Der in dem Schritt vom System generierte Link zu der Datei ist exakt so aufrufbar und zeigt nur den vorgegebenen Hash.

@simkli schrieb:

Ist das Shopware Hauptverzeichnis auch das DocumentRoot?

Sprich: Kannst du die Datei auch mit 

dein-shop.de aufrufen und NICHT dein-shop.de?

Viele Grüße

Ja auch das geht…mehrmals probiert !

Leider bisher keine Domainreg. möglich :frowning:

 

@shopware‍ ich könnte meinen Testshop gestern auch nicht registrieren …

ein Umweg hat geklappt, in dem ich den Shop auf ohne www. Konfiguriert habe, dann hat es geklappt …

genau, die Registrierung ohne www funktioniert. 

@shopware‍ wieso funktioniert die Validierung mit www nicht ?

Zeigt die Domain mit www im DNS auf die korrekte IP? Gibt es irgendwelche Umleitungsregeln, die im Wege stehen?

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

@Maze schrieb:

genau, die Registrierung ohne www funktioniert. 

@shopware‍ wieso funktioniert die Validierung mit www nicht ?

Bevor Du wieso fragst, frage ob. 

die DNS ist bei beiden gleich.

Kann ich evtl. etwas in den Shopeinstellungen/Shops falsch gemacht haben ?

Host: www.domain.de

SSL Host: www.domain.de

Hostalias: www.domain.de, domain.de

SSL verwenden: Ja

überall SSL verwenden: JA

 

in meinen provider einstellungen ist die bevorzugte domain auf www. per HTTP-301-Weiterleitung eingestellt.

und eine Dauerhafte, für SEO geeignete 301-Weiterleitung von HTTP zu HTTPS für SSL

 

Wenn der SSL-Host identisch ist mit dem Host, muss er nicht eingetragen werden. Führe die Schritte der Varlidierung noch mal genau in Ruhe durch. Welche Fehlermeldung gibt es?

ok, habe jetzt bei SSL Host nichts mehr drin stehen. Leider bekomme ich immerwieder die Meldung „Domain konnte nicht verifiziert werden“

Habe direkt im Shopware Hauptverzeichniss die   sw-domain-hash.html mit dem dazugehörigen schlüssel erstellt. 

die www.domain.de/sw-domain-hash.html wird geöffnet und der schlüssel wird angezeigt

kann mir im moment den fehler nicht erklären :frowning:

Hast Du einen Passwortschutz davor?

@NextMike schrieb:

Hast Du einen Passwortschutz davor?

wovor ? welchen meinst du ? 

Ist www.domain.de/sw-domain-hash.html ohne Passwort erreichbar?

@NextMike schrieb:

Ist www.domain.de/sw-domain-hash.html ohne Passwort erreichbar?

ja, uneigeschränkt erreichbar !

wie gesagt, ohne www konnte ich ihn registrieren  

Kann es vielleicht etwas mit den Hostingeinstellungen des Providers zutun haben ?

 

Wenn ich zusätzlich die Domain per Shopware Backend reg. möchte erhalte ich folgende Meldung

Error

Domain konnte nicht verifiziert werden

Error code: DomainVerificationException-2

bla bla blub,

mir geht es auch so, habe www.zwilla.de registriert und validiert, nun möchte ich shop.zwilla.de noch als Shop hinzufügen und nichts geht.

Selbst die one file installation geht nicht und bricht mit dem fehler:

TypeError: e.srcElement is undefined[Weitere Informationen]  index.php:40:7317
    Ajax.prototype.onLoad http://shop.zwilla.de/index.php:40:7317
     self-hosted:947:17

ab.

Wahrscheinlich wie immer irgendwas mit den Rechten. Klar andere Sache aber das fängt schon wieder gut an.

Mal sehen wie ich den shop.zwilla.de nun doch registriert bekomme.

@Zwilla4 schrieb:

bla bla blub,

mir geht es auch so, habe www.zwilla.de registriert und validiert, nun möchte ich shop.zwilla.de noch als Shop hinzufügen und nichts geht.

Selbst die one file installation geht nicht und bricht mit dem fehler:

TypeError: e.srcElement is undefined[Weitere Informationen]  index.php:40:7317
    Ajax.prototype.onLoad http://shop.zwilla.de/index.php:40:7317
     self-hosted:947:17

ab.

Wahrscheinlich wie immer irgendwas mit den Rechten. Klar andere Sache aber das fängt schon wieder gut an.

Mal sehen wie ich den shop.zwilla.de nun doch registriert bekomme.

rechte ? ich versteh nur bahnhof… 

mir wäre es nur extrem wichtig das ich im moment an keine Premium Plugins rankomme :frowning: