Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitI

Hallo,

Domain auf Server A, SW auf sever B. Nach dem auslösen der Seite www.sa_sa_sa_sa.de kommt front zu sehen alles funktioniert nur sobald man etwas anklickt kommt

Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace

Wie bekomme ich das fertig ?

Auf den SW Server kann ich folgende Einstellungen verändern.

display_errors:

magic_quotes_gpc:

register_globals:

safe_mode:

oPcache:

Encodery PHP

ionCube:

phpShield:

Zend Optimizer/Zend Guard:

Dies Optionen kann ich direkt am Server an / aus einstellen ?!

Hab mal probiert aber ohne Erfolg

Kann jemand Helfen ?

 

Hast Du in Shopware den Host korrekt eingetragen?

Wann erfolgte die DNS Umstellung?

1 Like

@NextMike schrieb:

Hast Du in Shopware den Host korrekt eingetragen?

Denke Schon die Gleiche Adresse wir die Domain 

Wann erfolgte die DNS Umstellung?

So Ca. vor 30 Stunden

Kann es sein, daß Du im Shopware-Backend als Domain www.domain.de eingetragen hast, Deinen Webserver aber so konfiguriert hast, daß er auf domain.de (ohne www) umschreibt (oder umgekehrt)? Gleiches wäre auch mit http vs. https denkbar (Du hast Shopware so konfiguriert, daß der Zugriff immer über https erfolgen soll, aber Dein Webserver ist so konfiguriert, daß er auf http umschreibt).

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

1 Like

Ok, danke erstmal habe jetzt alles auf ohne WWW geschaltet es war tatsächlich etwas nicht richtig ,jetzt wollen wir mal abwarten.

Also alles ohne WWW.

 

So jetzt habe ich abgewartet leider ohne Erfolg.

Mit https habe ich nichts gemacht alles nur http

???

Also scheint Dein Problem wie im anderen Thread geschrieben doch nicht gelöst zu sein!? :slight_smile:
Lies nochmal den anderen Thread, dort sind ja etliche Lösungsmöglichkeiten gelistet.

1 Like

Hallo,

Probleme teilweise gelöst. :slight_smile:

Es lag an der Seite des Servers wo die SW liegt. Es war so eingestellt das die Zuweisung der Domain auf ganzen Hauptverzeichnis geleitet war, habe das auf die Zuweisung auf entsprechende Verzeichnisse geändert und es funktioniert.

Es lag also nicht an WWW vor den Domains.

Aber es sind jetzt noch zwei Fehler die ich bearbeiten muss.

A) Nach Eingabe der Adresse mit WWW davor oder ohne kommt https:// also als unsichere Seite.

Nach der Eingabe das ich doch die Seite besuchen möchte kommt funktioniert alles wunderbar.

Doch für den Kunden ist das nicht akzeptabel !!! Da muss ich noch etwas Arbeiten dran.

B) Wenn ich auf ein Artikel gehe und dann auf „Frage zum Artikel?“ kann ich das Formular ausfüllen doch nach dem ich auf senden klicke kommt UPS! Es ist ein Fehler… alle andere Formulare die ich versenden Möchte funktionieren.

Viellicht hat vor ab jemand einen kleinen Tipp ?!

Danke

Du hast nach wie vor ein Problem in Deiner vHost Config. Requests auf http sollten auf https umgeleitet werden, zum Beispiel mit folgendem mod_rewrite:

        ServerName www.domain.at:80
        ServerAlias www.domain.at ww.domain.at apobag.at

        RewriteEngine On
        RewriteRule ^/?(.*) https://www.domain.at/$1 [R,L]

 

1 Like

@Ichkannesnicht schrieb:

 

A) Nach Eingabe der Adresse mit WWW davor oder ohne kommt https:// also als unsichere Seite.

Nach der Eingabe das ich doch die Seite besuchen möchte kommt funktioniert alles wunderbar.

Doch für den Kunden ist das nicht akzeptabel !!! Da muss ich noch etwas Arbeiten dran.

Du benötigst ein “richtiges” SSL-Zertifikat (z.B. von Comodo, GeoTrust, Thawte, Globalsign, etc.). Momentan scheinst Du nur ein selbstsigniertes SSL-Zertifikat zu nutzen (oder es ist abgelaufen).

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

1 Like

Wobei ein selbstsigniertes Zertifikat kein Grund für einen Redirect ist…
Du kannst auch eines von letsencrypt.org nehmen - die sind kostenlos und mit dem Dienst für Linux auch sehr bequem.

1 Like

Hallo, habe eine Frage in der Programmierung gestellt aber da bekomme ich keine Antwort da versuche ich hier.

ok der Shop habe ich auf die Beine Gestellt und es funktioniert das Problem ist das er im Front sehr langsam ist.

Habe jetzt gelesen das die “optimizer_search_depth” Einstellung ca. 25% das ganze beschleunigt.

Ok, jezt habe ich geschaut und tat sächlich die ist bei mir auf 62 jetzt will ich die auf 0 setzen doch es geht nicht.

Ich logge mich in der Mysql ein setze alles so wie es soll doch der wert bleibt immer auf 62.

Ich vermute das diese Einstellung irgendwo in einem Script von SW zu ändern ist, oder ?!

der Hoster sagt, das er den Wert nicht ändern kann das es für alle Nutzer seines services wäre und ich soll ein extra serve mieten wo ich alles für mich einstellen kann.

Doch durch ändereung eines Scripts sollte das auch gehen?

Und wenn dann wo ???

optimizer_search_depth ist eine MySQL-Variable: MySQL :: MySQL 5.6 Reference Manual :: 5.1.7 Server System Variables

Wenn Du Deinen eigenen Server oder VServer hast, dann kannst Du die Einstellung selber ändern (z.B. in /etc/mysql/my.cnf auf Debian/Ubuntu); wenn Du ein Shared Hosting hast, dann hast Du wahrscheinlich Pech gehabt, weil Dein Hoster das kaum für Dich ändern wird (denn die Änderunge beträfe automatisch auch alle anderen Benutzer auf dem Server).

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

Danke , genau das segten die mir auch :frowning:

Danke

Wie kommst Du zu dem Schluss, dass dieser Parameter die Performance-Issues begründet? Es gibt ungefähr 500 Parameter, die die Performance beeinflussen können - das ist nur einer davon…

Ja, da der Shop nach aufrufen im Frontet erst mal paar sekunden brucht bis er normal läuft suchte ich nach eine geschwiendigkeit optimierung,

Da habe ich die Hinweise auf optimizer_search_depth und wollte mal damit anfangen ?!

 

Kann es sein, dass Dein Shop noch im Bearbeitungsmodus ist? Schau mal auf der ersten Seite des Moduls Cache/Performance

Hallo,

ne ist alles ok, Produktivmodus ist Aktiv hin und her geschaltet kein Unterschied.

 

HTTP-Cache aufgewärmt? 

Ein Tipp: Analysiere zuerst den Perfomance-Bottleneck bevor Du an irgendwelchen Parametern schraubst ohne zu wissen was Du genau tust und ob (in diesem Fall) überhaupt die Datenbank das Problem darstellt. So zerstörst Du mehr als es nützt - abgesehen davon, dass es reine Zeitverschwendung ist im Dunkeln um sich zu schlagen.