Probleme mit SSL Zertifikat

Ich habe bei 1blu einen Managed Server incl. einem SSL Zertifikat für eine Domain. Dieses möchte ich gerne in meinen Shop einbinden. Weis aber leider nicht was ich unter SSL Host und SSL Pfad eintragen soll. Ich hoffe mir kann jemand weiterhelfen. Gruß Marco g-lasertshop

Als Host und Pfad musst du hier eigentlich nichts eingeben. Das SSL Zertifikat muss Serverseitig für deine Domain installiert & aktiviert werden, sodass die Webseite entsprechend über dieses SSL Zertifikat geladen werden kann. In Shopware aktivierst du dann einfach nurnoch “SSL aktivieren” und ggf. “Überall SSL aktivieren”, sofern die komplette Seite über SSL laufen soll. Allerdings hast du ja einen Managed Server, 1blu sollte dir da also natürlich entsprechend weiterhelfen - Sonst wäre es ja kein Managed Server :wink:

Wenn Du Dich für die Option „Überall SSL aktivieren“ entscheidest, ist die Startseite trotzdem noch per http erreichbar. Um Duplicate Content zu vermeiden, würde ich an Deiner Stelle zusätzlich noch eine Rewrite Rule einbauen, die generell von http nach https umleitet - für nginx z.B. so: https://timmehosting.de/alle-http-urls- … s-umleiten

Kommt das in die .htaccess ? Wenn ja an welcher Stelle? Würde das gerne bei Shopware 5 machen…

Hallo,

nö, das aktivierst du unter Einstellungen > Grundeinstellungen > Shops. Den Haken bei überall SSL verwenden setzen. Fertig.

Bei Hostalias nicht vergessen die Domain mit und ohne www einzugeben. Also 2 Zeilen untereinander.

Natürlich musst du beim Provider vorher ein SSL Zertifikat bestellen und am Server installieren lassen.

Viele Grüße

Matthias

 

Ich habe eine Frage dazu.

Ich habe das Zertifikat beim Provider eingerichtet. Hab den Haken bei “überall” in den Einstellungen. Domains hab ich sowohl mit als auch ohne “www” eingetragen.

Dennoch wird in meinem Browser (Firefox) ein graues Schloß mit gelben Dreieck angezeigt. Nur im Warenkorb und beim Bezahlvorgang ist des Schloß grün. Was ja schon mal ganz gut ist.

Warum aber nicht im Rest des Shops?

An das Löschen des _ kompletten _ Caches brauche ich dich wahrscheinlich nicht erinnern, so lange wie du schon dabei bist.

Betrifft das die Startseite oder auch alle anderen Seiten die nicht verschlüsselt dargestellt werden.

Uwe

Cache löschen ist klar. Nur der Warenkorb und Kasse sind verschlüsselt. Alles andere nicht. Selbst der Kundenbereich ist nicht verschlüsselt.

Hast du in der .Htaccess noch irgendeine Umleitung drin?

Bist du noch mit Shopware4 unterwegst. Sende mir mal den Link zum Shop per PN

@exzess‍

bei dir ist alles verschlüsselt nur eben die Startseite nicht, wenn man diese normal aufruft, über den Home-Button ist dieser Aufruf schon verschlüsselt.

Die Startseite, also in deinem Fall Kategorie „Deutsch“ ist bei Shopware ein Sonderfall, wenn man von Außen her zugreift. Wie oben @TimmeHosting‍ schon schreibt musst du da in die .htaccess eine Umleitung ein bauen, da es dadurch auch „doppelten Content“ geben könnte, da der gleiche Inhalt über zwei Url’s erreicht werden kann.

Das Thema gab es schon einige mal hier im Forum doch mit der Suche im Forum ist kaum was finden.

Über die große Suchmaschine hatte ich das hier gefunden > http://community.shopware.com/_detail_1863.html 

Müsste dann Theoretisch das erste auf dieser Seite sein.

Wenn Sie alle eingehende HTTP Aufrufe direkt auf HTTPS umleiten wollen, so können Sie folgende allgemeine Regel nutzen:

  RewriteCond %{HTTPS} !=on RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Nachtrag:
dierer Code muss nach:

RewriteEngine on

eingefügt werden.

Uwe 

@useg schrieb:

@exzess‍

bei dir ist alles verschlüsselt nur eben die Startseite nicht, wenn man diese normal aufruft, über den Home-Button ist dieser Aufruf schon verschlüsselt.

Die Startseite, also in deinem Fall Kategorie “Deutsch” ist bei Shopware ein Sonderfall, wenn man von Außen her zugreift. Wie oben @TimmeHosting‍ schon schreibt musst du da in die .htaccess eine Umleitung ein bauen, da es dadurch auch “doppelten Content” geben könnte, da der gleiche Inhalt über zwei Url’s erreicht werden kann.

Das Thema gab es schon einige mal hier im Forum doch mit der Suche im Forum ist kaum was finden.

Über die große Suchmaschine hatte ich das hier gefunden > http://community.shopware.com/_detail_1863.html 

Müsste dann Theoretisch das erste auf dieser Seite sein.

Wenn Sie alle eingehende HTTP Aufrufe direkt auf HTTPS umleiten wollen, so können Sie folgende allgemeine Regel nutzen:

  RewriteCond %{HTTPS} !=on RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Nachtrag:
dierer Code muss nach:

RewriteEngine on

eingefügt werden.

Uwe 

Hatte das gleiche Problem, hab die htacces bearbeitet wie du es geschrieben hast Uwe, jedoch bekomme ich jetzt einen Umleitungsfehler:

Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.

    Wenn ich die 2 Zeilen von der htacces entferne klappt die Seite wieder, jedoch klappt SSL nicht wenn ich die Seite ohne https:// aufrufe.

 

Jemand eine lösung da ?