Plugin installieren/kaufen fehler - Error

Hallo, habe schon 2 Beträge dazu gefunden, aber die haben mir nicht weitergeholfen, deshalb schreibe ich selbst. Habe einen Shopware 5.0.1 Community Edition vor zwei Tagen aufsetzen lassen. Bei der Ersteinrichtung konnte ich wunderbar Plugins installieren. Heute wollte ich mir das Plugin “erweitertes Menü” kaufen, leider ohne Erfolg. Habe eine Shopware ID angelegt und auch meinen Shop verknüpft. Wenn ich im Backend auf “Jetzt Kaufen” klicke, kommt dieser Fehler: Error Auf dem SBP-Server ist ein Fehler aufgetreten. Error code: OrdersException-2 Wenn ich auf “Meine Einkäufe” klicke, kommt dieser Fehler: Error Der übergebene Referenz Shop konnte vom SBP-Server nicht ermittelt werden. Error code: PluginLicensesException-3 Und wenn ich links auf Account oder meinen angezeigten Namen klicke, dann kommt erneut das Login-Feld. Hat jemand ne Ahnung? Der Shop ist frisch installiert, ich hab noch fast nichts damit gemacht und auch der Anbieter ist auf Shopware spezialisiert, also denke ich nicht, dass es ein Serverseitiges Problem ist. Grüße,

Hallo, die Fehlermeldung deutet darauf hin, dass die Domain mit der du das Backend aufrufst nicht 1:1 die gleiche ist, die bei uns registriert ist. Am besten schaust du mal in deinen Shopware-Account (account.shopware.com) welche Domain dort registriert ist und rufst dann registriertedomain/backend auf. Wichtig ist wirklich, dass diese beiden Dinge (Backend-Domain und Browserzeile) übereinstimmen. Wenn du bspw. den Shop mit www. verwendest, dann muss bei uns auch www. registriert sein. Viele Grüße Moritz

oh wei, daran lag es… mit www eingetragen, ohne www aufgerufen… :wtf: Dankeschön! Noch eine Frage, habe im Account keine Bearbeitungsmöglichkeit gefunden und jetzt einen neuen Shop registriert, kann ich den anderen löschen? Des Weiteren erstelle ich den Shop jetzt erst einmal auf einer Dummy Domain und werde diesen erst in zwei Monaten umstellen, wie kann ich dann die Domain ändern oder muss ich dann wieder einen neuen Shop registrieren? Grüße und danke für die Hilfe

Hallo, das kannst du am besten beides bei unserem Vertrieb erfragen. Die Domain kann da gelöscht/geändert werden. Den genauen Ablauf kenne ich jetzt auch nicht, aber da sollte man dir weiterhelfen können: https://de.shopware.com/contacts Moritz

Hallo, ich grätsche hier mal rein, da es vielleicht ganz sinnvoll ist das Thema gebündelt zu haben. Ich habe das exakt gleiche Problem wie Shoppilein, und war tatsächlich AUCH mit der falschen URL im Shop eingeloggt. Leider beseitigt bei mir das Hinzufügen des “www” die Probleme nicht. Habe bereits mehrfach die registrierte Domain und die verwendete Backend-Domain verglichen, mich aus- und eingeloggt, einen anderen Browser verwendet, die Kundendaten nochmal neu gespeichert, überprüft ob die Shop-Version korrekt eingestellt ist etc… Das Problem bleibt. Auch hier betrifft das Ganze einen noch fast jungfräulichen Shop, es kann eigentlich nicht an irgendwelchen Änderungen oder Anpassungen liegen daher. Das Plugin um das es sich handelt ist das Migrations-Tool für die Migration von anderen Shopsystemen zu Shopware. Gibt es irgendwelche weiterführenden Tipps oder Dinge an denen das liegen kann? Wie gesagt, die Fehlermeldungen sind EXAKT die gleichen wie bei Shoppilein… Danke schonmal!

Der Vollständigkeit halber, falls jemand mittels Suchfunktion auf dieses Thema hier stößt: Wir haben das Problem selber in den Griff bekommen. Aber tatsächlich müssen drei Komponenten korrekt sein, und nicht wie oben in den Beiträgen geschrieben zwei. So ist es wichtig dass sowohl der Shopware-Account, die Shopeinstellung(!) und der Backend-Aufruf mit der richtigen Domain (also beispielsweise alles mit “www” vorne dran) aufgerufen bzw. konfiguriert wird. Die Shop-Einstellung findet man unter Einstellungen -> Grundeinstellungen -> Shopeinstellungen -> Shops. Hier hat bei unserem Shop das “www” beim Host-Eintrag gefehlt.

2 Likes