Paypal Plugin Problem

Wir nutzen die Shopware Version 5.4.6 und das Paypal Plugin Express 3.6.1. Seit einigen Tagen gehen die normalen Paypal Zahlungen nicht mehr. die Kunden klicken im Warenkorb auf zahlungspflichtig bestellen und werden nicht weitergelietet sondern diese Seite wird einfach neugeladen.

 

Der Paypal Ratenauf hingegen funktioniert einwandfrei.

 

Jemand eine Idee was hier der Fehler sein könnte?

Hallo Gronau,

wir haben exakt dieselbe Konstellation SW 5.4.6 und PP–Express Plugin 3.6.1. Bei uns funktioniert’s noch einwandfrei.

VG
spiro

Kling mir auch eher so, als ob da noch ein weiteres Plugin mit im Spiel ist. Vielleicht kannst du ja mal schauen was du zuletzt aktualisiert hast.

es wurde zwischendurch nichts aktualisiert. Es lief seit Mittwoch unter der Version 3.5.0 schon nicht weshalb ich das von Shopware vorgeschlagene Update des PLugins in Paypal Express vorgenommen habe. Dies hat auch nichts gebracht. In unserem 2. Shop ist die 3.5.0 noch installiert und alles funktioniert super (bis jetzt). Die Einstellungen sind identisch und es wurde zwischenzeitlich nichts gemacht.

wenn ich jetzt die 3 Paypal Plugins (Express, PLus und Ratenkauf) deaktiviere und das nuee Paypal Plugin für alle installieren will, kommt diese Fehlermeldung

 

An exception occurred while executing ‘INSERT INTO s_core_menu (name, onclick, class, controller, action, shortcut, position, active, pluginID, parent) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?)’ with params [“PayPal”, null, “sprite–paypal-unified”, null, null, null, 0, 1, 86, 65]: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry ‘PayPal-65’ for key ‘name’

 

Irgend eine Idee hierzu?

Wieso hast du überhaupt alle drei in deinem Shop? Bevor du das neue installierst, müssen die anderen beiden deinstalliert werden. Entweder du nutzt Paypal Plus + Paypal Express oder Paypal Unified. Wenn beides installiert ist, dann funktionieren die Zahlungen auch nicht.

bisher sind nur Paypal, Paypal Plus und Ratenkauf per Paypal installiert gewesen, mit denen es auch normal lief bis letzte Woche

Aber PayPal Plus ist nicht mit 5.5 kompatibel. Dafür gibt es das neue Plugin.

Es konnte gelöst werden. Danke trotzdem für die Hilfe

Hallo Gronau, im Sinne des Forum’s, wäre es evtl. hilfreich auch die Lösung zu nennen.

Wir haben das Paypal Express (altes Paypal Plugin) gelöscht und noch einmal neu installiert. Wahrscheinlich hat sich dann der Fehler gelöst und es funktioniert alles wieder (auch Paypal Plus)

1 Like

Hallo, 

Ist das alte PayPal Plugin sicher? bzw. gibt es in Sicherheitsplugin von Shopware auch Sicherheitsupdates für das alte PayPal Plus? 

Mit freundlichen Grüßen

 

Hallo kadis,

sollten uns Sicherheitsprobleme mit den “alten” PayPal Plugins bekannt werden, wird es natürlich hier noch Bugfixes geben. 

Viele Grüße aus Schöppingen

cool Michael Telgmann

1 Like