Paypal Express - Zusätzliche Adresszeilen werden nicht richtig übergeben (Packstation)

Hallo,

wir haben folgendes Problem mit dem PayPal PlugIn in Bezug auf PayPal Express. Leider funktioniert die Übergabe der Lieferadresse nicht richtig, wenn zusäzliche Adresszeilen verwendet werden. Unser Shop ist zur Zeit Offline, ich konnte das Problem aber auch bei anderen Shops reproduzieren. Z.B. hier: https://shop.bvb.de

  • Einzelnen Artikel in den Warenkorb übernehmen
  • Warenkorb anzeigen
  • Direkt zu PayPal (PayPal Express)

Ich habe bei Paypal zum Test 2 Lieferadressen hinterlegt.

PayPal:
Vorname Nachname
1234567
Packstation 119
12345 Stadt

Im Shop fehlt dann leider die Packstation:
Vorname Nachname
123456
12345 Stadt

 

PayPal:
Vorname Nachname
Packstation 119
1234567
12345 Stadt

Im Shop fehlt hier die Kundennummer:
Vorname Nachname
Packstation 119
12345 Stadt

 

Gibt es für dieses Problem eine Lösung oder einen Workaround?

Hallo,

laut DHL und Post gehört die Postnummer nicht in zusätzliche Adresszeilen, sondern in das Firmenfeld!

@drakon schrieb:

Hallo,

laut DHL und Post gehört die Postnummer nicht in zusätzliche Adresszeilen, sondern in das Firmenfeld!

Hallo drakon,

danke für die Information. Bei Paypal gibt es kein Firmenfeld sondern nur ein Feld, in der man eine zusätzliche Information (additional Information) eintragen könnte. Es würde ja schon ausreichen, wenn Shopware diese Zeile als Firmenzeile übernehmen würde. Leider geht diese aber komplett verloren

 

Hallo,

keine Ahnung wie das dann bei uns übergeben wird. Wi habne nur in Ausnahmefällen keine Postnummer dabei.

Habt Ihr das VIISON Packstations-Plugin installiert? Evtl. wäre das hilfreich.

Hallo drakon,

der Shop, der in Deinem Benutzerprofil hinterlegt ist, hat das Problem ebenfalls.

Mich wundert nur dass das Problem mit der nicht übertragenen Zeile bei Paypal Express sonst nicht groß auffällt. Das Packstation PlugIn wird uns nicht helfen, da die Situation bei Packstationen nur ein Beispiel war. Wir haben auch Probleme bei Zustellung an Firmen, da die Zeile wie gesagt immer fehlt.

Hallo,

wenn ihr der Testkunde gestern wart, dann kann ich das Problem nicht ganz verstehen. Die Postnummer ist in der Straße gelandet, da ist sie noch nie von irgend einem anderen  Kunden gelandet. Da gehört die Bezeichnung Postfiliale oder Packstation hin. Die Nummer fehlte auch. Zum anderen hattet ihr noch GLS als Versand eingestellt. Per GLS ist der Versand an Packstationen aber sowieso ausgeschlossen, daher muss das an der Stelle auch nicht funktionieren. Bitte zuerst DHL auswählen, dann dort korrekt die Packstation auswählen. Dann funktioniert das auch.

Komisch, dass meine sonstigen Kunden das zu > 99 % hinbekommen, auch und gerade mit dem gerne verwendeten PP Express.

Ich glaube nicht, daß Deine hinterlegten Daten so stimmen.

Im Übrigen gehört die Packstation nur in die Lieferadresse und nicht in den Kundenaccount. Kunden, die keine ladungsfähige Adresse hinterlegen, beliefere ich aus rechtlichen Gründen in aller Regel nicht. Man kann keinen gültigen Kaufvertrag mit einer Packstation abschließen.

Ich habe mir das gerade mal angesehen. Das funktioniert anscheinend aktuell nicht. Die zusätzliche Adress-Zeile wird nicht im zusätzlichen Adressfeld1 gespeichert. Hier wird das gemacht: SwagPaymentPaypal/PaymentPaypal.php at 4541be18b7f8ff3fcd43ed5a46040a78539c45a7 · shopwareLabs/SwagPaymentPaypal · GitHub

Die Daten kommen korrekt von Paypal und werden auch an SW übergeben, nur wohl irgendwie falsch weggespeichert. Hab mal ein Ticket angelegt: Shopware Issuetracker

 

1 Like

Hab einen Pull-Request gemacht, der das fixt: Fix-Issues-With-Missing-Addional-Address-Line by mnaczenski · Pull Request #12 · shopwareLabs/SwagPaymentPaypal · GitHub

1 Like

@Moritz Naczenski schrieb:

Hab einen Pull-Request gemacht, der das fixt: https://github.com/shopwareLabs/SwagPaymentPaypal/pull/12/files

Hallo Moritz,

das ging ja schnell. Vielen Dank!!

Gruß Christian

Ich habe das Gleiche Problem nun mit dem neuen SwagPaymentPayPalUnified Plugin. Geht es irgendjemandem ähnlich, bzw. hat jemand eine Idee? Es wird Shopware Version 5.5.6 verwendet.

Viele Grüße
Mario