Paypal Checkout Plugin 4.3.2 und 4.3.3 Abbrüche

Vorteil vom Abschalten von Express: die Zahlungsarten werden wieder vielfältiger und die Kosten gehen runter.

Hallo @Lucas_Werth

die Fehlermeldung sagt leider nicht viel aus. Kannst du den Fehler denn nachstellen?

Viele Grüße aus Schöppingen
Michael Telgmann

@Michael_Telgmann Der Fehler konnte nachgestellt werden, indem man eine Paypalzahlung iniziiert hat.
Die Weiterleitung vom Warenkorb zu Paypal hat normal geklappt. Wenn man dann aber per Paypal den Kauf abschließen will, dann wurde man zu den Zahlungsarten zurückgekickt und hat die Fehlermeldung „Keine Kommunikation zu Paypal möglich“ bekommen.

Da wir damit sehr viele Verkäufe einbüßen würden, haben wir eine ältere Paypal-Version (4.2.3) installiert. Die funktioniert.

Könntest du dich dafür mal beim Support melden? Dann können wir uns das mal anschauen. Weil aus dem Weg, den du beschreibst, kann ich jetzt keine Besonderheit erkennen, die zu einem Fehler führt.

Klar. Mache gleich ein Ticket auf.

@Michael_Telgmann meinst du den Shopware oder Paypal Support? Da wir die Community Version nutzen, komme ich bei SW nicht weiter durch.

ich meine ein Support Ticket bei uns. Ich schätze, dass PayPal dir da nicht weiterhelfen kann, bzw. auf uns verweist :slightly_smiling_face:

Leider kann ich kein Support Ticket zu diesem Thema eröffnen, da wir die Community-Version von SW haben.

dann musst du uns hier mehr Informationen zur Verfügung stellen, damit wir dir helfen können. Weil ein normaler Checkout mit PayPal funktioniert bei mir ohne Probleme.

Ich habe das gleiche Verhalten auch in mehreren Shops festgestellt. Es tritt, soweit ich das sehe, nur bei PayPal Express-Kauf auf.
Am Ende wird man von der Confirm-Seite wieder zurück auf die Zahlarten-Seite geschickt und der besagte Fehler taucht im Log auf und wenn ich mir so die Anzahl anschaue, betrifft es jeden Kunden.

1 Like

schon mal den Thread durchgelesen?

Same here. Auch die 404er Fehlermeldung mit Landung auf der Zahlart-Seite!

Hallo,
wir haben das selbe Problem mit dem Plugin 4.3.3 in SW5 V 5.7.14:

PayPal: Could not get PayPal order due to a communication failure

{
„message“: „Client error: GET https://api.paypal.com/v2/checkout/orders/ resulted in a 404 Not Found response“,
„payload“: „“
}

Ich möchte aber nicht auf eine ältere PlugIn-Version zurückgreifen.
Der Tech-Support von Paypal verweist uns auf Shopware.

Nadem wir den PayPal Expresskauf bereits seit Wochen ausgeschaltet haben trat der 422er Fehler nun auch mit Sofortüberweisung auf.
SW 5.7.7, PayPal 4.3.2

Kunde hat versucht per Desktop PC unter Windows mit Sofortüberweisung zu bestellen. Der Artikel hatte Versandkosten.
Kunde wurde zur Zahlungsabwicklung von Sofort geleitet, hat dort seine Banking Pin eingeben und wurde anschließend mit Fehlermeldung zurück auf die Zahlartenseite geleitet. Dort hat er erneut Sofort ausgewählt, zum 2. Mal seine Pin eingegeben, Bestellung konnte aber dennoch nicht erfolgreich abgeschlossen werden.
Uns liegt also keine Bestellung vor. Geld wurde vom Konto des Kunden jedoch abgebucht. Wir hatten das mehrfach und aus Erfahrung wird das Geld automatisch nach einiger Zeit wieder dem Konto des Kunden gutgeschrieben. Dennoch sehr frustrierend.
Wir werden daher vorerst auch Sofort deaktivieren bis das Plugin stabil funktioniert. Hoffe das geschieht zeitnah…

Ich bin mir bewußt, dass das Problem bekannt ist, daher Poste ich diesen Bericht hier nur für die Statistik :slight_smile:

Log-Eintrag dazu:
{
„message“: „Client error: POST https://api.paypal.com/v2/checkout/orders/xxxxxxxxx/capture resulted in a 422 Unprocessable Entity response:\n{"name":"UNPROCESSABLE_ENTITY","details":[{"issue":"ORDER_NOT_APPROVED","description":"Payer has not yet approved the Or (truncated…)\n“,
„payload“: "{"name":"UNPROCESSABLE_ENTITY","details":[{"issue":"ORDER_NOT_APPROVED","description":"Payer has not yet approved the Order for payment. Please redirect the payer to the ‚rel‘:‚approve‘ url returned as part of the HATEOAS links within the Create Order call or provide a valid payment_source in the request."}],"message":"The requested action could not be performed, semantically incorrect, or failed business validation.","debug_id":"xxxxxxxxxx","links"…
}

Neuester Bug: Paypal 4.3.3 (NICHT Express) löscht das vom Kunden angefüllte Kommentarfeld.

Was ist denn da los? Es reicht jetzt wirklich, ist ja eine Frechheit. Kunde schreiben Sachen rein und bei Bestellung geht alles raus. Wieder zurück auf 4.2.3.

Jetzt kann ich allen Kunden die Ware, die per Paypal bezahlt wurde und nicht so gefertigt wurde wie sich der Kunde das gewünscht hat, auf meine Kosten zurücknehmen und auf meine Kosten wieder raussenden. Auch wenn das bei 4.3.3 als korrigiert vermerkt ist, es ist NICHT korrigiert.

1 Like

Hallo Steffffi,

ich habe gerade versucht, das Problem nachzustellen. Leider ohne Erfolg. Sowohl mit der aktuellen als auch deiner oben angegebenen Shopware Version 5.6.10.

Um das Problem zu beheben, müssen wir es nachstellen. Kannst du uns vllt. eine kleine step by step Anleitung geben wie das Problem bei dir zustande kommt?

LG

Dennis Garding

Naja, ganz einfach unterm Strich: Bestellung, Kommentarfeld Eingabe, Paypal Normal, fertig. Bei 4.3.3 kommt kein Kommentar an, bei 4.3.2. schon. Das 4.3.3 Update wurde am 01.09. eingespielt. Da September mau im Verkauf war fiel das auch nicht auf. Am 24.08. mit 4.3.2 war es noch in Ordnung,alles mit Original Kommentarfeld von Shopware.

Hier ein Screenshot: oben ist mit 4.3.2 und unten mit 4.3.3

image

Bei allen anderen Zahlungsarten kommt das Kommentar an. Express ist aus da das sowieso schon lange nicht mehr verlässlich funktioniert.

Am besten würde wohl sein, auf 3.2 zurückzugehen, was wohl nicht mehr so ohne weiteres geht.

Seit März seit v4 ist die Bezahlung mit Paypal nur mehr ein Glücksspiel im Versionskarusell. Ein unzumutbarer Zustand.

Hmm… also irgendwas scheint bei dir Verschwurbelt… Ab 4.3.3 wurden die Kommentare erst berücksichtigt. Es sei denn du nutzt noch PayPalPlus. Oder es gibt ein Drittanbieter-Plugin was dort eingreift.

Im PayPal Checkout dürften die Kommentare nicht gepeichert worden sein, da diese nicht berücksichtigt wurden.

Die Kommentare kamen bei 4.2.3 immer rein.

image

Ab 01.09. (Update 4.3.3) nicht mehr. Die 2 obigen sind wieder mit 4.2.3 (nicht 4.3.2!).

image

Lt. Bugtracker gab es da Probleme ab 4.3.0.

image

Das dürfte wohl noch nicht so ganz hinhauen. Das Kommentarfeld wurde von einem Plugin (Bestellkommentar LENZ) genommen da Leute wohl immer in die Artikelnummer Tabelle was reingeschrieben haben. Daher habe ich das ganze jetzt extra nochmals mit der Kommentarfunktion von Shopware (Storefront, Weitere Optionen…) getestet. Ergebnis ist gleich: mit 4.2.3 kommen die Kommentare mit, mit 4.3.3 nicht. Alles, was NICHT Paypal ist, klappt sowieso immer.

PS: Patches 26662 und 26666 sind auf Nein, also nicht aktiv.

Mit der aktuellsten Shopware & Paypal Version sollten keine Probleme auftreten. Zuviele Bezahlplugins können jedoch Fehler verursachen.

Wenn Paypal das Kommentarfeld löscht und NUR Paypal, dann ist wohl die Fehlerquelle eindeutig. Und wenn sich noch dazu das Verhalten von Pluginversion auf Pluginversion unterscheidet dann sind es wohl auch nicht „zuviel“ Bezahlplugins, die da wären: Rechnung, Vorkasse, Paypal und Stripe.