Paypal 2.1.7

Hi, nach dem Update von Paypal bekomme ich im Warenkorb einen Fehler: Unable to load template snippet ‚frontend/checkout/cart.tpl|frontend/plugins/seo/index.tpl|frontend/plugins/advanced_menu/index.tpl|frontend/payment_paypal/header.tpl‘ in Smarty/sysplugins/smarty_internal_templatebase.php on line 127 Nach einiger Recherche musste ich feststellen das es die datei payment_paypal/header.tpl gar nicht gibt. /shopware41/templates$ ll */frontend/payment_paypal/header.tpl ls: cannot access */frontend/payment_paypal/header.tpl: No such file or directory ll ./engine/Shopware/Plugins/Default/Frontend/SwagPaymentPaypal/Views/frontend/payment_paypal/ total 32 drwxr-xr-x 2 xx users 4096 Sep 16 14:53 . drwxr-xr-x 4 xx users 4096 Sep 16 14:53 … -rw-r–r-- 1 xx users 874 Sep 16 14:53 cancel.tpl -rw-r–r-- 1 xx users 258 Sep 16 14:53 express.tpl -rw-r–r-- 1 xx users 861 Sep 16 14:53 gateway.tpl -rw-r–r-- 1 xx users 293 Sep 16 14:53 layer.tpl -rw-r–r-- 1 xx users 628 Sep 16 14:53 logo.tpl -rw-r–r-- 1 xx users 1493 Sep 16 14:53 return.tpl

Hallo, ggf. hängen die irgendwo alte Informationen. Wurde das Plugin einmal deinstalliert und erneut installiert? Sebastian

Ich habe es mehrfach neu installiert, der apc cache ist auch deaktiviert/mehrfach geleert worden

Ich habe den Fehler gefunden: $ find . -name '\*paypal\*' ./engine/Shopware/Plugins/Default/Frontend/SwagPaymentPaypal/Snippets/backend/payment\_paypal ./engine/Shopware/Plugins/Default/Frontend/SwagPaymentPaypal/Views/backend/payment\_paypal ./engine/Shopware/Plugins/Default/Frontend/SwagPaymentPaypal/Views/frontend/\_resources/images/paypal ./engine/Shopware/Plugins/Default/Frontend/SwagPaymentPaypal/Views/frontend/payment\_paypal ./engine/Shopware/Plugins/Community/Frontend/SwagPaymentPaypal/Snippets/backend/payment\_paypal ./engine/Shopware/Plugins/Community/Frontend/SwagPaymentPaypal/Views/backend/payment\_paypal ./engine/Shopware/Plugins/Community/Frontend/SwagPaymentPaypal/Views/frontend/\_resources/images/paypal ./engine/Shopware/Plugins/Community/Frontend/SwagPaymentPaypal/Views/frontend/\_resources/styles/paypal.css ./engine/Shopware/Plugins/Community/Frontend/SwagPaymentPaypal/Views/frontend/payment\_paypal Im Default gibt es kein header.tpl, im community schon. BTW: 1. Warum ist im Paypal Plugin alles voller /__MACOSX/ Ordner? 2. Swag ist eine echt merkwürdiges Firmenkürzel, Yolo :slight_smile: [Edit] Ein manuelles Löschen des Default Plugins hat keine Besserung gebracht, Erfolg hatte ich nachdem ich das Plugin aus Community in Default kopiert habe.

hallo, ich wollte gerne mal mein problem schildern und hoffe es kann mir vielleicht jemand einen tipp geben? nach der installation des paypal plugin 2.1.7 versuche ich dieses in shopware zu aktivieren (4.1.4) und bekomme die fehlermeldung: Fatal error: Call to a member function setActive() on a non-object in /var/www/vhosts/bambus-parkett24.de/httpdocs/engine/Shopware/Plugins/Community/Frontend/SwagPaymentPaypal/Bootstrap.php on line 198 503 Service Unavailable Fatal error: Undefined class constant ‘PRIMARY_TYPE_NUM’ in /var/www/vhosts/bambus-parkett24.de/httpdocs/engine/Library/Zend/Session/SaveHandler/DbTable.php on line 522 503 - Service Unavailable kann mir jemand vielleicht einen tipp geben woran das leigen könnte ? merci, markus

… habe durch probieren herausgefunden: 1. paypal plugin aktivieren ohne schon die paypal daten einzutragen. 2. die paypal verbindungsdaten eintragen dann geht es. zuvor hatte ich beides in einem schritt direkt nach der installation versucht, was nicht ging, s.o. vg markus

1 Like

Ich bestätige gerne nochmal die genante Lösung, auch in aktueller Version. Installieren, aktivieren und ERST DANN die Daten füllen.