Neue Pluginstruktur ab Shopware 5.2 unter Windows

Liebes Forum :slight_smile: :slight_smile:

Ich habe ein Plugins im neuen 5.2 Format und Templatedateien ├╝beschrieben uns Less und JavaScript eingebunden. Klappt auf dem Server.

Aber nicht auf localhost (windows 7 / xampp). Es werden die Temlatedateien nicht eingebunden.

Beispiel:

 'onFrontendPostDispatchBlog'
        ];
    }
    public function onFrontendPostDispatchBlog(\Enlight_Controller_ActionEventArgs $args)
    {
        $this->container->get('template')->addTemplateDir(
        $this->getPath() . '/Resources/views/'
        );
    }
}

Ist das so, dass das mit windows bzw xampp nicht funktioniert oder mache ich was falsch ?

Liebe Gr├╝├če

Kerstin

Hallo,

ich w├╝rde da mal Gro├č- und Kleinschreibung der Ordnernamen penibel ├╝berpr├╝fen, damit das auch 100% mit dem Code ├╝bereinstimmt. Was f├╝r ein Betriebssytem l├Ąuft denn auf dem Server?

Hast Du unter XAMPP unter Windows auch die n├Âtigen Ordnerzugriffsrechte? Auch das k├Ânnte ein Problem sein. Eventuell mal das XAMPP Control Panel als Administrator ausf├╝hren.

 

Was passiert wenn du im Backend den Shop Cache leerst? Geht das fehlerfrei?

 

 

MFG

 

derwunner

Danke.

Auf dem Server l├Ąuft Linux. Reagiert ja eigentlich empfindlicher auf Gro├č/kleinschreibung. Habs aber nochmal gepr├╝ft.

Habe auch Xampp mit Administratorenrechten getartet.Hilft leider nicht.

Cache Leeren geht fehlerfrei.

Eigentlich funktioniert alles auch unter windows, nur das nicht.

Geht das denn ├╝berhaupt normalerweise unter windows/xamp ?