Nach Zahlung weißes Bild

Hallo, mein Name ist Thomas. Ich hbae vor kurzem auf SW5 upgedatet und alles läuft derzeit sehr gut. Bis auf das Heidelpay CE Plugin, nach BEstellabschluss kommt eine weisse Seite und man wird nicht weitergeleitet zu Danke für ihre Bestellung. Hatte schon mit Server Hoster und Heidelpay Kontakt, jedoch konnte mir keiner der beiden weiterhelfen. Lt. Heidelpay ist es ein HTTP Fehler und lt. Server Hoster ist es ein Plugin Fehler. In der Browser Url der weißen Seite steht https://shop.spielbrett.biz/PaymentHgw/ … 0&__shop=1 Kennt sich hier evtl. wer aus damit??? Bitte und Danke lg

Wir testen zurzeit ebenfalls das CE Plugin für einen unserer Kunden, wo wir derzeit einen Shop auf Basis von Shopware 5 programmieren. Das Plugin funktioniert so einwandfrei. Wir hatten hier lediglich den gleichen Fehler wie bei dir mit dem .htaccess Schutz, welchen wir vor der Seite hatten. Außerdem noch, wo wir eine Seite vor den Shop geschaltet haben, sodass die Seite nur zugänglich ist, wenn ein Cookie gesetzt ist. Allerdings ist beides bei euch nicht der Fall … welche Version setzt Ihr ein ? Habt Ihr evtl. einmal das Plugin durch Heidelpay konfigurieren lassen ? Eine weiße Seite deutet hier eigentlich eher darauf hin, dass das Plugin die Response nicht verarbeiten kann aufgrund A) Eines Server Problems / Konfigurations Fehler oder B) wie ich oben beschrieben habe

Hi Also Shopware Vers. 5.0 und Heidelpay CE Vers. 15.5.4 lg

Also wir haben hier Heidelpay 15.04.28 Evtl. einmal das Plugin updaten. *EDIT* Quatsch - Wir sollten mal updaten :smiley: Also bei uns funktioniert es ohne Probleme soweit.

Ich habe denn Shop in einem unterverzeichnis /shop laufen. Also habe ich eine redirect 301 .htaccess am server der auf den unterordner weiterleitet. Kann hier ein Fehler liegen, hat aber bis jetzt problemlos funktioniert. lg

Wenn ich altes Orange_Emotion Template aktiviere funktioniert das Heidelpaa Plugin mit dem REdirect im Checkout normal… O man, Heidelpay sagt es ist der Server, Server sagt es das Plugin… Arghhh^^

Hat denn Heidelpay keinen error log ? Sagt ansonsten der Server error log was dazu ?

Domain Factory sagt sie können keinen Fehler im Log festellen! Heidelpay sagt Der Server macht einen HTTP ERROR 503. Aber wenn ich das Orange Emotion aktiviere funktionierts, nur beim neuen Responsive Theme nicht, sehr eigenartig. lg

Nur um das ganze hier nochmal für alle festzuhalten, das Problem entstand durch ein Drittanbieter Plugin welches folgende Fehlermeldung erzeugt hat: [2015-05-13 15:07:03] core.ERROR: exception 'SmartyException' with message 'Unable to load template snippet 'frontend/payment\_hgw/response.tpl | frontend/plugins/advanced\_menu/index.tpl | ... Das Plugin wurde vorübergehend deaktiviert. Mit freundlichen Grüßen Andreas Nemet Plug-In Developer Heidelberger Payment GmbH

Weiter suchen… Plugins sind es wohl eher nicht…

Irgendwie scheint es auf alle Fälle mit der Belegserstellung zu tun zu haben.

Ok Problem doch nicht gelöst… Es kommt doch weißes Bild nach Zahlung und dieser Log Error exception ‚SmartyException‘ with message ‚Unable to load template snippet ‚frontend/payment_hgw/response.tpl|frontend/plugins/advanced_menu/index.tpl|frontend/plugins/seo/index.tpl|frontend/plugins/paymentfooter/paymenticons.tpl‘‘ in /kunden/416156_4891/shop/engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php:127 Stack trace: #0 /kunden/416156_4891/shop/engine/Library/Enlight/View/Default.php(274): Smarty_Internal_TemplateBase->fetch() #1 /kunden/416156_4891/shop/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(216): Enlight_View_Default->render(Object(Enlight_Template_Default)) #2 /kunden/416156_4891/shop/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(242): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->renderTemplate(Object(Enlight_Template_Default)) #3 /kunden/416156_4891/shop/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(136): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->render() #4 [internal function]: Enlight_Controller_Plugins_ViewRenderer_Bootstrap->onPostDispatch(Object(Enlight_Controller_ActionEventArgs)) #5 /kunden/416156_4891/shop/engine/Library/Enlight/Event/Handler/Default.php(91): call_user_func(Array, Object(Enlight_Controller_ActionEventArgs)) #6 /kunden/416156_4891/shop/engine/Library/Enlight/Event/EventManager.php(211): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs)) #7 /kunden/416156_4891/shop/engine/Library/Enlight/Controller/Action.php(202): Enlight_Event_EventManager->notify(‚Enlight_Control…‘, Object(Enlight_Controller_ActionEventArgs)) #8 /kunden/416156_4891/shop/engine/Library/Enlight/Controller/Dispatcher/Default.php(524): Enlight_Controller_Action->dispatch(‚responseAction‘) #9 /kunden/416156_4891/shop/engine/Library/Enlight/Controller/Front.php(227): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #10 /kunden/416156_4891/shop/engine/Shopware/Kernel.php(143): Enlight_Controller_Front->dispatch() #11 /kunden/416156_4891/shop/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(490): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #12 /kunden/416156_4891/shop/engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #13 /kunden/416156_4891/shop/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(261): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #14 /kunden/416156_4891/shop/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(278): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #15 /kunden/416156_4891/shop/engine/Shopware/Components/HttpCache/AppCache.php(133): Symfony\Component\HttpKernel\HttpCache\HttpCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #16 /kunden/416156_4891/shop/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(207): Shopware\Components\HttpCache\AppCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #17 /kunden/416156_4891/shop/engine/Shopware/Components/HttpCache/AppCache.php(114): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #18 /kunden/416156_4891/shop/shopware.php(101): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #19 {main}

Wir haben das Problem lokalisiert. Es lag daran, dass nach der saveOrder, nochmals versucht wurde das Template unserer ResponseAction zu rendern. Wir unterbinden das ganze aber der nächsten Modulversion (15.06.X) mit einem simplen: Shopware()-\>Plugins()-\>Controller()-\>ViewRenderer()-\>setNoRender(); Mit freundlichen Grüßen Andreas Nemet Plug-In Developer Heidelberger Payment GmbH

Der Thread ist zwar schon etwas älter, aber da wir gerade im Shop das gleiche Problem haben, schreibe ich jetzt hier anstatt einen neuen Thread zu eröffnen. Unser Shop ist in der Version 5.0.4 und das Plugin „Heidelpay CD Edition“ liegt aktuell in der Version 15.11.02 vor. Die Testdaten habe ich alle (wie in der Anleitung angegeben) im Plugin hinterlegt. Aber nach der Eingabe der Kreditkartendaten (auch aus der Anleitung) wird nur eine weiße Seite angezeigt. Hat vielleicht noch jemand diesen Fehler oder eine Idee, wie dieser behoben werden kann? Auch beim Wechsel auf das Responsive-Theme oder ein älteres Template tritt der Fehler auf. Den Cache habe ich dabei immer vollständig geleert und den Theme-Cache ggf. neu erstellen lassen. Vielen Dank im Voraus Leiv Bergmann

Das Problem in unserem Shop hat sich inzwischen gelöscht. Wir hatten dort noch den Wartungsmodus aktiviert, dadurch war es nicht möglich eine Response zum Shopsystem durchzuführen. Danke an den Heidelpay-Support, die schnell reagiert haben.

2 Likes