Nach Theme-Änderung (Von Custom Theme zum Standart) funktionieren Plugins nicht

Hey, ich habe eben von einem Custom-Theme zum Standart (bzw. meinem Theme welches 99% das Standart-Responsive Theme ist) gewechselt, und alle Plugins sind noch aktiviert, SIe funktionieren aber nicht. Das erweiterte Menü poppt nicht, und der Cookie-Hinweis kommt auch nicht (“Notification” - Plugin). Woran könnte das liegen? Habe den Cache geleert…

SW Hilfe:

  • Devtools deines Browsers nutzen

  • Browser F12 (Entwicklerwerkzeuge) nach Fehlerausgaben schauen

  • Fehlermeldungen in Shopware debuggen und untersuchen
    http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen_detail_1880.html

  • Fehlermeldungen in error_log auf Server untersuchen (mögliche PHP-Fehler)
    Bitte nicht mit Shopware Log verwechseln. Liegt meist außerhalb vom httpdocs-Order der Domain - ggf. beim Hoster anfragen.

 

@R4M schrieb:

SW Hilfe:

  • Devtools deines Browsers nutzen

  • Browser F12 (Entwicklerwerkzeuge) nach Fehlerausgaben schauen

  • Fehlermeldungen in Shopware debuggen und untersuchen
    http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen_detail_1880.html

  • Fehlermeldungen in error_log auf Server untersuchen (mögliche PHP-Fehler)
    Bitte nicht mit Shopware Log verwechseln. Liegt meist außerhalb vom httpdocs-Order der Domain - ggf. beim Hoster anfragen.

 

Es existiert keine error.log Datei auf dem Server (oder wo finde ich die sonst? Per FTP nachgeschauen). Die Konsole ist immer das erste, was ich mir anschaue. Da sind nur 615 logs, aber keine Fehler oder Warnungen, wenn ich die Logs unsichtbar schalte ist da also alles clear. Im Production-log der ein mal täglich erstellt wird (oder meintest du das mit error_log? ) steht folgender Error:

 

[2019-08-01 09:33:40] core.CRITICAL: Invalid compiled template for 'backend/base/bootstrap.js' [] {"uid":"5fd9b07"}
[2019-08-01 09:33:40] core.CRITICAL: Invalid compiled template for 'backend/base/bootstrap.js' [] {"uid":"5fd9b07"}
[2019-08-01 09:33:40] core.ERROR: exception 'SmartyException' with message 'Invalid compiled template for 'backend/base/bootstrap.js'' in /html/tom/shop/engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php:174 Stack trace: #0 /html/tom/shop/engine/Library/Enlight/View/Default.php(300): Smarty_Internal_TemplateBase->fetch() #1 /html/tom/shop/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(216): Enlight_View_Default->render(Object(Enlight_Template_Default)) #2 /html/tom/shop/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(242): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->renderTemplate(Object(Enlight_Template_Default)) #3 /html/tom/shop/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(136): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->render() #4 (internal function): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->onPostDispatch(Object(Enlight_Controller_ActionEventArgs)) #5 /html/tom/shop/engine/Library/Enlight/Event/Handler/Default.php(91): call_user_func(Array, Object(Enlight_Controller_ActionEventArgs)) #6 /html/tom/shop/custom/plugins/FroshProfiler/Components/Event/EventManager.php(296): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs)) #7 /html/tom/shop/custom/plugins/FroshProfiler/Components/Event/EventManager.php(84): FroshProfiler\Components\Event\EventManager->parentNotify('Enlight_Control...', Object(Enlight_Controller_ActionEventArgs)) #8 /html/tom/shop/engine/Library/Enlight/Controller/Action.php(235): FroshProfiler\Components\Event\EventManager->notify('Enlight_Control...', Object(Enlight_Controller_ActionEventArgs)) #9 /html/tom/shop/engine/Library/Enlight/Controller/Dispatcher/Default.php(563): Enlight_Controller_Action->dispatch('indexAction') #10 /html/tom/shop/engine/Library/Enlight/Controller/Front.php(222): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #11 /html/tom/shop/engine/Shopware/Kernel.php(202): Enlight_Controller_Front->dispatch() #12 /html/tom/shop/vendor/symfony/http-kernel/HttpCache/SubRequestHandler.php(102): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #13 /html/tom/shop/vendor/symfony/http-kernel/HttpCache/HttpCache.php(448): Symfony\Component\HttpKernel\HttpCache\SubRequestHandler::handle(Object(Shopware\Kernel), Object(Symfony\Component\HttpFoundation\Request), 1, true) #14 /html/tom/shop/engine/Shopware/Components/HttpCache/AppCache.php(260): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #15 /html/tom/shop/vendor/symfony/http-kernel/HttpCache/HttpCache.php(238): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #16 /html/tom/shop/engine/Shopware/Components/HttpCache/AppCache.php(105): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #17 /html/tom/shop/shopware.php(122): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #18 {main} [] {"uid":"5fd9b07"}

 

@MrHappy schrieb:

@R4M schrieb:

SW Hilfe:

  • Devtools deines Browsers nutzen

  • Browser F12 (Entwicklerwerkzeuge) nach Fehlerausgaben schauen

  • Fehlermeldungen in Shopware debuggen und untersuchen
    http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen_detail_1880.html

  • Fehlermeldungen in error_log auf Server untersuchen (mögliche PHP-Fehler)
    Bitte nicht mit Shopware Log verwechseln. Liegt meist außerhalb vom httpdocs-Order der Domain - ggf. beim Hoster anfragen.

 

Es existiert keine error.log Datei auf dem Server (oder wo finde ich die sonst? Per FTP nachgeschauen). Die Konsole ist immer das erste, was ich mir anschaue. Da sind nur 615 logs, aber keine Fehler oder Warnungen, wenn ich die Logs unsichtbar schalte ist da also alles clear. Im Production-log der ein mal täglich erstellt wird (oder meintest du das mit error_log? ) steht folgender Error:

 

[2019-08-01 09:33:40] core.CRITICAL: Invalid compiled template for ‘backend/base/bootstrap.js’ {“uid”:“5fd9b07”}
[2019-08-01 09:33:40] core.CRITICAL: Invalid compiled template for ‘backend/base/bootstrap.js’ {“uid”:“5fd9b07”}
[2019-08-01 09:33:40] core.ERROR: exception ‘SmartyException’ with message ‘Invalid compiled template for ‘backend/base/bootstrap.js’’ in /html/tom/shop/engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php:174 Stack trace: #0 /html/tom/shop/engine/Library/Enlight/View/Default.php(300): Smarty_Internal_TemplateBase->fetch() #1 /html/tom/shop/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(216): Enlight_View_Default->render(Object(Enlight_Template_Default)) #2 /html/tom/shop/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(242): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->renderTemplate(Object(Enlight_Template_Default)) #3 /html/tom/shop/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(136): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->render() #4 (internal function): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->onPostDispatch(Object(Enlight_Controller_ActionEventArgs)) #5 /html/tom/shop/engine/Library/Enlight/Event/Handler/Default.php(91): call_user_func(Array, Object(Enlight_Controller_ActionEventArgs)) #6 /html/tom/shop/custom/plugins/FroshProfiler/Components/Event/EventManager.php(296): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs)) #7 /html/tom/shop/custom/plugins/FroshProfiler/Components/Event/EventManager.php(84): FroshProfiler\Components\Event\EventManager->parentNotify(‘Enlight_Control…’, Object(Enlight_Controller_ActionEventArgs)) #8 /html/tom/shop/engine/Library/Enlight/Controller/Action.php(235): FroshProfiler\Components\Event\EventManager->notify(‘Enlight_Control…’, Object(Enlight_Controller_ActionEventArgs)) #9 /html/tom/shop/engine/Library/Enlight/Controller/Dispatcher/Default.php(563): Enlight_Controller_Action->dispatch(‘indexAction’) #10 /html/tom/shop/engine/Library/Enlight/Controller/Front.php(222): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #11 /html/tom/shop/engine/Shopware/Kernel.php(202): Enlight_Controller_Front->dispatch() #12 /html/tom/shop/vendor/symfony/http-kernel/HttpCache/SubRequestHandler.php(102): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #13 /html/tom/shop/vendor/symfony/http-kernel/HttpCache/HttpCache.php(448): Symfony\Component\HttpKernel\HttpCache\SubRequestHandler::handle(Object(Shopware\Kernel), Object(Symfony\Component\HttpFoundation\Request), 1, true) #14 /html/tom/shop/engine/Shopware/Components/HttpCache/AppCache.php(260): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #15 /html/tom/shop/vendor/symfony/http-kernel/HttpCache/HttpCache.php(238): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #16 /html/tom/shop/engine/Shopware/Components/HttpCache/AppCache.php(105): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #17 /html/tom/shop/shopware.php(122): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #18 {main} {“uid”:“5fd9b07”}

 

PS: Die Uhrzeit hat auch nichts mit der Uhrzeit der Theme-Änderung zutun. Auch wenn ich jetzt das Theme wieder umändere und dann abermals zurückändere, bleibt der log  gleich, aber der Fehler bestehen.

Es muss echt an einer Theme-Änderung liegen… im responsive-Theme popt auch das Userlike-Livechat icon unten auf… in meinem einfach nicht. Ich habe allerdings nur etwas am Artikelnamen verändert.