Meldung bei Betriebsstörungen

Hallo,
unser Shop ist seit einigen Monaten online und läuft mehr schlecht als recht. Nahezu täglich kommt es zu Störungen in Sichtbarkeit und Funktionalität. Das ist schon schlimm genug, allerdings stört mich am meisten, dass ich es immer nur zufällig mitbekomme. Sei es durch fehlende Verkäufe an den Vortagen oder durch Kundenanrufe, die den Checkout nicht durchlaufen können. Fehler 503 ist allgegenwärtig. 
Es kann doch nicht sein, dass ich viertelstündlich Testkäufe an unterschiedlichen Browsern durchführen muss, um die Funktionalität zu überwachen. Wie löst Ihr denn dieses Problem oder laufen Eure Shops immer fehlerfrei? Es sollte doch eine „Überwachungsplugin“ oder ein anderes Instrument zur Überwachung geben, welches die Probleme zeitnah und verständlich(auch wenn man kein Programmierer ist) darstellen kann?
Vielen Dank für Eure Hilfe.
Monty

Hallo @Monty‍

man kann sich Fehlermeldungen, die im Shopware-Log unter var/log liegen  per Email zustellen lassen. Ein 503 Error, der nicht permanent auftritt, darf eigentlich nicht entstehen. Die Ursache liegt wahrscheinlich in der Hostingumgebung und nicht in Shopware  ohne Plugins. 

Falls Shopware an allen Stellen des Shops getestet wurde, läuft es auch stabil ohne einen 503-Error zu erzeugen. Natürlich kann es so Problemen mit Zahlungsdienstleistern kommen, die einen Bestellabschluss verhindern oder verlorenen bzw.- abgelaufenen Sessison etc., aber nicht willkürlich zu einem 503-Error. Im Error-Log des Servers müsste stehen, wann und warum es zu einem 503 Error gekommen ist. 

1 Like

Vielen Dank,
also unter Einstellungen—> Logfile ist nix zu finden. Heute kann zum Beispiel über firefox kein Checkout durchlaufen werden. Wir sind bei Timmehosting und dort habe ich erfahren, dass es an der “CSR Token Validierung” liegt. Bei Shopware kann mir keiner helfen, da ist der Support nicht besetzt. Unser Agentur der Wahl ist auf der gleichen Party.
Herausbekommen habe ich das nur durch einen hilfsbereiten Kunden, der dann doch mal den Browser gewechselt hat. Bei mir in Chrome ging es reibungslos. Wie gesagt, so etwas muss man doch auch so herausbekommen.
Beste Grüße
Monty

Wenn es die CSRF-Token Validierung ist, kannt man diese in der config.php deaktivieren. Eigentlich steht diese Exception aber im Logfile von Shopware. 

'csrfProtection' => [
    'frontend' => false,
    'backend' => false
],

 

 

1 Like

Wir sind ebenfalls bei TimmeHosting und haben den Eintrag bzgl. csrf-Protection in der config.php nicht und keinerlei Problem.
Schau mal in den error-logs des Servers und in die Logfiles unter var/log.

Hast Du mal die URL zum Shop?

Und vor allem welche Version?

Klingt nach einer alten Version.

Und frag mal bei deiner Agentur nach was für Plugins die da gebastelt haben.

 

Und hau das Idealo raus auf der Startseite :slight_smile:

Letzte Bewertung 2014, da würde ich denken der Shop ist tot.

Ich würde ebenfalls vermuten, daß es an einem oder mehreren Plugins liegt, daher kannst Du versuchen, diese nach und nach zu deaktivieren, und dann schauen, ob das Problem noch auftritt. Deine Agentur sollte Dir ebenfalls helfen können. An der Hostingumgebung kann es nicht liegen, denn dann würdest Du in allen Browsern Probleme haben und nicht nur in einem, während der Shop in allen anderen Browsern funktioniert.

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

Hallo,

 

ich habe das selbe Problem. Durch das Logfile konnte ich identifizieren an welchem Plugin es liegt. Das Problem ist nur das dieses Plugin gar nicht mehr Installiert ist. Hat jemand eine Idee wie ich nun vorgehe?

Grüße

Schau mal in der Datenbank ob es dort wirklich auf inaktiv steht.

Schaue mal bei Shopware-Backend > Einstellungen > System: ist da alles okay? Wir hatten auch probleme mit der Anzeige der aktiviven Artikel: waren mal da und mal nicht. Da lag es an der sehr alten PHP Version. Wie neu/alt ist PHP/Datenbankserver? Was für einen Hoster? Was für ein Hosting-Paket? Wieviele Artikel/Varianten?

Das Plugin stand in der Datenbank noch auf Aktiv. Trotz Deinstallation. Wie kann das sein?

In den System-Informationen sieht alles gut aus. PHP Version ist 5.6.4 und mysql Version ist 5.6.23. Das sollte also passen. Wir haben ca. 1500 Artikel im Shop und inkl. Varianten sind es ca. 21000.