Layout Zuweisung verereben

Vielleicht irre ich mich, aber die Layout Zuweisung wird nicht vererbt. Wenn man durch Import oder Migration eine Reihe von Kategorien anlegt, will man nicht unbedingt in jede Kategorie rein und die Layout Zuweisung einstellen. Vielleicht mal mit anschauen.

Die Migration sollte das automatisch machen (ggf. funktioniert das aktuell noch nicht komplett).

Später wird es da für die Zuweisung einen Batch-Modus geben.

Bei meinem Test wurde nach der Migration gar nichts zugewiesen und ich musste in jede Kategorie rein.

Die Migration weißt eigentlich alle migrierten Produkte dem neuen SalesChannel zu.
Wenn es bei dir nicht der Fall ist, müsstest du mal in die Logging-Tabelle (swag_migration_logging) oder in die Migration-History in der Administration schauen, da werden alle Meldungen mit gelogged, die bei der Migration auffallen.

Ja das steht einiges drin, aber so richtig schlau werde ich damit im Moment nicht. Jedenfalls sehe ich nichts was im Bezug mit den Kategorien sein könnte. Ich kann gern mal die Liste hier posten.

Kannst du gerne machen.
Du kannst uns auch gerne die SW5-Daten per forum@shopware.de zukommen lassen, sodass wir uns deinen Migrationsfall selbst anschauen und vielleicht bei der Fehlerfindung helfen können.

Ah ok, ja im Log finde ich erst mal diese Zeilen (zusammengefasst):

info:

SWAG_MIGRATION_LANGUAGE_ENTITY_ALREADY_EXISTS
The language entity with source id "1" already exists and cannot be written.
...

SWAG_MIGRATION__SHOPWARE_UNSUPPORTED_NUMBER_RANGE_TYPE
NumberRange-Entity with source id "927" could not be converted because of unsupported type: sSERVICE2.
...

SWAG_MIGRATION__SHOPWARE_UNSUPPORTED_OBJECT_TYPE
translation of object type "config_mails" with source id "1" could not be converted.
translation of object type "custom_facet" with source id "4" could not be converted.
translation of object type "documents" with source id "2" could not be converted.
translation of object type "custom_sorting" with source id "3" could not be converted.
translation of object type "config_payment" with source id "7" could not be converted.
translation of object type "custom_facet" with source id "6" could not be converted.

warning:

SWAG_MIGRATION__SHOPWARE_UNSUPPORTED_SHIPPING_CALCULATION_TYPE
ShippingMethod-Entity with source id "9" could not be converted because of unsupported calculation type "3".
...

SWAG_MIGRATION_SHIPPING_METHOD_ENTITY_UNKNOWN
The order entity with the source id "113" cannot find the depended shipping_method entity with the source id "10".
...

Da es sich hierbei um einen Test-Shop handelt kann ich euch gern Zugangsdaten zukommen lassen. Ich bereite da etwas vor.

@R4M schrieb:

Ah ok, ja im Log finde ich erst mal diese Zeilen (zusammengefasst):

info:

SWAG_MIGRATION_LANGUAGE_ENTITY_ALREADY_EXISTS
The language entity with source id „1“ already exists and cannot be written.

SWAG_MIGRATION__SHOPWARE_UNSUPPORTED_NUMBER_RANGE_TYPE
NumberRange-Entity with source id „927“ could not be converted because of unsupported type: sSERVICE2.

SWAG_MIGRATION__SHOPWARE_UNSUPPORTED_OBJECT_TYPE
translation of object type „config_mails“ with source id „1“ could not be converted.
translation of object type „custom_facet“ with source id „4“ could not be converted.
translation of object type „documents“ with source id „2“ could not be converted.
translation of object type „custom_sorting“ with source id „3“ could not be converted.
translation of object type „config_payment“ with source id „7“ could not be converted.
translation of object type „custom_facet“ with source id „6“ could not be converted.

warning:

SWAG_MIGRATION__SHOPWARE_UNSUPPORTED_SHIPPING_CALCULATION_TYPE
ShippingMethod-Entity with source id „9“ could not be converted because of unsupported calculation type „3“.

SWAG_MIGRATION_SHIPPING_METHOD_ENTITY_UNKNOWN
The order entity with the source id „113“ cannot find the depended shipping_method entity with the source id „10“.

Da es sich hierbei um einen Test-Shop handelt kann ich euch gern Zugangsdaten zukommen lassen. Ich bereite da etwas vor.

Sieht doch ganz okay aus. Stelle uns mal die Daten zur Verfügung, dann können wir mehr dazu sagen.
Danke schon mal für deine Bemühungen. 

Mail ist unterwegs - Betreff: Test mit Migration SW5 zu SW6

Und Danke für eure Mithilfe

@R4M schrieb:

Mail ist unterwegs - Betreff: Test mit Migration SW5 zu SW6

Und Danke für eure Mithilfe

Haben wir erhalten und werden uns das mal anschauen, danke nochmals für deine Mithilfe. 

Guten Morgen R4M,

habe gerade eine Migration deines Testsystems ohne Probleme durchgeführt: Alle Kategorien hatten die “Default category layout” - Zuordnung, ich musste nur einmal die Indexer anstoßen, dass die Produkte auch in der Storefront angezeigt werden. Die Logging-Tabelle sieht gut und unauffällig aus. Wie du schon angemerkt hast:

  1. Müssen noch die Positionen der Attribute mit migriert werden, sodass die CustomFields in SW6 in der richtigen Reihenfolge stehen
  2. Wenn kein Label beim Attribut gesetzt ist, muss das Label auf den Namen des CustomFields gesetzt werden
  3. Wenn die Positionen der Kategorien aus SW5 leer sind, muss die Reihenfolge der Kategorien in SW6 trotzdem festgesetzt werden

Wir sind an den Lösungen hierfür dran und halten dich auf dem Laufenden.
Wenn du noch Fragen oder weitere Probleme hast, melde dich gerne.

Gruß

Krispin

Moin Krispin,

erst einmal vielen Dank für deine Mühe und dein Feedback. Ich werde da mit Sicherheit noch etwas herum spielen.

Grüße zurück

Moin R4M,

gern geschehen. Hört sich gut an, wenn noch was ist: Melde dich gerne.
Und viel Spaß beim herum spielen :wink:

Gruß

Krispin

Vielleicht dieser Punkt?

https://forum.shopware.com/discussion/62735/einstiegspunkt-leider-ist-etwas-schief-gelaufen