Installation stuck at configuration step

I am using Shopware in Ubuntu 20. My installation stops at configuration step. Has anybody fixed this issue ? There is no error in console.

There must be an error in the servers error.log or in an XHR-request (browser).

Maybe you have to activate error logging?


I have checked in /var/log/ I could not find anything. Please let me know where else I can check.

Status pending means it is not done yet. You have to wait.

Maybe Shopware tries to delete the installation files and has not permission to do so?

You can look what finish/ does in the source code, so you can narrow down the problem.

I have waited for 30 mins. Or do you mean wait for bug to be solved in current version of shopware ?

Inside app.php have following return from finish/

return $this->renderer->render(
        'url' => $schema . '://' . $_SERVER['HTTP_HOST'] . $basepath,
        'loginTokenData' => $loginTokenData,
        'basePath' => $basepath,
        'host' => explode(':', $_SERVER['HTTP_HOST'])[0],

I couldnot find finish.php file in the project folder.

There is no finish.php, it is only the name you see in the URL.

I did install the current shopware version on six servers in the last days. Never had any issues. Do you use Apache or nginx?

I am using PHP built-in web server; running with php -S -t public

Maybe that’s the problem… I do not know. I have never done that.

@Max_Shop So I tried to install new shopware using Apache. But now I get http://localhost/test-shopware/public/admin not found message after configuration step. Any idea ?

That cannot work.

Your domain or localhost must direct to the /public folder. That it is localhost/admin

It is a security „feature“.