HTTP ERROR 500 nach Update von 5.6.2 auf 5.6.3 und Neuinstallation 5.6.3

Hallo,

nach einem Update von 5.6.2 nach 5.6.3 habe ich leider ein  HTTP ERROR 500  bekommen.

Zum Test habe ich eine Neuinstallation vorgenommen (5.6.3) Die Installion wurde ohne Fehler abgeschlossn.

Aber auch hier  HTTP ERROR 500.

[Sat Dec 07 11:59:43.693851 2019] [fcgid:warn] [pid 27857:tid 140461662496512] [client xx.xx.135.213:50239] mod_fcgid: stderr: PHP Fatal error:  require_once(): Failed opening required ‘phar:///var/customers/webs/xxx/wwwde/563/vendor/phpstan/phpstan-shim/phpstan.phar/vendor/autoload.php’ (include_path=’/var/customers/webs/xxx/wwwde/563/engine/Library:.:/usr/share/php/:/usr/share/php5/’) in /var/customers/webs/xxx/wwwde/563/vendor/phpstan/phpstan-shim/bootstrap.php on line 8

Wie kann es dazu kommen?  Hat da einer einen Tipp?

PHP 7.2.18, mariadb 10.1.26

 

 

 

 

 

 

Hat keiner eine Idee was die Ursache sein könnte?

Wie kann es zu einem solchen Dateipfad kommen?

Failed opening required ‘phar:///var/customers/webs/xxx/wwwde/563/vendor/phpstan/phpstan-shim/phpstan.phar/vendor/autoload.php’

 

Sicher, dass tatsächlich php 7.2 läuft und die phar extension aktiv ist? 

1 Like

Nach Anzeige PHP-Info JA

PHP Version 7.2.18
Phar EXT version 2.0.2

Mein Versuch mit 5.6.4

Error

Received an error message.
URL:  importSnippets?offset=1200&totalCount=1601
Message:  Internal Server Error

Please try to fix this error and restart the update.

Response

  

Slim Application Error

The application could not run because of the following error:

Details

Type: RuntimeException

Message: Identifier DB not initialized yet

File: /var/customers/webs/esomatic/wwwde/564/recovery/install/src/ContainerProvider.php

Line: 155

Trace

  

#0 /var/customers/webs/esomatic/wwwde/564/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(118): Shopware\Recovery\Install\ContainerProvider->Shopware\Recovery\Install{closure}(Object(Pimple\Container))

#1 /var/customers/webs/esomatic/wwwde/564/recovery/install/src/app.php(633): Pimple\Container->offsetGet(‚db‘)

#2 [internal function]: {closure}()

#3 /var/customers/webs/esomatic/wwwde/564/recovery/common/vendor/slim/slim/Slim/Route.php(468): call_user_func_array(Object(Closure), Array)

#4 /var/customers/webs/esomatic/wwwde/564/recovery/common/vendor/slim/slim/Slim/Slim.php(1355): Slim\Route->dispatch()

#5 /var/customers/webs/esomatic/wwwde/564/recovery/common/vendor/slim/slim/Slim/Middleware/Flash.php(85): Slim\Slim->call()

#6 /var/customers/webs/esomatic/wwwde/564/recovery/common/vendor/slim/slim/Slim/Middleware/MethodOverride.php(92): Slim\Middleware\Flash->call()

#7 /var/customers/webs/esomatic/wwwde/564/recovery/common/vendor/slim/slim/Slim/Middleware/PrettyExceptions.php(67): Slim\Middleware\MethodOverride->call()

#8 /var/customers/webs/esomatic/wwwde/564/recovery/common/vendor/slim/slim/Slim/Slim.php(1300): Slim\Middleware\PrettyExceptions->call()

#9 /var/customers/webs/esomatic/wwwde/564/recovery/install/index.php(75): Slim\Slim->run()

#10 {main}

Hi,

ich stoße auch auf den Fehler. Und untersuche den Fehler jetzt schon nen halben Tag. Konntest du das Problem lösen?

Desweiteren verwenden Uwir nit-Tests, welche nach dem Deployment automatisiert laufen. Auch hier ist mir aufgefallen, dass bei der Testausführung dieser Fehler

 Fatal error: Class 'Enlight\_Components\_Test\_Plugin\_TestCase' not found in Test

auftaucht. Hier ist die Klasse definitiv vorhanden. Sie ist als Alias gekennzeichnet. Bei den obigen Fehler sind auch alle Pakete und Dateien vorhanden.

PS: ich habe auch php7.2 und PHAR EXT 2.0.2 installiert

Gruß

1 Like