Help! Bestellung; beim Absenden kommt der Fehler

Hallo,

irgendwas ist passiert, denn ich bekomme im Test beim Absenden einen Fehler der sich wie folgt bemerkbar macht. Bisher ist alles gegangen, und irgendwas habe ich verändert und bekomme es nicht mehr hin.

Es gibt keine Probleme bis zum " ZAHLUNGSPFLICHTIG BESTELLEN" aber auf klick kommt " LEIDER IST WAS SCHIF GELAUFEN"!!

Ich nutze folgende Einstellungen:
Verkaufskanäle: Standart-Kundengruppe

Einstellungen:
Versand Deutsche Post DHL: Verfügbarkeit ->  Alle Kunden der Standardgruppe

Zahlungsarten:
Vorkasse und Paypal (All Customers)

 

Die Gesamtsumme auf 0 gestellt ist normal, das ist nur ein Test und auch wenn ich ein Artikel mit einer Summe eingebe, kommt auch der Fehler.

 

$ttps://www.xxxxx-online.com /checkout/order

[2020-03-18 17:52:01] request.ERROR: Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\NotFoundHttpException: "No route found for "GET /shop.php" (from "https://www.amspo24-online.com/de/maru-spikey-monster-squirty-toy.html")" at /homepages/21/d816008475/htdocs/shopware/vendor/symfony/http-kernel/EventListener/RouterListener.php line 136 {"exception":"[object] (Symfony\\Component\\HttpKernel\\Exception\\NotFoundHttpException(code: 0): No route found for \"GET /shop.php\" (from \"https://www.amspo24-online.com/de/maru-spikey-monster-squirty-toy.html\") at /homepages/21/d816008475/htdocs/shopware/vendor/symfony/http-kernel/EventListener/RouterListener.php:136, Symfony\\Component\\Routing\\Exception\\ResourceNotFoundException(code: 0): No routes found for \"/shop.php/\". at /homepages/21/d816008475/htdocs/shopware/vendor/symfony/routing/Matcher/Dumper/CompiledUrlMatcherTrait.php:70)"} []
[2020-03-18 21:44:33] php.CRITICAL: Uncaught Error: Failed to create closure from callable: class 'Swag\PayPal\Installment\Banner\InstallmentBannerSubscriber' does not have a method 'addInstallmentBannerFooter' {"exception":"[object] (TypeError(code: 0): Failed to create closure from callable: class 'Swag\\PayPal\\Installment\\Banner\\InstallmentBannerSubscriber' does not have a method 'addInstallmentBannerFooter' at /homepages/21/d816008475/htdocs/shopware/vendor/symfony/event-dispatcher/EventDispatcher.php:304)"} []
[2020-03-18 21:44:33] request.CRITICAL: Uncaught PHP Exception TypeError: "Failed to create closure from callable: class 'Swag\PayPal\Installment\Banner\InstallmentBannerSubscriber' does not have a method 'addInstallmentBannerFooter'" at /homepages/21/d816008475/htdocs/shopware/vendor/symfony/event-dispatcher/EventDispatcher.php line 304 {"exception":"[object] (TypeError(code: 0): Failed to create closure from callable: class 'Swag\\PayPal\\Installment\\Banner\\InstallmentBannerSubscriber' does not have a method 'addInstallmentBannerFooter' at /homepages/21/d816008475/htdocs/shopware/vendor/symfony/event-dispatcher/EventDispatcher.php:304)"} []
[2020-03-18 21:44:36] php.CRITICAL: Uncaught Error: Failed to create closure from callable: class 'Swag\PayPal\Installment\Banner\InstallmentBannerSubscriber' does not have a method 'addInstallmentBannerFooter' {"exception":"[object] (TypeError(code: 0): Failed to create closure from callable: class 'Swag\\PayPal\\Installment\\Banner\\InstallmentBannerSubscriber' does not have a method 'addInstallmentBannerFooter' at /homepages/21/d816008475/htdocs/shopware/vendor/symfony/event-dispatcher/EventDispatcher.php:304)"} []
[2020-03-18 21:44:36] request.CRITICAL: Uncaught PHP Exception TypeError: "Failed to create closure from callable: class 'Swag\PayPal\Installment\Banner\InstallmentBannerSubscriber' does not have a method 'addInstallmentBannerFooter'" at /homepages/21/d816008475/htdocs/shopware/vendor/symfony/event-dispatcher/EventDispatcher.php line 304 {"exception":"[object] (TypeError(code: 0): Failed to create closure from callable: class 'Swag\\PayPal\\Installment\\Banner\\InstallmentBannerSubscriber' does not have a method 'addInstallmentBannerFooter' at /homepages/21/d816008475/htdocs/shopware/vendor/symfony/event-dispatcher/EventDispatcher.php:304)"} []

... und weitere fehler

 

Danke für euere Hilfe.

MfG R. Amend

E-mail Template checken. hast iwo {{ path(’/shop.php’) }} oder sowas ähnliches stehen ;) 

nvm! muss wohl doch am PayPal plugin liegen ^^

@Moorleiche‍
 

Danke für die Info. Bei Mail finde ich nichts, es ist ja vorher auch gelaufen.

Paypal hatte auch funktioniert.

Trotzdem wäre mal wichtig zu wissen, wie die Einstellungen in den Bereichen Versand und Zahlungarten (DHL // Vorkasse und Paypal) aussehen müssen.

Wie müssen den die Einstellungen -> Rule Builder - sein, oder besser ich mache das letzte Backup rein, oder was meint Ihr?

Moin Moin,

ich habe immer noch keinen Ansatz um das Problem beheben zu können. Eine Bestellung geht durch, aber die Weiterleitung bleibt stehen, unter …

LEIDER IST ETWAS SCHIEF GELAUFEN

Bestellungen gehen auch durch, könnten demnach auch Abgewickelt werden, nur der Kunde sieht dieses Problem und denkt, dass keine Bestellung durch gelaufen ist.

@Moorleiche‍

… auch wenn Paypal deaktiv ist, bleibt das Problem!

 

@

Dieser Fehler ist auch neu aufgetreten und mehrere Test-Bestellung gingen vorher. Kann das auch an einem Plugin hängen.

Gibt es Agenturen die auch Probleme beheben auserhalb der eigenen Plugin-Programmierungen?

Mit freundlichen Grüßen
Rainer Amend

@AMSPO24online schrieb:

Gibt es Agenturen die auch Probleme beheben auserhalb der eigenen Plugin-Programmierungen?

Nur für Troubleshooting wirst du keine Agentur finden, zumal die Agenturpreise ab 100€/h beginnen :wink:

Dann evtl nen Freelancer, aber ehrlich gesagt sind die auch nur an langfristigen Partnerschaften interessiert. 

Du musst dich entscheiden ob du selbst deinen Shop einrichten willst oder es machen lässt, denn neimand mag es wenn der Kunde mitentwickelt und viel selber machen will.

Gib nicht auf, du wirst den Fehler schon finden :wink:

@Moorleiche‍

Der Shop war eingerichtet und hatte in Tests auch funktioniert. Ich hatte schon mal vor ewig langer Zeit die Professional Edition 3.5 (denke ich), damals noch 1200 Euro gehabt.

Aber egal, ich warte noch bis Ende Mai ob ich das hinbekomme, dannach werde ich meinen alten Shop wieder aktivieren und damit weiter arbeiten.

Ich denke auch, dass da noch einige Fehler drin sind. Klar ist gut, wenn man solche Leute “Freelancer” hat, aber dauerhaft wird das nicht sein, weil wenn ein Shop läuft, dann macht er keine Probleme mehr. Höchstens ein Update schlägt fehl. Dann lässt man das wieder Reparieren…!

 

@Moorleiche‍

Wie und wo kann ich das E-Mail Template für Shopware 6 finden?

 

E-mail Template checken. hast iwo {{ path(’/shop.php’) }} oder sowas ähnliches stehen

Hey, vergiss den Ansatz, bei Fehlern in den Mail Templates werden die Fehlermeldungen nur im Error Log angezeigt. Wundert mich dass du noch garnicht weiter gekommen bist. Hast du denn bereits stück für stück andere Zahlungs/Versandarten genutzt, Plugins deaktiviert etc um den Fehler einzugrenzen? :wink:

Also nach wie vor: In deiner Fehlermdlung stand etwas mit Paypal:

php.CRITICAL: Uncaught Error: Failed to create closure from callable: class 'Swag\PayPal\Installment\Banner\InstallmentBannerSubscriber' does not have a method 'addInstallmentBannerFooter'

Und noch ein kleiner Tipp: nicht blind drauf los updaten, richte dir ein Zweitsystem (Staging) ein um Neuerungen vorab zu testen. Ich hab es sogar noch bei Shopware 5 dass so manch ein Update mir den ganzen Shop zerschießt - wobei ich mich frage wieso bei SW5 noch so fleißig am Core gewerkelt wird  Undecided

@Moorleiche‍

Danke, dass war ein entscheidender Hinweis!

Ich habe alle Plugins deaktiviert bis auf Vorkasse und Paypal. Dann funktioniert es auch. Und jetzt kommt die Fehlersuche Step by Step.

Bekomme ich auch die vielen Test-Bestellungen gelöscht?

 

Fehler lokalisiert: Blauband E-Mails (EKS) - Blauband GmbH

 

@AMSPO24online schrieb:

 

LEIDER IST ETWAS SCHIEF GELAUFEN

Bestellungen gehen auch durch, könnten demnach auch Abgewickelt werden, nur der Kunde sieht dieses Problem und denkt, dass keine Bestellung durch gelaufen ist.

 

 

Da ich dieses Problem auch hatte… bei mir war es ein blödes Leerzeichen hinter oder vor  der E-Mail Adresse bei der Shopkonfiguration.

Ich habe Schopware 6 erstmal auf’s Eis gelegt.

Das genannte Problem hatte ich nicht, weil ich meine Daten automatisiert Eingelesen habe.

Abwarten was sich in den nächsten Monaten tut.

 

Hallo,

ich habe immer noch das Problem, dass nach einer Bestellung, die auch durch geht, nicht korrekt weitergeleitet wird.

Der Bildschirm bleit Weiß mit dem Fehler was ich ganz oben bescjreben habe.

Vielleicht hat einer von euch eine Info wie ich das lösen kann?

Version: 6.2.0

MfG Rainer