Hat jemand bereits world4you Erfahrungen gesammelt?

Hat jemand bereits world4you Erfahrungen gesammelt?
Bin echt am verzweifen, denn ich schaffe es einfach nicht die Installation zu starten.

Webspace: world4you

Webspacepaket: Domainserver Start (ANGEBLICH zu vergleichen mit Domainserver Pro)

Vorgehensweise:

#1 alles mal auf der webspace gelöscht, also haben wir ein komplett sauberes Verzeichnis

#2 download von shopware

#3 entpacken und per filezilla ins hauptverzeichnis hochladen (meinedomain.at/…)

#4 aufrufen der seite meinedomain.at/recovery/install

#5 NICHTS PASSIERT ausser dieser Fehlermeldung:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Also was kann ich tun Leute? Kann mir vl jemand helfen?

mfG Boris

filezilla ansicht

Hier mal die .htaccess File bevor mich jemand danach fragt… Sauber und kompl. unverändert…

RewriteEngine on

#RewriteBase /shopware/

# Https config for the backend
#RewriteCond %{HTTPS} !=on
#RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule backend/media/(.*) media/$1 [NC,L]

RewriteCond %{REQUEST_URI} !(\/(engine|files|templates|themes|web)\/)
RewriteCond %{REQUEST_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]

# Fix missing authorization-header on fast_cgi installations
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]



    # Block access to VCS directories
    RedirectMatch 404 /\\.(svn|git|hg|bzr|cvs)(/|$)

    # Restrict access to root folder files
    RedirectMatch 404 /(composer\.(json|lock)|README\.md|UPGRADE\.md)$


# Staging environment
#SetEnvIf Host "staging.test.shopware.in" SHOPWARE_ENV=staging

# Development environment
#SetEnvIf Host "dev.shopware.in" SHOPWARE_ENV=dev
#SetEnv SHOPWARE_ENV dev

DirectoryIndex index.html
DirectoryIndex index.php
DirectoryIndex shopware.php

# Disables download of configuration

    # Deny all requests from Apache 2.4+.
    
          Require all denied
    

    # Deny all requests from Apache 2.0-2.2.
    
        Deny from all
    


# Enable gzip compression

    AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json



    
        ExpiresActive on
        ExpiresDefault "access plus 1 month"
    

    
        Header append Cache-Control "public"
        Header unset ETag
    

    FileETag None


# Match generated files like:
# 1429684458_t22_s1.css
# 1429684458_t22_s1.js

    
        Header set Cache-Control "max-age=31536000, public"
    

    
        ExpiresActive on
        ExpiresDefault "access plus 1 year"
    


# Disables auto directory index

	Options -Indexes



    Options -MultiViews



# php_value memory_limit 256M
# php_value max_execution_time 120
# php_value upload_max_filesize 20M
   php_flag phar.readonly off
   php_flag magic_quotes_gpc off
   php_flag session.auto_start off
   php_flag suhosin.session.cryptua off
   php_flag zend.ze1_compatibility_mode off
   php_value always_populate_raw_post_data -1


# AddType x-mapp-php5 .php
# AddHandler x-mapp-php5 .php


    Header append X-Frame-Options SAMEORIGIN

 

ps.: die phpinfo.php konnte ich auch nicht aufrufen…

also direkt ins hauptverzeichnis und dann per meinedomain/phpinfo.php aufrufen…

hier kommt wieder die selbe Fehlermeldung:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

 

Schau’ mal ins Error-Log der Website. Falls Du darauf keinen Zugriff hast, wende Dich bitte an den Hoster.

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

Im Error-Log steht leider nur die oben eingefügte Fehlermeldung drinnen, sonst nichts…

Ps.: Habe mal versucht, Owncloud zu installieren (um zu sehen, ob es mit dem php-file überhaupt geht)

doch auch hier tut sich nichts. Mit genau derselben Vorgehensweise hat es auf meiner 2.Wwebspace wunderbar funktioniert (selber host)

Also gehe ich mal stark davon aus dass es an World4you liegt, doch die lassen sich mit einer zufriedenstellenden Antwort auch mächtig viel Zeit…

Ich warte mal gezwungenermaßen auf die Lösung vom Host und sag euch dann bescheid doch falls jemand die Erfahrung bereits gemacht haben sollte:

BITTE MELDE DICH ^^

Also gehe ich mal stark davon aus dass es an World4you liegt, doch die lassen sich mit einer zufriedenstellenden Antwort auch mächtig viel Zeit…

Bei einem Shop mit dem man Geld verdienen möchte, sollte man nicht beim Server sparen. Wenn man dann auch noch wie Du schreibst beim Support ewig warten muss, ist ein Serverwechsel dringend anzuraten. Sonst wirst Du nicht glücklich, und Geld wirst mit so einen schlechten Server auch keins verdienen. ;)

Grüße

Error 500 hört sich nach einem Berechtigungsproblem an, wenn Du noch nicht mal eine phpinfo-Datei aufrufen kannst.

Du kannst versuchen, auf die phpinfo.php Datei oder den Ordner selbst (dort wo auch Deine Shopware Installation ist) 755 Rechte per CHMOD zu setzen. Geht z.B. auch ohne SSH Verbindung mit Filezilla: http://filezilla-client.de/anleitung/chmod-aendern.html

VG

1 Like

[@Vitago GmbH](http://forum.shopware.com/profile/21824/Vitago GmbH „Vitago GmbH“)‍  Bin jetzt mittlerweile seit knapp einem Jahrzehnt dort und es hat immer alles geklappt. Deshalb fällt es einem schwer direkt den Host zu tauschen, schon alleine wegen Owncloud und dem unbegrenzten Speicherplatz das ich im Paket habe. Ich werde mal noch ein bisschen abwarten und notfalls muss ich mir eine zweite Webspace zulegen.

Heute hatte ich die Ehre mit dem Support telefonieren zu können. Es wurde etwas Serverseitiges (worauf ich kein Zugriff habe) editiert, doch noch immer kein Ergebnis.

@AIXPRO‍  Danke für die Idee. Bei älteren Shopware-Versionen hatte ich bereits darüber gelesen. Doch wie in der Anleitung beschrieben, habe ich die entpackten Daten direkt ins Haupt/Root-Verzeichnis per Filezilla hochgeladen und versucht loszustarten. Doch selbst die Berechtigungen alle auf einen numerischen Wert von 777 zu setzen hat nichts  gebracht. Wobei man es ja auch sicher nicht so belassen kann ^^

Also wieder einmal alles löschen und original hochladen Crying

Habe das Problem ENDLICH gefunden ^^

Anscheinend muss ich 2 Optionen in der .htaccess Datei deaktivieren…

Durch eine Kulazlösung werde ich noch 512M Ram anstelle von 256M beantragen…

Wenn das auch klappt… Hurra  Wearing-Sunglasses

# Disables auto directory index

#	Options -Indexes



# Options -MultiViews

 

OVER AND OUT

Prima - dann kommst Du ja weiter :slight_smile:

Dann nicht vergessen eine INNO DB verwenden die kostet extra.

Bei den Bildern musst du auch in der htaccess diese optionen verändern.

u.v.m.