Google +1 Button

Jetzt gibt es ja den Google +1 Button für die eigene Website. Allerdings kommt Shopware mit der Spracheinstellungscode nicht klar, der ist nämlich: <!-- Dieses Tag in den Head-Bereich oder direkt vor dem schließenden Body-Tag einfügen --><script type="text/javascript" src="https://apis.google.com/js/plusone.js"> {lang: 'de'} </script><!-- Dieses Tag dort einfügen, wo die +1-Schaltfläche dargestellt werden soll --><plusone size="medium"></plusone> und dieses {lang: 'de'} mag Shopware gar nicht, der Shop lässt sich nicht mehr öffnen. ... on line 91 "{lang: 'de'}" - Unexpected ": ", expected one of: "}" , " "' in ... Kann man das Problem lösen oder muss der Button jetzt auf englisch bleiben?

Das liegt an der eckigen Klamme. Smarty denkt das wäre Smarty Code. Es gibt einen Smarty Tag, welchen du davor und danach setzen sollst, damit es geht. ich such gerade mal, im Kopf hab ich den nicht. Habs schon gefunden: {literal} <script type="text/javascript" src="https://apis.google.com/js/plusone.js"> {lang: 'de'} </script>{/literal}

Danke das war ja mal kurz und schmerzlos, klappt natürlich wunderbar. Nur komisch dass der Button irgendwie nicht so wirklich funktionieren will. Habe testweise mal mit 2 Google Accounts auf +1 geklickt aber der Zähler bleibt auf 0. Ist das evtl. etwas verzögert oder stimmt da bei mir was nicht?

[quote=“parkkralleshop”]Danke das war ja mal kurz und schmerzlos, klappt natürlich wunderbar. Nur komisch dass der Button irgendwie nicht so wirklich funktionieren will. Habe testweise mal mit 2 Google Accounts auf +1 geklickt aber der Zähler bleibt auf 0. Ist das evtl. etwas verzögert oder stimmt da bei mir was nicht?[/quote] Man muss auch richtig lesen! In der Mail steht “in der kommenden Woche”! :wink:

Hmm okay danke :slight_smile:

[quote=“parkkralleshop”]Danke das war ja mal kurz und schmerzlos, klappt natürlich wunderbar. Nur komisch dass der Button irgendwie nicht so wirklich funktionieren will. Habe testweise mal mit 2 Google Accounts auf +1 geklickt aber der Zähler bleibt auf 0. Ist das evtl. etwas verzögert oder stimmt da bei mir was nicht?[/quote] Hallo, in welcher Datei wird der Google Code eingebunden? Ich habe schon verschiedene Möglichkeiten probiert, ich bekomme es einfach nicht hin.

Da ich auch das Facebook Plugin benutze habe ich die Datei hier dafür benutzt: frontend/plugins/facebook/blocks_detail.tpl Die sieht bei mir jetzt so aus (Zeile 5 und 6 ist dazugekommen): [code]{block name=“frontend_detail_index_actions” append} {if !$hideFacebook}


{/if} {/block} {block name=“frontend_detail_index_tabs_related” append} {if $app_id && !$hideFacebook}

Facebook-Kommentare

{/if} {/block} {block name=“frontend_detail_tabs_rating” append} {if $app_id && !$hideFacebook}- Facebook-Kommentare
{/if} {/block}[/code] Und diesen Teil hier in frontend/detail/header.tpl zum Beispiel unter Zeile 33 () einfügen: {literal}<script type="text/javascript" src="https://apis.google.com/js/plusone.js"> {lang: 'de'} </script>{/literal} So sieht das Ganze dann bei mir aus: http://parkkralle.de/parkkrallen-im-ueb … ter?c=1178

2 Likes

[quote=„parkkralleshop“]Da ich auch das Facebook Plugin benutze habe ich die Datei hier dafür benutzt: frontend/plugins/facebook/blocks_detail.tpl Die sieht bei mir jetzt so aus (Zeile 5 und 6 ist dazugekommen): [code]{block name=„frontend_detail_index_actions“ append} {if !$hideFacebook}


{/if} {/block} {block name=„frontend_detail_index_tabs_related“ append} {if $app_id && !$hideFacebook}

Facebook-Kommentare

{/if} {/block} {block name=„frontend_detail_tabs_rating“ append} {if $app_id && !$hideFacebook}- Facebook-Kommentare
{/if} {/block}[/code] Und diesen Teil hier in frontend/detail/header.tpl zum Beispiel unter Zeile 33 () einfügen: {literal}<script type="text/javascript" src="https://apis.google.com/js/plusone.js"> {lang: 'de'} </script>{/literal} So sieht das Ganze dann bei mir aus: http://parkkralle.de/parkkrallen-im-ueb … ter?c=1178[/quote] Hallo und besten Dank, ich werde heute Abend mal probieren ob ich das auch so hinbekomme. @@@ Bestens jetzt scheint es zu fuktionieren.:thumbup: Dank für die Hilfe. Sollte richtig angezeigt werden