Freitextfeld / Attribute / protected

Hi Leute,

ich habe auch mal ein Problem und zwar kämpfe ich seit heute morgen ein Freitextfeld (s_articles_img_attributes) ins Template zu bekommen.

Nach der Ausgabe über {Dump} habe ich gesehen, das die Inhalte zwar vorhanden sind, diese aber “protected” sind.

Auch über $sArticle.attributes.core->get( “attr1” )  habe ich kein Glück an die Inhalte zu kommen.

Kann mir vielleicht jemand weiterhelfen.

Danke Rene

 

 

Hallo @scriptfarm‍,

beim img attributes es heißt ‚attribute1 - attribute2 …‘  nicht ‚attr1‘

z.b $bild Variable hat ein bild , dann beim Template du kannst das bild Attribute wie so erreichen :

$bild.attribute.attribute1

VG,

Tel.: +49 755 - 183 990 00 | Email: info@enbit.de | Web: http://enbit.de/

1 Like

Hallo @ahmadsaad

danke für die Rückmeldung, also dann im Prinzip so : {$sArticle.image.attribute.attribute1} ?

 

 

@scriptfarm schrieb:

Hallo @ahmadsaad

danke für die Rückmeldung, also dann im Prinzip so : {$sArticle.image.attribute.attribute1} ?

 

 

 ja genau

OK danke, das sieht schon mal alles gut aus.

Wie kann ich den Feld Inhalt von Bild 1, Bild 2 oder Bild 3 direkt ansprechen.

Ich habe so ein wirrwarr bei der print Array Ausgabe, das ich nichts zuordnen kann.

Eine Schleife hilf mir nicht weiter.

Etwa so ?

{$sArticle.image[1].attribute.attribute1}

 

------------------- EDIT --------------------

Habe den Schnacksus gefunden, es muss dann so heissen :

{$sArticle.image.attribute.attribute1}

{$sArticle.image s [0].attribute.attribute1}

{$sArticle.image s [1].attribute.attribute1}

Da muss man erst einmal drauf kommen, das nur das Mainipage mit „image“ aufgerufen wird, alle anderen mit „image s“.

Danke

 

Hat jemand eine Idee, wie ich an die BildAttribute im Produkt-Feed (auch „Produktexport“ genannt) komme?