Frage zum Thema Preisangaben und Anzeige der Preise

Hallo zusammen,

ich habe Artikel, die ich in der Preisliste als Basispreis vom Hersteller bekomme. 

Diesen Basispreis habe ich bei der entsprechenden Variante eingetragen:  318,10  (ohne MwSt.)

Auf diesen Preis wird in der für den Artikel festgelegten und aktivierten Preisgruppe ein Abschlag von 45% berechnet: 174,95 (ohne MwSt.)

Daraus ergibt sich der Endverbraucherpreis im Shop: 208,20 (inkl. MwSt.)    Dieser Preis ist der, der wichtig ist!

Wenn ich aber im Frontend nach dem Artikel suche, werden 378,54 (Basispreis inkl. MwSt.) angezeigt.

Und in der Artikelübersicht im Backend werden ebenfalls 378,54 (Basispreis + MwSt.) angezeigt. 

Bei der Preisgruppe ist bei “Bruttopreise im Shop” ein Haken drin, da Endverbraucher inkl. MwSt. angezeigt werden muss. 

In der Preisgruppe ist 45% als Discount eingetragen. 

Was läuft falsch?  Was muss ich umstellen ? 

Damit ich

a) In der Artikelübersicht im Backend den Endverbraucherpreis (208,20) angezeigt bekomme? 

b) In der Suche den Endverbraucherpreis (208,20) angezeigt bekomme? 

 

Etwas kompliziert, ich weiß, aber ich blicke da nicht richtig durch…

 

Danke für jede Hilfe.

 

Gruß headwork55

 

Kann es sein, dass der Kunde (Kundengruppe) sich erst einloggen muss um den Rabattpreis zu sehen, weil ein Besucher hat ja noch keine Kundengruppe?

a.) Im Backend anzeigen geht nicht.

b.) dazu müsste man als Kunde eigentlich eingeloggt sein

1 Like

@brettvormkopp schrieb:

Kann es sein, dass der Kunde (Kundengruppe) sich erst einloggen muss um den Rabattpreis zu sehen, weil ein Besucher hat ja noch keine Kundengruppe?

a.) Im Backend anzeigen geht nicht.

OK, damit könnte ich leben. 

b.) dazu müsste man als Kunde eigentlich eingeloggt sein

**Wenn ich den Shop aufrufe, ohne eingeloggt zu sein (als Endverbraucher), dann sehe ich den richtigen Preis. Suche ich aber nach dem Artikel im „Suche“ Feld, wird er mir mit den falschen 378,54 (Basispreis + MwSt.)​ angezeigt. 

Habe gerade geschaut: Es ist egal ob ich als Endverbraucher eingeloggt bin oder nicht, das Problem bleibt gleich…**
 Der Rabatt läuft ja auch über die Preisgruppe und nicht über die Kundengruppe. 

 

Ich drehe echt bald durch mit der Preisgestaltung…

Im Artikel selbst ist aber die Preisgruppe aktiv UND Preisgruppe zugeordnet?

Ausserdem: der Artikel braucht einen Lagerbestand! Sieht für mich aus wie ein Bug weil in der Suche wird es mit Rabatt angezeigt, auf der Detailseite nicht.

Bei der Preisgruppeneinstellung brauchst du auch eine Artikelanzahl größer als 0 sonst löscht sich der Rabatt wieder raus.

1 Like

@brettvormkopp schrieb:

Im Artikel selbst ist aber die Preisgruppe aktiv UND Preisgruppe zugeordnet?

Ja, beides korrekt.

Ausserdem: der Artikel braucht einen Lagerbestand!

Lagerbestand knapp 500 

Sieht für mich aus wie ein Bug weil in der Suche wird es mit Rabatt angezeigt, auf der Detailseite nicht.

Achtung, es ist wie oben beschrieben umgekehrt: In der Suche wird der Rabatt aus der Produktgruppe NICHT angewendet (378,54 €) , auf der Detailseite ist der Preis korrekt (208,20€). Aber mir nützt es halt nichts, wenn dem Kunden in der Suche ein hoher Preis angezeigt wird, der in Wirklichkeit viel niedriger ist. Dann ist er vertsändlicherweise gleich wieder weg…   

Bei der Preisgruppeneinstellung brauchst du auch eine Artikelanzahl größer als 0 sonst löscht sich der Rabatt wieder raus.

Anzahl der Artikel ist, siehe oben, knapp 500 

Hallo zusammen,

das Problem wurde gelöst: Es war das Plugin DK Search im Einsatz, damit ich nach verschiedenen Feldern suchen konnte. Dort war ein Bug drin, der die Produktgruppen nicht beachtet hatte. Der Fehler wurde behoben, das Plugin bekam heute früh ein Update. Jetzt funktioniert es. 

Ja, sorry, ist mir gerade aufgefallen, hätte ich vielleicht auch angeben müssen, dass ich das Plugin verwende. Hätte vielleicht geholfen. 

Trotzdem vielen Dank. Auch an den Support von „Die Konkurrenz“, dem Hersteller des Plugins. 

Gruß headwork55