Fehlermeldung und Verständnisfrage bei der Installaion von SW6 RC2

Guten Abend,

ich muss mich jetzt doch an euch wenden. Bisher bin ich mit SW immer gut klar gekommen usw. auch was die Installation und ähnliches angeht.
Aber diesmal will es mir einfach nicht gelingen es ordentlich zum Laufen zu bringen.

Ich habe bei All Inkl. ein Paket was bisher super funktioniert und auch für meine Zwecke erstmal ausreicht.
Ich habe SW6 CE Edition runtergeladen und mit Filezilla übertragen, dabei kam es schon zu 18 Fehler mit zu langen Namen.
Diese habe ich kurz umbenannt und dann konnte ich sie kopieren.

 

Ich weiß man kann sich auch Leute für solche Sachen suchen aber ich bastle gerne und lerne nie aus, daher würde ich das gerne verstehen und selber machen.

Laut Installationsanleitung sollen ggf. die Routing-Einstellungen angepasst werden. Wann sollen diese angepasst werden, das verstehe ich nicht ganz und wenn ja wo/wie?
Anschließend heißt es in der Anleitung das die URL des Shops aufgerufen werden soll um die Installation zu beginnen.

 

Ich denke damit ist www.domain-name.de gemeint, da bekomme ich einen 403-Fehler.
Also habe ich mir die Verzeichnisse angeschaut und bin in …/public fündig geworden.
Dort war eine index.php die ich uber www.domain-name.de/public aufgerufen habe. Die Installation begann und wurde problemlos durchgeführt.

 

Im Anschluss konnte ich mich auch im Admincenter anmelden und mir das Backend betrachten.
Allerdings lies sich der Shop selber nicht aufrufen. Wenn ich www.domainname.de aufrufe bekomme ich immer einen 403-forbidden Fehler.
Ich denke das hat was mit der Routing-Einstellung vom Anfang zu tun.

 

Mein nächster Gedanke war erneut www.domainname.de/public aufzurufen um weiterzukommen aber da erhalte ich nur noch die Fehlermeldung siehe Ende.

Ich habe das ganze nochmal komplett von vorne begonnen aber auch da komme ich wieder genau dieselben „Ergebnisse“.

Ich hoffe Ihr könnt mir weiterhelfen. Gerne würde ich mir SW6 mal näher anschauen.
Ansonsten steige ich wieder auf die 5.xx um die hatte ich ohne weiteres zum laufen bekommen und auch angepasst,

 

Danke und schöne Feiertage

 

Unable to find a matching sales channel for the request: http://www.domain-name.de/public/". Please make sure the domain mapping is correct.

    Exception Stack Trace 

Shopware\Storefront\Framework\Routing\Exception\ SalesChannelMappingException
in /www/htdocs/w00ecf8b/domain-name.de/vendor/shopware/storefront/Framework/Routing/RequestTransformer.php (line 98)

            $salesChannel = $this->findSalesChannel($request);
            if ($salesChannel === null) {
                // this class and therefore the "isSalesChannelRequired" method is currently not extendable
                // which can cause problems when adding custom paths
                throw new SalesChannelMappingException($request->getUri());
            }
            $absoluteBaseUrl = $this->getSchemeAndHttpHost($request) . $request->getBaseUrl();
            $baseUrl = str_replace($absoluteBaseUrl, '', $salesChannel['url']);

RequestTransformer->transform(object(Request)) in /www/htdocs/w00ecf8b/domain-name.de/public/index.php (line 92)

        $container = $kernel->getContainer();
        // resolves seo urls and detects storefront sales channels
        $request = $container
            ->get(RequestTransformerInterface::class)
            ->transform($request);
        $enabled = $container->getParameter('shopware.http.cache.enabled');
        if ($enabled) {
            $store = $container->get(CacheStore::class);

 

Also bei Shopware 6 isf es wichtig, dass deine Domain nicht auf den Ordner von Shopware zeigt, sondern auf den public-Ordner der Installation. Sonst musst du das /public überall mit angeben.

Am besten schaust du mal in den Sales-Channel wie die Domain da angegeben ist. Wenn muss da auch die URL mit /public stehen. Wenn du die Domain auf /public routest, steht die da ohne /public in der Url.

Hallo Moritz,

vielen Dank für deine Antwort.

 

Als ich die Installation durchgeführt hatte und kurz im Backend war hatte ich das gesehen das /public mit hinterlegt war.
So konnte ich ja auch kurz den Shop sehen, also mit …de/public. Aber so will ich das ja nicht haben. Soll ja ohne /public laufen.

Daher ja auch mein Gedanke mit der Routing anpassen so wie es auch in der Anleitung steht. Da habt ihr ja ein Beispiel angehangen.

 ServerName "_HOST_NAME_" 
 DocumentRoot _SHOPWARE_DIR_/public 

  
  Options Indexes FollowSymLinks MultiViews 
  AllowOverride All 
  Order allow,deny 
  allow from all 
  

 ErrorLog ${APACHE_LOG_DIR}/shopware-platform.error.log 
 CustomLog ${APACHE_LOG_DIR}/shopware-platform.access.log combined 
 LogLevel debug 

Ist das dann eine Datei oder wie/wo wird das angepasst. (Ordner anpassen usw. ist klar)

Ich denke es ist so gedacht. Dateien auf Server kopieren und dann www.domainname.de ohne /public aufrufen und der angepasste Code oben leitet dann auf den /public Ordner weiter und führt dann die Installation durch.

Einige werden sich jetzt die Haar raufen und denken, lass sein wenn du keine Ahnung hast aber ich versuche das zu verstehen und zu lernen.

 

Werde es gleich nochmal installieren und schauen ob ich es ohne Fehlermeldung zum laufen bekommen.

@klamottenkiste24 schrieb:

 

Ist das dann eine Datei oder wie/wo wird das angepasst. (Ordner anpassen usw. ist klar)

Das wird grundsätzlich auf dem Server zur Domain angepasst. Da muss dann auch in keiner Datei mehr rumgefummelt werden. Da müsstest Du dann bei Deinem Paket bei „AllesInklusive“ die Domain so konfigurieren dass sie auf /public zeigt. Leider kenne ich das dortige AdminPanel nicht, sodass ich nicht sagen kann wie das dort gemacht wird, könnte aber das hier sein: Anleitungen, KAS, Domain, Einstellungen bearbeiten: Einstellungen Übersicht

1 Like

@kulli‍ vielen Dank für den Hinweis. Das fiel mir auch gerade direkt ein, als du sagtes es muss im Adminpanel eingestellt werden. 
Das schaue ich mir nachher nochmal an.

Danke

Guten Abend zusammen,

ich habe gestern SW6 Installiert und bin allmählich am verzweifeln. Hat jemand eine Idee?

Startverzeichnis: /shopware6/public

 

Shopware\Storefront\Framework\Routing\Exception\ SalesChannelMappingException

 

shopware6/vendor/shopware/storefront/Framework/Routing/ RequestTransformer.php (line 120)

 

shopware6/vendor/shopware/core/ HttpKernel.php -> transform (line 140)

 

shopware6/vendor/shopware/core/ HttpKernel.php -> doHandle (line 77)

 

HttpKernel->handle(object(Request)) in shopware6/public/ index.php (line 83)

 

 

@klamottenkiste24 schrieb:

Ich denke damit ist www.domain-name.de gemeint, da bekomme ich einen 403-Fehler.

 

Wir hatten diese Woche mit Shopware 6.1.4 ebenfalls einen 403-Fehler. Nach Rücksprache mit unserem Hoster lag es an automatisch (?) falschen Datei- und Ordnerberechtigungen. Wir konnten das über SSH wie folgt lösen:

Per SSH geht dies elegant und schnell über folgende Befehle:

_find . -type f -exec chmod 644 {} \;_ 

Dieser Befehl setzt die Berechtigungen sämtlicher Dateien des aktuellen Ordners und aller Unterordner auf 644.

_find . -type d -exec chmod 755 {} \;_ 

Dieser Befehl setzt die Berechtigungen sämtlicher Unterordner des aktuellen Verzeichnisses auf 755.

 

Vielleicht hilft diese Lösung ja dem einen oder anderen!

 

@mrtwin schrieb:

 

Startverzeichnis: /shopware6/public

 

Startverzeichnis für die Domain wäre /public 

und:

Alles so gemacht.

Ganz merkwürdig!

Die Fehlermeldung kommt unter https://meineseite.de/ ,

unter https://www.meineseite.de/ klappt alles ganz normal!

Ich verzweifel langsam. Der Host anbieter hat keine Lösung!

Hier noch jemand eine Idee?

Dann ist die Domain serverseitig nicht richtig konfiguriert (bevorzugte Domain: mit/ohne www. etc.)