Fehler nach Installation mit OneClick Installer

Hallo Leute,

ich habe aktuell meinen Shop auf WordPress Basis und möchte Shopware auf einer Subdomain testen: test.lagon-shop.de

Allerdings kommt nach der Installation folgender Fehler:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

 

Kann mir jemand sagen woran das liegt? Eventuell daran, dass ich nur eine MySQL Datenbank habe?

Vielen Dank im Voraus

An der Datenbank sollte es nicht liegen, Shopware hat mit MySQL keine Probleme.

Welchen Installer hast du denn verwendet, was ist das für ein Server und sieht die „config.php“ unter httpdocs in Ordnung aus?

habe den oneinstaller benutzt, bei dem man nur eine index.php hochlädt und dann die domain aufruft.

der server liegt bei 1&1 und ist eigentlich für wordpress gebucht.

@PStadtfeld schrieb:

An der Datenbank sollte es nicht liegen, Shopware hat mit MySQL keine Probleme.

Welchen Installer hast du denn verwendet, was ist das für ein Server und sieht die „config.php“ unter httpdocs in Ordnung aus?

Habe nochmal die config.php durchgeschaut und alle Daten zur Datenbank sind korrekt. Verstehe also das Problem leider nicht. 

EDIT:

habe einfach in der url statt test.lagon-shop.de/recovery/install noch die /index.php hinzugefügt und dann hat der installer gestartet. 

Jetzt funktioniert zumindest der Frontend, aber die gleiche Meldung wie oben kommt jetzt wenn ich /backend aufrufen möchte…

Würde /backend/index.php auf Basis deiner Frontend-Erfahrung auch funktionieren?

Das klingt insgesamt eher merkwürdig… Liegt in deinem Verzeichnis eine htaccess-Datei die vielleicht ein wenig banane Anweisungen enthält?
Die würde ich vielleicht mal rausnehmen oder mit einer aktuellen Shopware htaccess abgleichen

 

 

Das hatte ich letztens auch. Bei 1&1 muss in der .htaccess Datei folgendes geändert werden:

Von

#RewriteBase /shopware/

zu

RewriteBase /

(Also “#” entfernen und “/shopware/” zu “/” ändern.)

Viele Grüße

1 Like

@simkli schrieb:

Das hatte ich letztens auch. Bei 1&1 muss in der .htaccess Datei folgendes geändert werden:

Von

#RewriteBase /shopware/

zu

RewriteBase /

(Also “#” entfernen und “/shopware/” zu “/” ändern.)

Viele Grüße

Vielen Dank das hat geklappt, aber jetzt hab ich das Problem, dass ich es nicht schaffe den ioncube loader zu installieren…

Hast du hierfür auch einen Tipp bei 1und1? 

Das hat der Kunde bei uns übernommen. Der hat uns keinen Zugriff zum ControlPanel gegeben.
Aber vielleicht hilft dir das: https://hilfe-center.1und1.de/hosting/1und1-webhosting-c10085285/skript--und-programmiersprachen-c10082634/php-c10082686/bedienung-c10082739/ioncube-loader-installieren-a10790155.html

Viele Grüße

1 Like

@simkli schrieb:

Das hat der Kunde bei uns übernommen. Der hat uns keinen Zugriff zum ControlPanel gegeben.
Aber vielleicht hilft dir das: https://hilfe-center.1und1.de/hosting/1und1-webhosting-c10085285/skript–und-programmiersprachen-c10082634/php-c10082686/bedienung-c10082739/ioncube-loader-installieren-a10790155.html

Viele Grüße

Ja die Seite hab ich schon gesehen und habe die Anleitung befolgt aber dann kommt folgender Fehler:

"Please note that the following problem currently exists with the ionCube Loader installation:

  • The necessary zend_extension line could not be found in the configuration."

Obwohl ich die php.ini mit dem Befehl hochgeladen habe und über PuTTY in alle Unterverzeichnisse verlinkt habe.

Die ioncube Datei für die passende PHP Version ist auch hochgeladen und die Pfade stimmen eigentlich auch alle, aber ich komme gerade nicht weiter.