Fehler mit Plugin "Custom Products" von Shopware

Hallo, wir haben bei uns für die Individualisierung von vielen Produkten das Plugin „Custom Products“ im Einsatz. Hier gab es bislang nie Probleme. Das Plugin soll laut Store auch für die aktuelle Version 5.02 tauglich sein. Dem scheint aber nicht so. Sobald wir dieses Plugin aktivieren gibt es folgende Probleme: - die Produktbilder (wenn mehr als eins) lassen sich nicht mehr wechseln und ansehen - man kann in dem responsive Template von Shopware auch nicht mehr die Laschen rechts und links in einem Artikel nutzen um vor oder zurück zu springen (sind einfach nicht mehr da) - Das Template der Artikel Detailansicht ist zerschossen - keine Ansicht mehr von „Ähnliche Artikel Kunden kauften auch“ - keine Ansicht mehr von „Kunden haben sich ebenfalls angesehen“ - bei beidem letzteren gibts auch dann keine Bilder mehr Kann jemand das ganze reproduzieren oder hat hierfür eine Lösung? Installiert ist das Modul in der aktuellen Version 1.3.6 unter Shopware 5.0.2 Gruß Sandra

Hallochen! Ich häng mich mal hier dran. Ich war ja gerade mal geschockt. Wir haben die Testversion des Custom Products ebenfalls in unserem 5.0.2 testshop in einsatz. Ich habe die Gruppe sowie die Option dazu konfiguriert und die Gruppe dem Produkt hinzugewiesen. Im Frontend sehe ich das Custom Produkt Feld aber nicht. Ein Blick in den Quellcode zeigt mir folgenden Fehler: Uncaught ReferenceError: jQuery is not defined Ähem, wuut? Ich meine das ist ein Shopware eigenes Plugin, ein sehr teures dazu. Laut Account ist die Version von Custom Products 1.3.6 mit der 5.0.2 kompatibel. Der Fehler zeigt aber deutlich das hier ebenfalls inline JQuery verwendet wird, welches zu früh aufgerufen wird. Also wie kann das kompatibel mit der 5.0.2 version sein? @Sandra, hast du denn auch eine Fehlermeldung im Shop?

1 Like

Gibt auch Ticket in der Jira dazu, habe das mal upgevoted, hier zu finden: http://jira.shopware.de/?ticket=PT-3473

1 Like

[quote=„shopbesitzer“]@Sandra, hast du denn auch eine Fehlermeldung im Shop?[/quote] Hallo Shopbesitzer, nein eine Fehlermeldung haben wir nicht. Nur ein zerschossenes Template (original von Shopware) wenn wir das Plugin aktivieren. Wie Du schon sagst, es ist nicht billig. Umso stinkiger bin ich. Gerade die hauseigenen Plugins sollten wohl fehlerfrei sein. Aber das kenne ich ja bereits von bepado.

Hallo, soweit ich das sehe ist das Update schon in Arbeit und läuft über ein anderes Ticket. Kann da nächste Woche mal nachhören, wie da der Status ist. Das Problem tritt aktuell nur in der 5.0.2 auf. Grüße Moritz

1 Like

Hallo Moritz, vielen Dank. Das lässt hoffen :wink:

prima! Welches Ticket ist das?

Gibt es da schon ein Update dazu? Wenn ich mir die offenen Bug-Tickets zum Custom Products in der jira anschaue, überlege ich mir wirklich, ob sich das ganze lohnt… :frowning:

Also erstmal danke für das Update! Nun sehe ich das Feld mit den Custom products immer noch nicht im Shop. Im Frontend gibt es zwar keine Fehlermeldung, aber das Textfeld zu meinem Produkt sehe ich jetzt immer noch nicht. Das Feld ist aktiviert, konfiguriert und auch dem Produkt zugewiesen. Beim Produkt selbst ist es aktiviert. Das Theme habe ich nach dem update erneut kompilliert und die gesamten Cache gelöscht. Habe jeweils mit dem default responsive sowie unseren anpassungen probiert, keine Änderung Das Bare theme kann ich nicht aktivieren: ährend der Bearbeitung von Shop "Hauptshop Deutsch" ist ein Fehler aufgetreten: variable @text-color-dark is undefined in file .../engine/Shopware/Plugins/Default/Frontend/AdvancedMenu/Views/frontend/\_public/src/less/advanced-menu.less in advanced-menu.less on line 3, column 22 1| // Advanced menu container that contains every category listing 2| 3| @adv-menu-header-bg: @text-color-dark; 4| @adv-menu-header-text-color: @btn-secondary-text-color; 5| @adv-menu-bg: @btn-secondary-text-color; 6| @adv-menu-text-color: @text-color-dark; :cry:

Hallo, das Bare Theme kannst du nicht ohne weiteres einfach nutzen, dort fehlen allerlei Definitionen die von Plugins gebraucht werden. Das Standardtemplate in Shopware ist das Responsive-Template. Dein eigenes Template leitet ja davon ab. Wenn du also das Responsive startest, sollte Custom products angezeigt werden. Deine individuellen Anpassungen solltest du nie direkt am Responsive vornehmen. Wenn das Feld bei dir nicht angezeigt wird, dann ist ggf. die Gruppe oder die Option nicht aktiv. Weitere Ursachen können natürlich andere Plugins und Theme-Anpassungen sein. Grüße Moritz