Fehler Meldung - Theme Manager - 503 - Service Unavailable

Hi und sorry, dass ich mal eure Hilfe brauche.

Leider bin ich an der Stelle nicht so der Profi und vielleicht ist die Lösung auch total einfach aber irgendwie stehe ich auf dem Schlauch.

Zuerst einmal würde ich Euch den Umstand schildern und am Ende die Fehlermeldung macl dranhängen.

Wir haben uns für die testversion des Exquisite Theme entschieden, die bis zum 29.06. läuft (lief). (hat sich scheinbar jetzt selbst deinstalliert)  Zusätzlich haben die Kollegen heute morgen zwei Plug Ins instlliert (DHL Wunschpaket und  Marketplace Connector) beide wurden nach auftreten des Fehlers erst einmal deinstalliert. Denn seit Mittag kommen wir auf einmal nicht mehr in den Theme Manager. Da erscheint dann der Fehler 503 und das Fenster bleibt leer. 

Sollte selbst wenn das Theme heute ausläuft, sollte dann nicht zumindest der Manager ohne Probleme laufen? Was kann ich ggf. machen? Vielleicht sieht einer von Euch das Problem für das ich zu blöd bin :-) 

Ich Danke Euch schon einmal vielmals für eure Hilfe 


Theme Manager:

503 - Service Unavailable

Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. Parent ExquisiteTheme of theme WaffenladenthemeWareDemo not found in engine/Shopware/Components/Theme/Installer.php on line 390 Stack trace: #0 engine/Shopware/Components/Theme/Installer.php(165): Shopware\Components\Theme\Installer->setParents(Array) #1 engine/Shopware/Components/Theme/Installer.php(130): Shopware\Components\Theme\Installer->synchronizeThemes() #2 engine/Shopware/Controllers/Backend/Theme.php(195): Shopware\Components\Theme\Installer->synchronize() #3 engine/Library/Enlight/Controller/Action.php(193): Shopware_Controllers_Backend_Theme->listAction() #4 engine/Library/Enlight/Controller/Dispatcher/Default.php(549): Enlight_Controller_Action->dispatch(‚listAction‘) #5 engine/Library/Enlight/Controller/Front.php(222): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #6 engine/Shopware/Kernel.php(215): Enlight_Controller_Front->dispatch() #7 vendor/symfony/http-kernel/HttpCache/HttpCache.php(486): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #8 engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #9 vendor/symfony/http-kernel/HttpCache/HttpCache.php(253): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #10 engine/Shopware/Components/HttpCache/AppCache.php(105): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #11 shopware.php(122): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #12 {main}  

Die Meldung sagt, dass das Theme was aktuell aktiv ist, auf dem gelöschten Theme basiert. Das kann natürlich nicht funktionieren.

Du müsstest hier per FTP die theme.php anpassen. Also /themes/frontend/WaffenladenthemeWareDemo/theme.php.

Dort musst du dann das extend ändern, damit es vom Standard-Theme ableitet, bspw so:

    protected $extend = 'Responsive';

 

1 Like

Dickes Danke für die schnelle Hilfe, leider hat sich nichts verändert. Frontend wie Backend nicht. Könnte es ggf. an einem Plug In gelegen haben oder tatsächlich das Theme?

Laut Fehlermeldung liegt es am Theme.

Hast du mal den Cache geleert?

Ja, dass war das aller erste was wir gemacht hatten. Wir haben auch versucht mal auf die Standardeinstellung zu setzen aber das klappt auch nicht und dann bleibt die Fehlermeldung beim Theme-Manager leer.

 

Naja, im Zweifel mal testweise den Theme-Ordner löschen.

Am besten vorher ein Backup machen.

Danke dir, dass wird die letzte Möglichkeit sein. Denn es klappt auch nicht wenn man testweise ein neues Plugin lädt und aktiviert! Man kommt nicht in den Manager! 

Ist echt komisch, ist so ein Fehler schon öfter mal aufgetreten? Oder hab ich gerade echt nur Pech :slight_smile: :smiley:

 

Naja, wenn du ein Theme hast, was auf einem Plugin basiert und diese Basis nicht mehr existiert, dann erzeugt das einen Fehler. In diesem Fall reicht es aber eigentlich aus über die theme.php die Ableitung zu ändern. Weiß nicht warum es bei dir hängt.

Der gezeigte Fehler im Theme Manager wird häufig durch mangelnde Server-Ressourcen ausgelöst, zB wenn viele Themes ‚getestet‘ werden. Hier finden sich umfassende Informationen und Lösungsansätze zu diesem Problem: https://help.tc-innovations.de/support/solutions/articles/29000016476-fehler-500-communication-failure-es-werden-keine-themes-angezeigt-im-theme-manager

@Moritz Naczenski schrieb:

Die Meldung sagt, dass das Theme was aktuell aktiv ist, auf dem gelöschten Theme basiert. Das kann natürlich nicht funktionieren.

Du müsstest hier per FTP die theme.php anpassen. Also /themes/frontend/WaffenladenthemeWareDemo/theme.php.

Dort musst du dann das extend ändern, damit es vom Standard-Theme ableitet, bspw so:

protected $extend = ‚Responsive‘;

 

Super vielen Dank. Das hat mir unendlich geholfen. Danke, danke, danke