Fehler bei Shopseiten

Hallo liebe Shopware Community

Ich habe Heute das Update auf 5.2 durchgeführt und musste leider feststellen, dass nach der Installation der Menüpunkt Inhalte -> Shopseiten ein Fehlerreport anzeigt.
Es wird folgendes erwähnt:

​Ups! Ein Fehler ist aufgetreten!

Die nachfolgenden Hinweise sollten Ihnen weiterhelfen.

Unable to load template snippet 'backend/site/model/attribute.js' in 'snippet:string:{include file="backend/site/model/nodes.js"}
{include file="backend/site/model/groups.js"}
{include file="backend/site/model/selected.js"}
{include file="backend/site/model/attribute.js"}
{include file="backend/site/view/main/window.js"}
{include file="backend/site/view/site/tree.js"}
{include file="backend/site/view/site/form.js"}
{include file="backend/site/view/site/group_dialog.js"}
{include file="backend/site/store/nodes.js"}
{include file="backend/site/store/groups.js"}
{include file="backend/site/store/selected.js"}
{include file="backend/site/store/shop.js"}
{include file="backend/site/controller/tree.js"}
{include file="backend/site/controller/form.js"}
{include file="backend/site/controller/main.js"}' in engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php on line 127
Stack trace:

#0 engine/Library/Smarty/sysplugins/smarty_internal_template.php(286): Smarty_Internal_TemplateBase->fetch(NULL, NULL, NULL, NULL, false, false, true)
#1 var/cache/production_201607011315/templates/backend_de_DE_79a01/c1/fc/e8/c1fce82bcaf9ecdb54dd60b183190422b556c005.snippet.7a38ee8668bcfeb388c2ce551c8bf37cd0ddfedf.php(28): Smarty_Internal_Template->getSubTemplate('backend/site/mo...', NULL, 'backend_de_DE_7...', NULL, NULL, Array, 0)
#2 engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php(180): content_577a1418298cc4_91391315(Object(Enlight_Template_Default))
#3 engine/Library/Enlight/View/Default.php(274): Smarty_Internal_TemplateBase->fetch()
#4 engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(216): Enlight_View_Default->render(Object(Enlight_Template_Default))
#5 engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(242): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->renderTemplate(Object(Enlight_Template_Default))
#6 engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(136): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->render()
#7 [internal function]: Enlight_Controller_Plugins_ViewRenderer_Bootstrap->onPostDispatch(Object(Enlight_Controller_ActionEventArgs))
#8 engine/Library/Enlight/Event/Handler/Default.php(91): call_user_func(Array, Object(Enlight_Controller_ActionEventArgs))
#9 engine/Library/Enlight/Event/EventManager.php(214): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs))
#10 engine/Library/Enlight/Controller/Action.php(202): Enlight_Event_EventManager->notify('Enlight_Control...', Object(Enlight_Controller_ActionEventArgs))
#11 engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight_Controller_Action->dispatch('loadAction')
#12 engine/Library/Enlight/Controller/Front.php(226): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp))
#13 engine/Shopware/Kernel.php(175): Enlight_Controller_Front->dispatch()
#14 vendor/symfony/http-kernel/HttpCache/HttpCache.php(487): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#15 engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)
#16 vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true)
#17 engine/Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true)
#18 shopware.php(101): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request))
#19 {main}

Weiss jemand was ich falsch gemacht habe oder wieso das jetzt dieser Fehler auftaucht?

Bedanke mich jetzt schon herzlichst für eure Antworten.

Hi,

die Datei „backend/site/model/attribute.js’“ existiert in 5.2 nicht mehr, da diese durch das neue Attribut-System abgelöst wurde. Hast du den Cache einmal komplett geleert? Es wäre möglich, dass das gecachte Backend diese Datei noch anfragt. Oder gibt es vielleicht Plugins o.ä. die darauf zugreifen?

Besten Gruß,

Daniel

Vielen Dank für die Schnelle Antwort Daniel.

Habe ich gleich ausprobiert und leider liegt das Problem immer noch vor. Habe das Freitextattribute Plugin von Shopware installiert, dieses gelöscht und Chache demensprechend gelöscht. 

Werde mich nochmals durch die Plugins arbeiten und schauen ob doch noch eines vorhanden ist, welches auf diese Informationen zugreift.
 

Habe das gleiche Problem und auch alles Caches gelöscht. Ohne Erfolg. Das Responsive-Theme funktioniert nur mein eigenes nicht. Sobald ich eine Lösung finde werde ich diese hier posten.

Hallo. Wir evaluieren gerade wodurch dieses Problem im Update Paket besteht. Als zwischenzeitlichen Fix könnt ihr unter themes/Backend/ExtJs/backend/site die app.js anpassen und bei den Models das Attribute model entfernen. Dieses wird fälschlicherweise versucht zu laden. Anschließend noch einmal den Cache leeren. Das sollte helfen.

Viele Grüße

Holger

3 Likes

Habe das gleiche Problem. Es scheint ein include ein den Template-Dateien des Backends fehlzuschlagen. Schon jemand herausgefunden, wo?

Den Fix werde ich testen

 

UPDATE: Fix hilft, besten Dank

Tagchen. 

Habe da entweder das selbe oder ein verwandtes Problem. 

Nach dem Update von 5.1.6 auf 5.2.1 will mein Theme nicht mehr so recht.

Das Theme kompiliert zwar allerdings kommt im Frontend trotzdem der Fehler “Ups! Ein Fehler ist aufgetreten!”.

Log sagt ebenfalls:

[2016-07-06 12:46:29] core.ERROR: Reverse proxy returned invalid status code {"uid":"23517d2"}
[2016-07-06 12:51:13] core.ERROR: Reverse proxy returned invalid status code {"uid":"ed8db25"}
[2016-07-06 12:51:20] core.ERROR: Reverse proxy returned invalid status code {"uid":"71ff424"}
[2016-07-06 12:51:20] core.ERROR: Reverse proxy returned invalid status code {"uid":"71ff424"}
[2016-07-06 12:51:40] core.ERROR: Reverse proxy returned invalid status code {"uid":"c8e92ef"}
[2016-07-06 13:05:21] core.ERROR: Reverse proxy returned invalid status code {"uid":"7cfa6f9"}
[2016-07-06 13:05:21] core.ERROR: Reverse proxy returned invalid status code {"uid":"7cfa6f9"}
[2016-07-06 13:05:44] core.ERROR: Reverse proxy returned invalid status code {"uid":"10f53a5"}
[2016-07-06 13:08:23] core.ERROR: Reverse proxy returned invalid status code {"uid":"db2a42b"}
[2016-07-06 13:08:23] core.ERROR: Reverse proxy returned invalid status code {"uid":"db2a42b"}
[2016-07-06 13:09:07] core.ERROR: Reverse proxy returned invalid status code {"uid":"aadc42e"}
[2016-07-06 13:13:10] core.ERROR: Reverse proxy returned invalid status code {"uid":"de6dd99"}
[2016-07-06 13:13:30] core.ERROR: Reverse proxy returned invalid status code {"uid":"704d612"}
[2016-07-06 13:18:25] core.ERROR: Reverse proxy returned invalid status code {"uid":"b8e9dd7"}
[2016-07-06 13:18:25] core.ERROR: Reverse proxy returned invalid status code {"uid":"b8e9dd7"}
[2016-07-06 13:18:44] core.ERROR: Reverse proxy returned invalid status code {"uid":"0cd318a"}
[2016-07-06 13:21:45] core.ERROR: Reverse proxy returned invalid status code {"uid":"28b89e4"}
[2016-07-06 13:21:45] core.ERROR: Reverse proxy returned invalid status code {"uid":"28b89e4"}
[2016-07-06 13:23:21] core.ERROR: Reverse proxy returned invalid status code {"uid":"0c8a655"}
[2016-07-06 13:26:04] core.ERROR: Reverse proxy returned invalid status code {"uid":"6a48682"}
[2016-07-06 13:26:04] core.ERROR: Reverse proxy returned invalid status code {"uid":"6a48682"}
[2016-07-06 13:26:24] core.ERROR: Reverse proxy returned invalid status code {"uid":"5a587de"}
[2016-07-06 13:27:34] core.ERROR: Reverse proxy returned invalid status code {"uid":"4e4db83"}
[2016-07-06 13:27:54] core.ERROR: Reverse proxy returned invalid status code {"uid":"35a9e94"}
[2016-07-06 13:29:21] core.ERROR: Reverse proxy returned invalid status code {"uid":"98fd985"}
[2016-07-06 13:30:46] core.ERROR: Reverse proxy returned invalid status code {"uid":"e04d4a4"}

In der app.js ist kein attribute mehr in den models.

Im Browserlog kommt der Feher:

Uncaught TypeError: Cannot read property 'ajax_add_article' of undefined

Einer ne Idee?

Bester Gruß

Philipp

*edit

liegt es vlt daran, dass ich im Shopware Account die Hauptdomain und nicht unsere für die Entwicklung genutzte Subdomain verwende?