Erweitertes Menü zeigt vertauschte Unterkategorien an

Hi,
ich habe folgendes Problem:
Angenommen ich habe die Hauptkategorien A und B, welche in der Hauptleiste angezeigt werden. Diese haben jeweils die Unterkategorien A1,A2 (A) und B1,B2 (B). Wenn ich jetzt mit der Maus über der Hauptkategorie hover, öffnet sich das erweiterte Menü. Es werden aber bei Kategorie A die Unterkategorien B1 und B2 angezeigt und bei Kategorie B entsprechen A1 und A2. D.h. die Unterkategorien werden jeweils vertauscht angezeigt.
Woran kann das liegen? Version ist 5.7.2. Das erste mal ist mir der Fehler nach dem Update auf 5.7 aufgefallen.

1 Like

Hi marioheaven,

das Verhalten kann ich so im Standard von Shopware nicht nachstellen, sprich in einer frischen Installation ohne Fremdplugins.

Prüfe doch bitte zunächst einmal ob Du das Verhalten noch feststellen kannst, wenn du den Cache löscht und das Theme neu kompilierst.

Solltest Du das Verhalten dennoch feststellen, würde ich Dir empfehlen einmal den Kategorie-Baum neu aufzubauen (Einstellungen > Cache / Perf. > Cache / Perf. > Einstellungen > Kategorien > Kategoriebaum neu aufbauen).

Hi Tobias,
folgende Dinge habe ich getan:

  • Cache gelöscht und Theme neu kompiliert
  • Kategoriebaum neu aufgebaut
  • Das erweiterte Menü neu installiert

Hat aber alles nichts gebracht. Die Unterkategorien werden weiterhin vertauscht angezeigt.

Edit: Hab nochmal die php-Version von 8 zurück auf 7.4 geändert. Das hat den Fehler behoben.

@marioheaven

Ok, gut das du das Problem beheben konntest. Ich werde nochmal bei mir prüfen, ob ich das Verhalten mit PHP8 reproduzieren kann.

Danke dir für das Feedback

Hast Du das eigentlich gelöst? Habe mit PHP 8 exakt das gleiche Problem

Hallo @marioheaven ,
das Problem tritt bei mir ebenfalls auf und ich konnte bislang keine Lösung finden. Theme und Plugins habe ich ergebnislos getestet und da ich nicht auf php 7.4 zurückwill, verzichte ich auf das erweiterte Menü :frowning:

Gruß Armin

Kann ich auch bestätigen das das Problem nur bei php8 auftritt.
Gruß Volker

Hallo !

Das Problem mit PHP8 und dem erweiterten Menü besteht ja immer noch. Gibts da immer noch keine Lösung ?

Gruß
Michael