Error code: PluginLicensesException-3

Hallo, ich habe momentan ein Shopware 5.0.2 im Einsatz. Ich wollte heute PayPal Plus installieren allerdings erhalten ich folgende Fehlermeldung: Der übergebene Referenz Shop konnte vom SBP-Server nicht ermittelt werden. Error code: PluginLicensesException-3 Ich habe bereits gelesen, dass es daran liegen kann, dass die Domain des Shops nicht mit der in meinem Account überein stimmt. Dies ist leider bei mir so, da wir die Domain gewechselt haben. Ich wollte hier bereits die neue Domain eintagen allerdings bekomme ich hier immer einen Validierungsfehler :thumbdown:. Kann mir hier jemand weiterhelfen?

Hi, wenn du Probleme beim Lizenzumzug hast, wende dich besten eben an unseren Sales, die sollten dir da schnell helfen können. Daniel Gesendet von meinem SM-N910F mit Tapatalk

[quote=„Daniel Nögel“]Hi, wenn du Probleme beim Lizenzumzug hast, wende dich besten eben an unseren Sales, die sollten dir da schnell helfen können. Daniel Gesendet von meinem SM-N910F mit Tapatalk[/quote] Ich habe das gleiche Problem, allerdings habe ich keinen Domain-Umzug hinter mir. Shop ist neu aufgesetzt. Gibt es eine Möglichkeit die Logindaten, die erscheinen, wenn man im Plug in Manager „MEINE EINKÄUFE“ drückt noch einmal zu prüfen?

Ich habe dasselbe Problem 

Error

Der übergebene Referenz Shop konnte vom SBP-Server nicht ermittelt werden.

Error code: PluginLicensesException-3

Hab keinen URL wechsel gemacht, da ich den Shop erst eingerichtet habe?

Mathias

Hi,

gibt’s hierzu neues? Ich bekomme genau denselben Fehler bei dem Shop, den ich für den Produktivbetrieb einrichten wollte. (Bei einem anderen Testshop funktioniert es allerdings). History:

  1. Der Produktivshop wurde unter https://www.domain.de/subdir eingerichtet
  2. Da er noch nicht fertig eingerichtet ist, ist er meistens noch hinter einem http-basic-auth versteckt. Für die Registrierung etc. nehme ich die natürlich raus.
  3. Bei der Shopregistierung kann ich https://www.domain.de/subdir eingeben, bekomme einen Hash mitgeteilt. Diesen legen ich wie gefordert in einer sw-domain-hash.html ab. Manuell lässt sich die Datei abrufen, und ich bekomme auch einen grünen Haken bei der Verifizierung. Beim Abspeichern kommt dann aber die Fehlermeldung, das der Prozess nicht abgeschloßen werden kann.
  4. Ich habe hier im Forum den Tipp gefunden, https://www.domain.de verfizieren zu lassen, und danach die Registrierung nach …/subdir zu ändern. Und ja, ohne …/subdir (https://www.domain.de) konnte der erste Registrierungsprozess abgeschlossen werden. Das Ändern der Registrierung nach …/subdir (also https://www.domain.de/subdir) schlug aber fehl, so wie unter 3. beschrieben. In der Übersicht im Account steht der Shop allerdings jetzt trotzdem mit …/subdir drin. Scheint aber intern bei Shopware wirklich nicht funktioniert zu haben, weil…: Z.B. bei Klick auf “meine Käufe” kommt (immer noch) “Error - Der übergebene Referenz Shop konnte vom SBP-Server nicht ermittelt werden. - Error code: PluginLicensesException-3”

Somit kann ich leider weiterhin keine (dringend) benötigten Plugins installieren, die, obwohl kostenlos, eine solche korrekte Registrierung voraussetzen.

Wie bekomme ich das zum Laufen? Für mich stellt sich das so dar, als hätte SW ein Problem damit, Shops zu registrieren, die in Unterverzeichnissen liegen. (Der Testshop ist nicht in einem Unterverzeichnis installiert)

/Edit: SW-Version ist die derzeit aktuellste  Shopware 5.5.7  Build Rev 201902250948

Meines Wissens wird nur die Domain registriert und zwar genau so wie Sie aufgerufen wird (mit oder ohne www.), egal ob und in welchem Unterverzeichnis der Shop läuft. Da muss und darf man auch später kein Unterverzeichnis dran hängen. Die sw-domain-hash.html wird dabei im Hauptverzeichnis der Domain platziert.

Wenn man die Subdirs eintragen müßte, würde ja das ganze Testshopsystem in div. Unterverzeichnissen auch nicht funktionieren.

1 Like

Tastächlich, so funktionierts. Ok, das war mir so nicht klar.

Das könnte Shopware vielleicht etwas deutlicher beschreiben…