Error beim Speichern von Artikeln (4.3.1) (Datenbankfehler)

Hallo liebe Community, ich habe von 4.3.1 auf 4.3.2 geupdatet. Anschließend war mein Shop fehlerhaft. Zum Glück habe ich vor dem Update eine Sicherung gemacht. Nach dem Wiederherstellen des Shops inkl aller Konfigurationen gibt es nun trotzdem fehler. Zwar nicht mehr im Frontend, aber im Backend! Ich kann keine Artikel mehr bearbeiten. Artikel neu zu erstellen funktioniert ebenfalls nicht! Beim Neuerstellen bekomme ich abwechselnd diese zwei Fehlermeldungen: Fehlgeschlagen Während des Speicherns ist ein Fehler aufgetreten:An exception occurred while executing 'SELECT s0\_.id AS id0, s0\_.article\_id AS article\_id1, s0\_.unit\_id AS unit\_id2, s0\_.order\_number AS order\_number3, s0\_.suppliernumber AS suppliernumber4, s0\_.additionaltext AS additionaltext5, s0\_.active AS active6, s0\_.instock AS instock7, s0\_.stockmin AS stockmin8, s0\_.weight AS weight9, s0\_.width AS width10, s0\_.length AS length11, s0\_.height AS height12, s0\_.ean AS ean13, s0\_.position AS position14, s0\_.minpurchase AS minpurchase15, s0\_.purchasesteps AS purchasesteps16, s0\_.maxpurchase AS maxpurchase17, s0\_.purchaseunit AS purchaseunit18, s0\_.referenceunit AS referenceunit19, s0\_.packunit AS packunit20, s0\_.shippingfree AS shippingfree21, s0\_.releasedate AS releasedate22, s0\_.shippingtime AS shippingtime23, s1\_.id AS id24, s1\_.template\_id AS template\_id25, s1\_.customer\_group\_key AS customer\_group\_key26, s1\_.`from` AS from27, s1\_.`to` AS to28, s1\_.price AS price29, s1\_.pseudoprice AS pseudoprice30, s1\_.baseprice AS baseprice31, s1\_.percent AS percent32, s2\_.id AS id33, s2\_.groupkey AS groupkey34, s2\_.description AS description35, s2\_.tax AS tax36, s2\_.taxinput AS taxinput37, s2\_.mode AS mode38, s2\_.discount AS discount39, s2\_.minimumorder AS minimumorder40, s2\_.minimumordersurcharge AS minimumordersurcharge41, s3\_.id AS id42, s3\_.template\_id AS template\_id43, s3\_.attr1 AS attr144, s3\_.attr2 AS attr245, s3\_.attr3 AS attr346, s3\_.attr4 AS attr447, s3\_.attr5 AS attr548, s3\_.attr6 AS attr649, s3\_.attr7 AS attr750, s3\_.attr8 AS attr851, s3\_.attr9 AS attr952, s3\_.attr10 AS attr1053, s3\_.attr11 AS attr1154, s3\_.attr12 AS attr1255, s3\_.attr13 AS attr1356, s3\_.attr14 AS attr1457, s3\_.attr15 AS attr1558, s3\_.attr16 AS attr1659, s3\_.attr17 AS attr1760, s3\_.attr18 AS attr1861, s3\_.attr19 AS attr1962, s3\_.attr20 AS attr2063, s4\_.id AS id64, s4\_.template\_price\_id AS template\_price\_id65 FROM s\_article\_configurator\_templates s0\_ LEFT JOIN s\_article\_configurator\_template\_prices s1\_ ON s0\_.id = s1\_.template\_id LEFT JOIN s\_core\_customergroups s2\_ ON s1\_.customer\_group\_key = s2\_.groupkey LEFT JOIN s\_article\_configurator\_templates\_attributes s3\_ ON s0\_.id = s3\_.template\_id LEFT JOIN s\_article\_configurator\_template\_prices\_attributes s4\_ ON s1\_.id = s4\_.template\_price\_id WHERE s0\_.article\_id = ?' with params [173]: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'Shopware.s\_article\_configurator\_template\_prices\_attributes' doesn't exist Fehlgeschlagen Während des Speicherns ist ein Fehler aufgetreten:An exception occurred while executing 'INSERT INTO s\_articles\_details (articleID, unitID, ordernumber, suppliernumber, kind, additionaltext, active, instock, stockmin, weight, width, length, height, ean, position, minpurchase, purchasesteps, maxpurchase, purchaseunit, referenceunit, packunit, shippingfree, releasedate, shippingtime) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)' with params [174, null, "SW10173", "", 1, "", true, 0, 0, 0, null, null, null, "", 0, null, null, null, null, null, "", 0, null, ""]: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'SW10173' for key 'ordernumber' Beim bearbeiten steht nur da: „Ups! Wir sind bereits über diesen Fehler informiert und arbeiten daran. Bitte versuchen Sie es zu einem späteren Zeitpunkt noch einmal!“ (oder sinngemäß) Hat irgendjemand eine Idee, wie ich das wieder beheben kann? Ich habe in der Datenbank keine Tabellen gelöscht oder abgeändert. Daher ist es sehr verwunderlich, dass irgendwelche Tabellen fehlen…beim durchführen des Updates ging ebenfalls nichts schief. Das System lief vorher einwandfrei. Ich bin ratlos…

keiner eine Idee??

Habe die selbe Fehlermeldung gerade (die zweite von dir genannte, erste kam mir bisher nicht vor), hast du schon eine Lösung gefunden? Kann keine Artikel speichern.

bisher nichts! Außer über die Datenbank alles abzuändern, das funktioniert. Aber umständlicher gehts kaum…:wtf:

Hallo, Fehler dieser Art gab es hier ja schon häufig. Sind denn die Foreign-Keys schon einmal geprüft / repariert worden? http://wiki.shopware.com/Foreign-Keys-r … l_954.html Das Problem ist ja, wenn der komplette Cache geleert wurde, die Datenbank aber vorher schon defekt war, kann Shopware keinen neuen sauberen Attribute-Cache anlegen. Daher bringt in diesem Fall das Backup auch keine Abhilfe, da höchstwahrscheinlich die Fehler schon vorher vorlagen. Aufgrund des alten Caches aber nicht aufgefallen ist. Also am besten mal nach dem Wiki Artikel vorgehen Sebastian

1 Like

mach grade ein backup und dann wirds gleich probiert. wenn das funktioniert…das wär was! mach schon ewigkeiten damit rum