Erneut Probleme mit Updatefunktion von 5.26 auf 5.27

Hallo zusammen,

immer wieder misslingen Updates, daher habe ich mich auch noch nicht für die Bezahltversionen entschieden.

Es kommt diese Fehlermeldung:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@… to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

 

Ich bin nun echt am Verzweifeln, da ich nicht immer wieder langwierige Backups und Wiederaufspielung machen möchte, zumal auch diese nicht immer einwandfrei funktionieren.

Hat jemand eine Antwort für mich zu dem o.g. Fehler?

Das ist ja keine SW-Fehlermeldung, sondern die kommt vom Server.

Am besten besorgst du erstmal die konkrete Fehlermeldung: http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen_detail_1880.html#Frontend_Error_Reporter

Logisch, ist ja die einzige Meldung die ich erhalte

Der Fehler sagt überhaupt nichts aus. Mach mal was Moritz geschrieben hat.

Mal sehen, ob ich das hinbekomme. Ich hatte das gleiche Problem schon beim Update auf 5.2.26

Hi,

wenn das Problem schon mal aufgetreten ist, deutet das noch mehr auf ein Problem mit der Hosting-Konfiguration hin. Alle Systemvoraussetzungen sind aber erfüllt oder?

In der Fehlermeldung wird auch hingewiesen in die Logs zu schauen. Also in das Log des Servers. Da wird eher was passendes zu finden sein als im Shopware Log, da das Problem auch unabhängig von Shopware zu sein scheint.

Sebastian

1 Like

Ja, diese sind erfüllt. Habe meinen Anbieter angemailt, mal sehen.

More information about this error may be available in the server error log.

Warum wird da nicht nachgeschaut? 

Ja, schau’ mal im Error-Log der Website und auch in den Shopware-Logs nach.

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

Wenn ich nur diese Log-Dateien finden würde … Ich bin auch im Kontakt mit meinem Provider.

Inzwischen das Log gefunden?

Die Shop Log-Datei ist zu groß zum hier reinkopieren - ich erstelle die mal als PDF und lade diese auf meine Seite hoch.

@MichaSand schrieb:

http://letule.gmxhome.de/Log-Datei.pdfDie Shop Log-Datei ist zu groß zum hier reinkopieren - ich erstelle die mal als PDF und lade diese auf meine Seite hoch.

So mein Provider hat wohl etwas gefunden - was mich aber extrem wundert.

Sie haben hier ein Rechte Problem:

[Sat Aug 05 13:22:48.865312 2017] [:error] [pid 1746] [client 178.2.112.1…] SoftException in Application.cpp:261: File “/home4/kd32148/public_html/shop/recovery/update/index.php” is writeable by group

Die Dateiberechtigungen standen auf 666  - aber dies wird mir ja automatisch vom Update her so eingespielt. Bin nun unsicher, ob ich auf 755 ändern soll.

Bei Dateien sollte 644, bei Ordnern 755 passen.

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

1 Like

Danke für die Info - ja, das hat mir mein Provider gestern abend genannt. Es funktioniert nun wieder, nach langem Suchen.

Erstaunlicherweise wurde zudem im Ordner files ebenfalls ein update-ordner angelegt. Erst nachdem ich auch diesen gelöscht hatte, hat es funktioniert.

Ich frage mich nun aber hauptsächlich, warum die Dateirechte beim Update nicht richtig gesetzt werden! Somit würde ich beim nächsten Mal wieder Probleme bekommen.