Eigene Mail-Einstellungen für SubShops werden dann doch vom Haupt-Shop überschrieben

Hallo Forum,
ich habe Subshops eingerichtet und für jeden eigene SMTP Einstellungen/Zugangsdaten hinterlegt.

Beispiel
Hauptshop: DE - DomainFactory
SubShop: CH - Thurweb.ch

Die Bestellbestätigung vom CH Shop wird dann mit den SMTP-Einstellungen vom Main Shop versendet. Wieso werden nicht die Einstellungen der SubShops verwendet, wenn Sie ja richtig hinterlegt sind? Kann mir hier jemand weiterhelfen?

Fehlermeldung von Thurweb (Die Angabe smtprelay04.ispgateway.de ist DomainFactory)

  gigersbox@thurweb.ch
    host mail1.thurweb.ch [213.196.149.41]
    SMTP error from remote mail server after RCPT TO:<gigersbox@thurweb.ch>:
    Sender address rejected: usage of our own domains as sender is NOT allowed on this port. Use submission port 587 or 465 with proper authentification

Reporting-MTA: dns; smtprelay04.ispgateway.de

 

Ich nutze (noch) Shopware 5.5.7 (Leider ist ein Update auf die aktuellste Version von Shopware wegen DomainFactory nicht möglich)

Wichtig: Wurde nach dem Ändern der Einstellung auch der „Shopware Konfiguration“-Cache vom Shop gelöscht? Das ist immer wichtig, denn sonst kommen „alte“ Einstellungen aus dem Cache.

1 Like

Hi sonic,

das komische daran ist: es lief bis Dezember 19 einwandfrei. Die Konfiguration ist nicht neu. Warscheinlich hat Thurweb bis dahin das Senden erlaubt und es nun gesperrt. wie auch immer. Die Einstellungen werden leider nicht  pro SubShop übernommen!

Die Fehlermeldung sagt ja du sollst SSL benutzen.

1 Like

Hi h_lohaus,

das tue ich bereits! Die Fehlermeldung ist aber ein Folgefehler. Da ich mich nicht bei Thurweb authentifizieren kann, schlägt die Fehlermeldung eine „einwandfreie Authentifizierung mit dem richtigen Port“ vor. Dies würde ja passieren, wenn die Einstellungen von den SubShops verwendet würden. Hier sind die Zugangsdaten ja hinterlegt.

hmmmm…