Dynamische Produktgruppen nach Update auf 6.6.3.0 nicht mehr sichtbar

Hallo zusammen,

wir haben gerade das Problem, dass unsere dynamischen Produktgruppen nicht mehr angezeigt werden. Im Backend unter Vorschau wird alles richtig angezeigt. Im Frontend ist der Block wie ausgeblendet. Das Problem trat erst nach dem Update auf von der 6.6.1.0 auf die 6.6.3.0 auf.

Hat jemand das gleiche Problem nach der Umstellung?

Beste Grüße
Bene

1 Like

Einstellungen > Caches & Indizes mal alles anklicken?

Wir haben auch massive Probleme mit der Shop Version.
Wenn wir in der Erlebniswelt die dynamische Produktgruppe auswählen, wird die nicht ausgegeben.

Die Vorschau zeigt aber alles richtig an.

Wenn wir ein manuelles Produkt auswählen, dann funktioniert alles einwandfrei.

1 Like

Hallo Raymond,

haben wir schon probiert, leider ohne Erfolg.

Haben wir auch probiert. Keine Veränderung.

Nabend,

die zwei häufigsten Fehlerquellen, Theme und Erweiterungen bereits ausgeschlossen? Mal aufs Standard-Theme schalten und falls das nichts ergibt, testweise alle Erweiterungen aus.

VG Benjamin

und falls das nicht hilft was @Benjamin_Hummel schreibt: Ticket aufmachen auf https://issues.shopware.com/

Hey Benjamin,
bereits alles probiert. Auch das Standard Theme lässt es nicht zu.

Wir werden den Shop noch einmal neu installieren

Ich habe die Datei vendor/shopware/core/Content/Product/Cms/ProductSliderCmsElementResolver.php aus einem Backup mit der Version 6.6.1.0 rein geladen. Jetzt gehen die Produkt-Slider, wie gewohnt.

3 Likes

Moin Moin,
bei 6.6.3.1 leider auch noch keine dynamischen Gruppen sichtbar. Weder Standard noch Ableitungs Theme.
Mit dem Workaround von @bene-albenisa scheint es zu funktionieren. Da kein 6.6 Backup die Datei aus unserem 6.5 er Shop genommen.

Dann issue hier aufmachen: https://issues.shopware.com/

(Beitrag vom Verfasser gelöscht)

Steht doch drei Beiträge weiter oben?

Nach Update auf 6.6.4.0 leider gleiches verhalten.
Habe mal ein Ticket eröffnet.
https://issues.shopware.com/issues/NEXT-37114

Same hier. Habs gerade schon hochgevotet.
Vorschau passt, Regeln sind auch klar definiert. Produkt ist auch sichtbar und aktiv. Kann im Shop auch bestellt werden.
In der Dynamischen Produktgruppe aber nicht zu sehen…
Shopware wird immer besser!

Ich habe das gleiche Problem mit den dynamischen Produktgruppen im Slider auf der Startseite.
Mal wird ein oder zwei Produkte angezeigt, manchmal nichts.

In einer Kategorie z.B sale wird alles angezeigt.

Wir haben auch das Problem und sobald wir Zufällig auswählen, wird nichts mehr angezeigt. Alles andere funktioniert gem der Anleitung @bene-albenisa

@bene-albenisa vllt mal die Datei zur Verfügung stellen, wäre doch ne Option für alle anderen :wink: