Domain-Änderung wurde festgestellt - Obwohl Erweiterungen bereits auf Domain lizenziert sind

Hallo liebe Community,
ich hoffe mir kann wer weiterhelfen.

Damals habe ich beim Umzug des Shops von der Testdomain auf die Produktivdomain vergessen, die .env-Datei anzupassen. Sonst überall wurde die korrekte Domain eingetragen. (Shopware Account - Shopinformationen; System-Einstellungen im Backend und Verkaufskanal)

Heute, nachdem ich das Update auf die neueste Version vollzogen habe, wurde mir dann mitgeteilt, dass die Apps sich nicht verbinden können und vermutlich der Fehler in der .env-Datei beim Parameter APP_URL zu finden ist.
Da ist mir dann auch aufgefallen, dass tatsächlich noch die Hoster-Domain enthalten ist.
Also habe ich sie auf die korrekte Domain abgeändert.

Seitdem kommt aber nun wenn ich die Administrationsseiten aktualisiere die Meldung, dass eine Domain-Änderung festgestellt wurde. Beide Domains werden im Kopf auch aufgeführt.
Wenn ich dann die Option „Migriere Dein Apps zur neuen Domain“ wähle und die Auswahl bestätige, kommt nur die Fehlermeldung „Keine Änderung durchgeführt“.
Und nun sitze ich hier und weiß nicht weiter. Im weiten Internet, hier im Forum, in FB-Gruppen usw. habe ich nichts dazu finden können.

Hat jemand von euch eventuell einen Lösungsansatz?
Die Apps laufen ja eigentlich bereits auf die korrekte Domain. (jedenfalls laut account.shopware.com)

Ich danke schon mal vorab!

Gruß, Daniel

Domain in der .env ändern, migrieren und wieder ändern.

Auf eine beliebige andere Domain?

Würde deine eigene nehmen, einmal mit www. und einmal ohne. Je nachdem was jetzt eigestellt ist.