Datenbank Zeichensatz kryptisch

Hallo,

in meiner Datenbank sind nach der Installation mit den Demodaten viele Einträge kryptisch.

Z.B. in der Tabelle ‘Category’:

id    version_id    auto_increment    parent_id    parent_version_id    media_id    cms_page_id    product_stream_id    product_assignment_type    path    after_category_id    after_category_version_id    level    active    child_count    display_nested_products    visible    type    created_at    updated_at
c

[¨ðèõ    ©ãéjK¾KÙÎu,4%    60    ¢é{´!IP¿!ÆO©ãéjK¾KÙÎu,4%    ðFS5M:G%ƒ×÷¿^ІD    {I”?€„E8¶'¹ªÌÜ    NULL    product    |c464383aed6a44a5a250ee5f672c6c3d|a2e97b16b4214950bf21c64f3ca09e34|    'Ú¥ÈGºÓ’š`TUÓ    ©ãéjK¾KÙÎu,4%    3    1    0    1    1    page    2021-01-27 15:25:11.004    NULL

Ist das irgendwie verschlüsselt?

Für die DB hatte ich als Zeichensatz und Kollation UTF-8mb4_unicode gewählt.

das ist (bei Shopware) normal. IDs werden ‚aus technischen Gründen‘ als binär hinterlegt

1 Like

Hallo,

das wird wohl wahrscheinlich eher daher kommen, dass das Tool, womit du dir die Datenbankdaten ansiehst, die Binary - Daten nicht korrekt anzeigen kann. Sonst ist da eigentlich nichts „kryptisch“. Deshalb empfiehlt Shopware auch Adminer. Möglich beispielsweise auch in der Administration über das Plugin: https://github.com/FriendsOfShopware/FroshPlatformAdminer .

Grüße

Sebastian

1 Like

Hallo,

danke für die Antworten.

Im Moment benutze ich Sequel Pro.
Ich schaue mal, ob ich das dort einstellen kann.
Oder benutze auch Adminer.

VG
Genji

Hallo,

Sequel Pro ist für Shopware 6 nicht (mehr) geeignet und dort kannst du es leider auch nirgends einstellen, damit es Binary - Daten korrekt anzeigt. Du müsstest also auf Adminer oder andere Programme umsteigen, siehe auch: https://docs.shopware.com/en/shopware-6-en/first-steps/system-requirements#recommended.

Grüße

Sebastian

ich bin ein langjähriger Fan von HeidiSQL