createEmotionComponent() im neuen Plugin-System

hi, ich wollte mir gerade ein kleines Plugin für ein eigenes Einkaufswelten-Element schreiben. Das wollte ich dann auch gleich im neuen Plugin-System machen.

Leider musste ich ziemlich schnell feststellen, dass es die Methode createEmotionComponent() nicht gibt bzw. nciht zur Verfügung steht.

Welche alternative kann ich nutzen?

Grundsätzlich: Ist das neue Plugin-System überhaupt schon zur verwendung zu empfehlen? ich habe das gefühl hier fehlt noch jede Menge und im gegensatz zum alten System ist viele sehr umständlich.

ok, ich habe nun das hier gefunden:

https://developers.shopware.com/developers-guide/plugin-system/#add-backend-emotion-components

leider bekomme ich beim Installieren dann folgenden Fehler:

 

You have requested a non-existent service "shopware.emotion_component_installer".

Was fehlt mir?

Hallo,
ich hänge mich hier einfach mal mit dran - ich probiere ebenfalls (leider bisher ohne Erfolg) ein Plugin zu bauen, welches eine Custom Emotion Component bereitstellt. Ich habe auch versucht Beispiel-Plugins oder Plugins von Github zum Laufen zu bekommen, aber unter Shopware 5.2 will einfach keins richtig laufen!

Meistens geht in den Einkaufswelten nicht mal das Modal auf, wo man dann das Content Element bearbeiten könnte. Das einzige Plugin, welches ich gefunden habe wo das geht ist: https://github.com/shopfreelancer/Shopware_VideoWidget

Aber bei diesem Plugin kommt dann leider nichts im Frontend heraus… Wäre toll, wenn jmd. von Shopware mal das Example Plugin von Custom shopping world elements für Shopware v5.2 bereitstellen könnte - am Besten mit der 5.2er Plugin API! Vielen Dank.

So, habe ein mit der 5.2er Shopware-Plugin-API lauffähiges Emotion Plugin auf Github eingestellt… Möge es helfen!

2 Likes

Hallo,

ich habe dein Beispiel in Shopware 5.3 Installiert, leider geht hier auch das Popup nicht auf zum bearbeiten. Hat jemand schon ein lauffähiges Emotion Plugin für Shopware 5.3 erstellt?

Wir haben noch kein Shopware 5.3 irgendwo im Einsatz. Wenn ich abends vielleicht mal Zeit habe, dann kann ich mal ein 5.3er Shopware aufsetzen und schauen, wo es klemmt. Aber das Repo kann ja gern ge’fork’t werden. Pull Requests nehme ich gerne an :slight_smile:

Ich habe leider das exakt gleiche Problem mit Shopware 5.3. Wäre echt total nett, wenn du mal schauen könntest wo es klemmt :slight_smile:

Danke!