Bilder werden nicht angezeigt!

Hallo zusammen Leider werden ab und zu mit dem Chrome-Browser die Bilder nicht dargestellt. (Siehe Screenshot). Wer kann mir helfen? Was kann ich tun? Denn für Kunden ist es ja sehr ärgerlich, wenn die Bilder nur als „Platzhalter“ angezeigt werden. Shopware: 5.0 Ps: Habe den Cache schon etliche Male gelöscht, auch wurden die Bilder „neu generiert“. Besten Dank für Eure Hilfe!! Gruss Cyril

*up*

Ich habe mir Deine Seite mal im Chrome angesehen. Die Seite läuft unter https://, aber einige Bilder sind über http:// statt https:// eingebunden und werden daher nicht geladen (daher hast Du oben in der Adressleiste auch eine Warnung: “Diese Seite enthält jedoch andere, nicht sichere Ressourcen.”). Wenn Deine Seite über SSL läuft, müssen auch alle Elemente (Bilder, CSS, JS, etc.) über SSL geladen werden. Wenn Du das änderst, sollten die Bilder auch geladen werden (sofern sie existieren).

Hallo Besten Dank für deine Antwort. Wie kommt es, dass einige Bilder über http:// statt über https:// geladen werden? Wie kann ich diese Problematik lösen? Die Warnung in der Adressleiste erscheint bei mir leider nicht. Beste Grüsse & Danke Cyril

Hallo zusammen Im Chrome habe ich immer noch das Problem mit der Bilderdarstellung: https://www.tradeby.ch/dev/shopware4 Verzeichnisschutz Benutzername: c pw: 1234 Weiss jemand noch mehr? Interessant ist die Fehlermeldung von Chrome mit dem Webtool: Failed to load resource: net::ERR\_CONTENT\_LENGTH\_MISMATCH https://www.tradeby.ch/dev/shopware4/media/image/50200-175\_TB1.jpg Gruss und vielen Dank Cyril

Bei mir werden bei dem Produkt alle Bilder korrekt dargestellt: https://www.tradeby.ch/dev/shopware4/pf … -bio-green Hast Du es schon mal an einem anderen PC versucht? Mal zum Test das AntiVir Programm deaktiviert?!

Hallo Besten Dank für dein Feedback! Habe es schon mit etlichen Geräten versucht. MacBook,PC etc. Interessant ist, dass FireFox auch Probleme hat mir der Darstellung der Bilder: Hier habe ich soeben einen neuen Testartikel erstellt. Habe auch “SSL” Verschlüsselung deaktiviert. Habe etliche Plugins deaktiviert (nur noch welche von Shopware). Habe alle Artikel-Thumbnails neu generieren lassen. Auch Cache im Backend und Cache in allen Browsern gelöscht. Habe jetzt sogar unter http://development.tradeby.ch/detail/index/sArticle/167 einen neuen Artikel erstellt, auch dort gibt es Probleme mit der Bilddarstellung. Gruss und Danke Cyril ps: Antivirus deaktiviert, auch alle Pop-Up und AdBlocker deaktiviert… Problem triff im FireFox auf (Bild wird nur 1/2 dargestellt) und im Chrome ab und zu nur der Platzhalt für ein Bild wird dargestellt. Interessant ist auch, wenn ich mit der Zoom-Viewer Funktion über das Bild “fahre” (Lupe), erscheint das Bild, obwohl ja nur 1/2 angezeigt wird und der Rest vom Bild “weiss” ist…ich weiss nicht mehr weiter…

[quote=„TimmeHosting“]Ich habe mir Deine Seite mal im Chrome angesehen. Die Seite läuft unter https://, aber einige Bilder sind über http:// statt https:// eingebunden und werden daher nicht geladen (daher hast Du oben in der Adressleiste auch eine Warnung: „Diese Seite enthält jedoch andere, nicht sichere Ressourcen.“). Wenn Deine Seite über SSL läuft, müssen auch alle Elemente (Bilder, CSS, JS, etc.) über SSL geladen werden. Wenn Du das änderst, sollten die Bilder auch geladen werden (sofern sie existieren).[/quote] Hallo Wie genau kann ich das ändern, damit die Bilder auch über https:// statt über http:// geladen werden? Gruss & Dank Cyril

Hallo zusammen Habe jetzt auch folgende Einstellungen im Backend angepasst: Leider habe ich sogar jetzt auch mit dem FireFox Probleme mit der Bilddarstellung. Fehlermeldung bez. HTTPS habe ich jedoch keine Fehlermeldungen. Hier noch die .htaccess -Datei [code]
RewriteEngine on

#RewriteBase /shopware/

Https config for the backend

RewriteCond %{HTTPS} !=on
#RewriteRule backend/(.) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
RewriteRule (.
) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
#RewriteRule ^(.) https://%{SERVER_NAME}/$1 [R,L] --> Forum
#RewriteRule ^(.
) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule backend/media/(.*) media/$1 [NC,L]

RewriteCond %{REQUEST_URI} !(/(engine|files|templates)/)
RewriteCond %{REQUEST_URI} !(/media/(archive|banner|image|music|pdf|unknown|video)/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]

Fix missing authorization-header on fast_cgi installations

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
# Staging-Rules start #SetEnvIf Host “staging.test.shopware.in” ENV=staging DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration
Deny from all
# Enable gzip compression
AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/json


ExpiresActive on
ExpiresDefault “access plus 1 month”
FileETag None

Header append Cache-Control “public”
Header unset ETag


# Disables auto directory index
Options -Indexes

Options -MultiViews

php_value memory_limit 128M

php_value max_execution_time 120

php_value upload_max_filesize 20M

php_flag phar.readonly off
php_flag magic_quotes_gpc off
php_flag session.auto_start off
php_flag suhosin.session.cryptua off
php_flag zend.ze1_compatibility_mode off
# AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php AddHandler application/x-httpd-php56 .php AuthName “WEGEN WARTUNG GESPERRT!” AuthUserFile “/home/tradebyt/.htpasswds/public_html/shopware/passwd” [/code] Wer kann helfen - wäre mega! Gruss & Dank Cyril

Hallo, das Problem scheint in der Thumbnail-Erstellung zu sein. Machst du die Bilder selbst oder bekommst du Sie vom Lieferanten? Wenn du Sie vom Lieferanten bekommst, probier doch mal, dass du alle Bilder konvertierst in ein neues JPG und lade diese neu hoch. Lässt sich z. B. sehr einfach über IrfanView (kostenlos) machen. Kann gut sein, dass META-Daten in den Bildern bei der Thumbnail-Erstellung das Problem verursachen. Was noch sein kann, ist natürlich dieser Mix aus HTTP und HTTPS, das hier irgendwann das laden vom Browser wegen “unsicheren” Inhalts unterbrochen wird. Hoffe das Hilft dir etwas. Viele Grüße.

[quote=“Neoxx”]Hallo, das Problem scheint in der Thumbnail-Erstellung zu sein. Machst du die Bilder selbst oder bekommst du Sie vom Lieferanten? Wenn du Sie vom Lieferanten bekommst, probier doch mal, dass du alle Bilder konvertierst in ein neues JPG und lade diese neu hoch. Lässt sich z. B. sehr einfach über IrfanView (kostenlos) machen. Kann gut sein, dass META-Daten in den Bildern bei der Thumbnail-Erstellung das Problem verursachen. Was noch sein kann, ist natürlich dieser Mix aus HTTP und HTTPS, das hier irgendwann das laden vom Browser wegen “unsicheren” Inhalts unterbrochen wird. Hoffe das Hilft dir etwas. Viele Grüße.[/quote] Hallo Besten Dank für deine Hilfe & Antwort! Die Bilder haben wir von Lieferanten - ja, sie werden aber von uns bearbeitet (verkleinert und komprimiert und am schluss mit Thiny JPG https://tinyjpg.com/ nochmals komprimiert) Also wie gesagt, alle Bilder wurde konventiert. Ich habe auch schon alle Thumbnail Bilder gelöscht und alle neu generiert. Der Mix aus HTTPS und HTTP kommt von den Einbindungen z.B. Schema.org oder GoogleFonts… Das wird ja von Shopare aus schon eingebunden, jedoch NICHT über HTTPS sondern nur http… Das sind laut Quelltext die “einzigen” Elemente welche nicht über HTTPS laufen. Soll ich diese mal versuchen via https:// einzubinden? (wird sicher nicht schnell&einfach gehen). Ich habe auch schon gedacht, dass es am HTTP-Cache liegen kann… In der Testumgebung ohne https:// habe ich nie Probleme… Besten Dank für deine Hilfe. Gruss Cyril

Die Meta’s sind egal, da wird ja nichts geladen. Google-Fonts kannst du einfach als HTTPS einbinden. Google blockt sich da nicht. In Firefox gibt’s z. B. einen kleinen Button links neben der URL der dir Anzeigt, ob noch was über http geladen wird. (Icon ist so ein Schild). Wenn du drauf klickst, sagt dir Firefox auch gleich, dass unsichere Inhalte blockiert werden. Das musst du halt weg bekommen. Viele Grüße.

[quote=“Neoxx”]Die Meta’s sind egal, da wird ja nichts geladen. Google-Fonts kannst du einfach als HTTPS einbinden. Google blockt sich da nicht. In Firefox gibt’s z. B. einen kleinen Button links neben der URL der dir Anzeigt, ob noch was über http geladen wird. (Icon ist so ein Schild). Wenn du drauf klickst, sagt dir Firefox auch gleich, dass unsichere Inhalte blockiert werden. Das musst du halt weg bekommen. Viele Grüße.[/quote] Hallo Neoxx Besten Dank! Dann muss ich wohl oder übel alle http:// links mit https:// manuell ersetzen (also auch schema.org etc.) Lustig ist, dass auf meiner Hauptdomain www.tradeby.ch im FireFox KEIN Schild angezeigt wird mit diesen Infos. Hingegen auf der Dev-Version ( https://www.tradeby.ch/dev/shopware4/ ) wird dieses Schild im FireFox angezeigt…komisch… Benutzername: c pw: 1234 Also ich versuche mal alle Links im Quellcode auf https:// hinzubekommen. Besten Dank für Eure Hilfe! Gruss Cyril

Ja, weil du auf deinem Hauptshop keine Google-Fonts hast. Das Problem tritt ja auch nur wegen Google auf. Diese http’s in den META-Daten sind egal, diese Seiten werden vom Browser nicht geladen, sondern nur die Google-Fonts. Heißt, du musst nur Google-Fonts per HTTPS einbinden. Gruß.

[quote=“Neoxx”]Ja, weil du auf deinem Hauptshop keine Google-Fonts hast. Das Problem tritt ja auch nur wegen Google auf. Diese http’s in den META-Daten sind egal, diese Seiten werden vom Browser nicht geladen, sondern nur die Google-Fonts. Heißt, du musst nur Google-Fonts per HTTPS einbinden. Gruß.[/quote] Achso, jetzt hab ichs verstanden. Im Hauptshop hats keine Google Fonts, das hab ich jetzt kapiert. ABER im Hauptshop werden die Bilder auch nicht angezeigt, genau wie in der Testumgebung nicht. Also besteht das Problem weiterhin, auch wenn FireFox keine Meldung (siehe Hauptshop) anzeigt… Gruss

Mhm… Also in deinem Hauptshop werden bei mir alle Bilder korrekt geladen. Chrome sowie Firefox. Kann somit eigentlich nur am Browser liegen. Lade ich mir das „halbe“ Bild runter, wird es vollständig angezeigt. Ansonsten bin ich auch mit meinem Latein am Ende. Gruß

Ich bekomme in Google wie auch in Firefox alles normal ohne Fehlermeldungen angezeigt! Auch in deiner Dev-Version…

1 Like

Hallo zusammen Besten Dank für euren Input. Das ist auch so…zu 90% wird auch alles korrekt angezeigt. Leider treten die Fehler nur sporadisch auf. Ich kann das Problem nicht per sofort rekonstruieren. Ich dachte mir, es liegt am gleichen PC und Browser. Jedoch taucht es auch auf anderen Laptops und anderen Browsern auf. Google Chrome: Platzhalter wird für das Bild angezeigt FireFox: Nur die Hälfte des Bildes wird geladen Safari (iPad): Foto mit grossem schwarzem Rechteck Ich bin mit meinem Latein ebenfalls am Ende. Habe sogar den Hoster des Shops kontaktiert - auch dieser konnte nicht weiterhelfen. Gruss Cyril

…Was ich jetzt auch noch im FireFox hatte, was ich bis jetzt noch nie gesehen habe: Es wird gar kein Bild angezeigt… – > Drücke ich aber Ctrl+F5 wird natürlich alles neu geladen und das Bild ist wieder da… Irgendwas ist sehr komisch… Verzweifle fast…:wtf: Youtube Film mit Fehler: http://youtu.be/KWAyStTZB3w

interessant…IE 11 zeigt auch Fehler an mit den Produktbilder :cry: