Backend kann nicht mehr aufgerufen werden

So mich Newbie hats dann auch heut erwischt. Nichts geht mehr nachdem ich das Modul „Kundenspezifische Preise“ installiert habe. Daraufhin lies sich der Shop noch aufrufen - das Backend nicht. HILFE! Habe seitdem im Forum nach Lösungen gesucht und nur den Cache aus den jeweiligen Server-Verzeichnissen per FTP gelöscht. Der Blick in die Logdatei vom Server macht mir gerade eher Bauchschmerzen statt zu helfen :frowning: Was muss ich tun ? [2015-01-26 16:57:46] core.ERROR: exception 'Doctrine\ORM\ORMException' with message 'The identifier id is missing for a query of Shopware\Models\Shop\Locale' in /mnt/webs/e0/66/54418466/htdocs/shopperware/vendor/doctrine/orm/lib/Doctrine/ORM/ORMException.php:259 Stack trace: #0 /mnt/webs/e0/66/54418466/htdocs/shopperware/vendor/doctrine/orm/lib/Doctrine/ORM/EntityManager.php(427): Doctrine\ORM\ORMException::missingIdentifierField('Shopware\\Models...', 'id') #1 /mnt/webs/e0/66/54418466/htdocs/shopperware/vendor/doctrine/orm/lib/Doctrine/ORM/EntityRepository.php(154): Doctrine\ORM\EntityManager-\>find('Shopware\\Models...', NULL, 0, NULL) #2 /mnt/webs/e0/66/54418466/htdocs/shopperware/engine/Shopware/Plugins/Default/Backend/Auth/Bootstrap.php(280): Doctrine\ORM\EntityRepository-\>find(NULL) #3 /mnt/webs/e0/66/54418466/htdocs/shopperware/engine/Shopware/Plugins/Default/Backend/Auth/Bootstrap.php(209): Shopware\_Plugins\_Backend\_Auth\_Bootstrap-\>initLocale() #4 /mnt/webs/e0/66/54418466/htdocs/shopperware/engine/Library/Enlight/Event/Handler/Plugin.php(149): Shopware\_Plugins\_Backend\_Auth\_Bootstrap-\>onPreDispatchBackend(Object(Enlight\_Controller\_ActionEventArgs)) #5 /mnt/webs/e0/66/54418466/htdocs/shopperware/engine/Library/Enlight/Event/EventManager.php(211): Enlight\_Event\_Handler\_Plugin-\>execute(Object(Enlight\_Controller\_ActionEventArgs)) #6 /mnt/webs/e0/66/54418466/htdocs/shopperware/engine/Library/Enlight/Controller/Action.php(138): Enlight\_Event\_EventManager-\>notify('Enlight\_Control...', Object(Enlight\_Controller\_ActionEventArgs)) #7 /mnt/webs/e0/66/54418466/htdocs/shopperware/engine/Library/Enlight/Controller/Dispatcher/Default.php(528): Enlight\_Controller\_Action-\>dispatch('getLoginStatusA...') #8 /mnt/webs/e0/66/54418466/htdocs/shopperware/engine/Library/Enlight/Controller/Front.php(228): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #9 /mnt/webs/e0/66/54418466/htdocs/shopperware/engine/Shopware/Kernel.php(141): Enlight\_Controller\_Front-\>dispatch() #10 /mnt/webs/e0/66/54418466/htdocs/shopperware/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(472): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #11 /mnt/webs/e0/66/54418466/htdocs/shopperware/engine/Shopware/Components/HttpCache/AppCache.php(256): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #12 /mnt/webs/e0/66/54418466/htdocs/shopperware/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(243): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true) #13 /mnt/webs/e0/66/54418466/htdocs/shopperware/engine/Shopware/Components/HttpCache/AppCache.php(102): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true) #14 /mnt/webs/e0/66/54418466/htdocs/shopperware/shopware.php(109): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #15 {main} [] {"uid":"52e9c23"} [2015-01-26 16:57:47] core.ERROR: exception 'Doctrine\ORM\ORMException' with message 'The identifier id is missing for a query of Shopware\Models\Shop\Locale' in /mnt/webs/e0/66/54418466/htdocs/shopperware/vendor/doctrine/orm/lib/Doctrine/ORM/ORMException.php:259 Stack trace: #0 /mnt/webs/e0/66/54418466/htdocs/shopperware/vendor/doctrine/orm/lib/Doctrine/ORM/EntityManager.php(427): Doctrine\ORM\ORMException::missingIdentifierField('Shopware\\Models...', 'id') #1

Hallo, Schau mal hier administration-f55/kein-backend-login-id-is-missing-ormexception-php-t8957.html Oder administration-f55/hilfe-aus-dem-backend-ausgesperrt-sprache-geandert-t19747.html#p88015 Tippe also nicht, dass es am Plugin liegt. Evtl. wurde durch die Installation nur der Cache aktualisiert. Sebastian

1 Like

[quote=“Sebastian Klöpper”]Hallo, Schau mal hier administration-f55/kein-backend-login-id-is-missing-ormexception-php-t8957.html Oder administration-f55/hilfe-aus-dem-backend-ausgesperrt-sprache-geandert-t19747.html#p88015 Tippe also nicht, dass es am Plugin liegt. Evtl. wurde durch die Installation nur der Cache aktualisiert. Sebastian[/quote] Vielen Dank für den Tipp :smiley: Absolut richtig. In der Tabelle s\_core\_config\_element nach dem "name" --\> "backendLocales" suchen und den ganzen Eintrag löschen - das wars.