Autocomplete für das Backend Login

Hallo, gibt es eine Möglichkeit für den Login im Backend die „Autocomplete“ Funktion der Browser zu aktivieren? Im Moment ist sie direkt in den Input Feldern mit dem HTML Atribute ‚autocomplete=„off“‘ deaktiviert. Vielen Dank Robert

Hallo Robert, da es sich hier um ext.JS handelt ist die Änderung in der Datei templates_default\backend\login\view\main\form.js vorzunehmen. Zeile 71/80 ergänzen: allowBlank: true, listeners:{ afterrender:function(cmp){ cmp.inputEl.set({ autocomplete:'on' }); } }, Siehe dazu auch diesen Eintrag auf StackOverflow. Viele Grüße Marc Heying

1 Like

Vielen Dank für Deine Antwort Marc. Das funktioniert super! Jetzt gibt es noch das Problem das eingegebene Passwörter nicht gespeichert werden. Dies liegt wohl daran, das dafür ein Page Reload nötig ist. Kennt jemand eine Möglichkeit wie dies hier zu realisieren wäre? Vielen Dank Robert

Mögliche Alternative: http://store.shopware.de/administration … ink-aufruf Viele Grüße

Vielen Dank Aquatuning GmbH für den Plugin Tipp! Ich habe noch zwei Frage für Anpassungen am Backend Template. Wenn ich an den JavaScript Dateien etwas ändere (wie z.B. an “backend\login\view\main\form.js”) muss ich sie komplett in den Ordner “templates_local\backend…” übernehmen. Eine Art Vererbung ist hier nicht möglich, richtig? Wenn ich eine Template Datei überschreiben möchte so kann ich doch vom Original erben. Ich habe dies mit der Datei “backend\index\index.tpl” versucht, bekomme aber einen “illegal recursive call” Fehler. So sieht meine index.tpl aus welche ich im Verzeichnis “_local\backend\index” erstellt habe: [code] {extends file=“parent:backend/index/index.tpl”} {block name=“backend/base/container” append}

Test Content

{/block} [/code] Habe ich hier falsch vererbt oder gibt es bei dem Backend Template etwas besonderes zu beachten?

Ich habe jetzt ein Lösung gefunden welche im Chrome für das automatische speichern der Passwörter sorgt. Funktioniert leider nur eben im Chrome: In der Datei “templates_default\backend\login\view\main\form.js” den Parameter “autoEl: ‘form’” hinzufügen. Der Inhalt schaut dann so aus: Ext.define('Shopware.apps.Login.view.main.Form', { extend: 'Ext.form.Panel', plain: true, frame: false, border: false, alias: 'widget.login-main-form', bodyStyle: 'border-bottom-color: transparent', preventHeader: true, autoEl: 'form', defaults: { labelWidth: 100, width: 370 }, Vlt. hat ja noch jemand eine Idee wie man das automatische Speichern der Passwörter auch in den anderen Browsern aktivieren kann.

Ok, das Problem ist das das Login Formular wirklich abgesendet werden muss damit die Login Daten in allen Browsern gespeichert werden. Es darf nicht nur eine Ajax Request gesendet werden. Dafür habe ich in der Datei „templates_default\backend\login\view\main\form.js“ den Parameter „autoEl“ folgender maßen geändert: autoEl: { tag: 'form', method: 'POST', action: window.location.href }, Zusätzlich muss noch die „success“ Function in der Datei „templates_default\backend\login\controller\main.js“ geändert werden. Ich habe hier den Code „form.owner.el.dom.submit();“ eingefügt: onLogin: function(btn) { var me = this, win = btn.up('window'), formPnl = win.down('form'), form = formPnl.getForm(), values = form.getValues(); if(!form.isValid() || !values.password.length || !values.username.length) { return false; } form.submit({ url: '{url action=login}', waitMsg: '{s name=wait/message}Login...{/s}', success: function(form, action) { form.owner.el.dom.submit(); },

1 Like

Guten Morgen Leute, kurze Frage meinerseits. Ich habe gestern festgestellt, dass wenn ich beim Kundenkonto die Autofill-Funktion anwende(Google Chrome), die Registrierung nicht abgeschlossen werden kann. Es erscheint jedoch keine Fehlermeldung, da die Daten korrekt eingetragen wurden. Wäre um jeden Rat dankbar, da dies natürlich äußerst negativ für einen Kunden wäre, wenn er den Einkauf abwickeln möchte, jedoch nie über den Registrierungspunkt kommt. Vielen Dank im Voraus! Liebe Grüße, Michael