3D-Secure für Clickpay-Schnittstelle?

Moin! Habe gestern zufällig dieses Ticket gefunden: http://trac.shopware.de/trac/ticket/100128 Ist es tatsächlich so, dass 3D-Secure nicht unterstützt wird? Würde mich doch wundern. Ihr setzt das doch selbst im Bereich „Mein Account“ ein, oder? Und da habe ich schon mit Kreditkarte das Konto aufgeladen. Ich denke, dass dort das 3D-Secure-Passwort abegfragt wurde. Könntet Ihr uns da mal kurz Klarheit verschaffen? Denn mit Hinblick auf die Haftungsumkehr ist das natürlich schon wichtig. Danke. AS

Moin, ja das unterstütze ich auch dringendst! Habe darüber einen Vertrag gemacht weil ich dachte, das wäre eine einfache Sache da Shopware das auch nutzt! Und jetzt kann ich es nicht einsetzen! :cry:

Also, ich habe eben einmal paar CREDITS im Account drauf geladen. Der MasterCard Secure Code wird dort abgefragt. Kann mir jemand erklären, warum es dann oben bezeichnetes Ticket gibt? Oder funktioniert das nur bei der Shopware AG, nicht aber in der ausgelieferten Schnittstelle? AS

@artep: Hast Du es denn schon ausprobiert? Vielleicht funktioniert es ja? Ich bin jetzt völlig verwirrt dass hier nicht wenigstens eine Antwort kommt ob es geht oder ob daran erst noch gearbeitet werden muss. Wie gesagt, im Account-Bereich funktioniert es ja auch … AS

Hi, [quote]Ich bin jetzt völlig verwirrt dass hier nicht wenigstens eine Antwort kommt ob es geht oder ob daran erst noch gearbeitet werden muss. Wie gesagt, im Account-Bereich funktioniert es ja auch …[/quote] @Alpinswift Wie schnell erwartest Du hier eigentlich Antworten im Forum!? Also eine Frage, die hier im Forum heute um 8:21 Uhr gestellt wird, darf doch keine Panik erzeugen, nur weil um 11:46 Uhr - am selben Tag - dazu noch keine offizielle Stellungnahme der shopware AG vorliegt!!! :shock: Wenn Du eine derartig kurze Stellungnahme und Reaktionszeit erwartest, dann solltest Du bei uns ein priorisiertes Ticket aufmachen im Support, mit einer garantierten Reaktionszeit von max. einer Stunde, etc… Generell beobachten wir wichtige Themen sowieso und beantworten die nach Möglichkeit auch recht zeitnah. Das offizielle Tagesgeschäft hat aber natürlich immer Vorrang. Bremse Dich daher im Forum bitte einmal selber etwas aus, bevor Du völlig in Panik verfällst nach 3 Stunden ohne Antwort! Ist jetzt nicht böse gemeint, musste aber mal gesagt werden. :wink: ---------- So jetzt zum eigentlichen Thema: Shopware 3.5.3 unterstützt 3D-Secure auf jeden Fall im Hinblick auf die Clickpay-Schnittstelle. Im Testmodus kann dies allerdings nie getestet werden, da es dafür keine Testdaten gibt. Im offiziellen Betrieb habe ich das sogar gerade Live in einer aktuellen Shopware Demo mit Live-Projektdaten getestet, mit Mastercard 3D-Secure ging das Bezahlen inkl. Codeeingabe schon einmal problemlos. Eine Visa-Card besorge ich mir nun auch noch heute Mittag und teste das damit ebenfalls noch einmal durch. Wichtig ist halt immer, dass der Karteninhaber selber sich für dieses Verfahren registriert hat, ansonsten kommt diese Abfrage des Codes nicht und die Zahlung läuft nur über die Kartennummer, Prüfziffer und Gültigkeit. Wichtig ist ebenfalls, dass der eingesetzte Acquirer (z.B. B&S Card) das verfahren ebenfalls unterstützt, ansonsten erfolgt auch keine Code-Abfrage trotz Kreditkarte, die der Karteninhaber für 3D-Secure freigeschaltet hat. Zum aktuellen Zeitpunkt kann ich aber sagen, alles läuft perfekt, zu Visa melde ich mich heute Mittag noch mal, rein sicherheitshalber. Zu dem Trac Ticket kann ich nur sagen, das können wir wieder zu machen. Hier muss ich aber ehrlich auch eingestehen, hier hatte “artep” bei uns aus dem Support eine leicht fehlerhafte Aussage erhalten, zumindest was die eingesetzte Version 3.5 betrifft… Das hat dann für etwas Verwirrung gesorgt. SHOPWARE UND DAS INTERFACE UNTERSTÜTZEN 3D-SECURE ABER! :slight_smile: Stefan :shopware:

Danke. Asche auf mein Haupt … :oops: AS

[quote=“Stefan Heyne”]Hi, [quote] Wichtig ist ebenfalls, dass der eingesetzte Acquirer (z.B. B&S Card) das verfahren ebenfalls unterstützt, ansonsten erfolgt auch keine Code-Abfrage trotz Kreditkarte, die der Karteninhaber für 3D-Secure freigeschaltet hat. Zum aktuellen Zeitpunkt kann ich aber sagen, alles läuft perfekt, zu Visa melde ich mich heute Mittag noch mal, rein sicherheitshalber. Zu dem Trac Ticket kann ich nur sagen, das können wir wieder zu machen. Hier muss ich aber ehrlich auch eingestehen, hier hatte “artep” bei uns aus dem Support eine leicht fehlerhafte Aussage erhalten, zumindest was die eingesetzte Version 3.5 betrifft… Das hat dann für etwas Verwirrung gesorgt. SHOPWARE UND DAS INTERFACE UNTERSTÜTZEN 3D-SECURE ABER! :slight_smile: Stefan :shopware:[/quote][/quote] Hallo Stefan, danke für diese Info! Ich hatte das ja im November ausprobiert mit meiner Visa und da ging es nicht, da ich noch nicht 3.5 hatte! Wenn es aber jetzt doch geht, bin ich natürlich mehr als zufrieden! Supi! :wink:

Hi, Visa teste ich definitiv noch in einer Liveumgebung, wahrscheinlich wird das aber doch erst Morgen was… Das muss aber auch problemlos funktionieren. Ich melde mich auf jeden Fall dazu noch einmal unaufgefordert, sobald ich damit durch bin. Dafür gibt es halt leider keine Testkarten und einen Testmodus… Stefan

Hey, ich verlasse mich da jetzt einfach drauf. Wenn Ihr sagt dass es funktioniert, dann ist das erfahrungsgemäss auch so. Wenn Du es auch noch testest, umso besser. Aber wenn das heute nichts mehr wird geht die Welt auch nicht unter … :wink: Mich hatte wie gesagt einfach das Ticket irritiert und ich wusste gar nicht mehr woran ich war. Wünsch Euch was … AS

Hi, so habe heute Morgen nun VISA getestet. Eine Zahlung konnte ich problemlos durchführen. Ich hatte mich 5 Minute zuvor für das “Verrified by VISA” registriert (in meinem Fall Mercedes Bank), ein Code wurde direkt bei der Bezahlung jetzt aber noch nicht abgefragt. Das kann aber auch etwas dauern. Halten wir erst einmal fest: Das Interface läuft fehlerfrei, dem Bezahlen steht also schon einmal nichts im Wege. Trotzdem haben wir nun noch einmal mit EOS telefoniert, warum man nach erfolgreicher Registrierung nicht direkt auch eine Code-Abfrage bekommt. Bei Mastercard hat das ja funktioniert, bei VISA nicht. EOS (Clickpay) sagt: 1. Kann das einige Zeit dauern, bis der Code aktiv wird. Das ist generell immer Sache der jeweiligen Bank und derer Prozesse. 2. Das Interface läuft einwandfrei, denn Mastercard 3D-Secure hat funktioniert, dass ist in der Schnittstelle ein identischer Prozess. So far… Stefan

Hallo Stefan, ich habe gerade eine Testbestellung per Visacard durchgeführt. Ich bin registriert für Visa 3D-Secure. In meinem Shop geht leider nicht 3D-Secure auf! Muß man dazu noch irgendwo was einstellen?

Hi, nein, einstellen muss man das nicht. Es kann abe auch sein - wie aktuell in meinem Fall heute Morgen - , dass man sich für 3D-Secure registriert, das Verfahren aber nicht unmittelbar funktioniert, weil die jeweilige Bank das noch nicht freigeschaltet hat. Die Anfrage geht immer an die jeweilige Bank und die Bank entscheidet dann, ob dieser Code zur Eingabe abgefragt wird. Das macht nicht die Schnittstelle selber. Das entscheidet ebenfalls nicht Mastercard oder VISA selber, sondern das läuft alles über die eingesetzte Bank. Hast Du einmal mit Deiner Bank telefoniert, ob die das Verfahren auch bereits live einsetzen oder man sich dafür nur registrieren kann? Kannst Du mit Deiner Visacard in anderen Shops inkl. Codeeingabe bestellen? Zufällig schon einmal probiert? Falls ja, kommt da auch nur Abfrage nach Kartennummer, Gültigkeit und Prüfziffer? Stefan

Hallo Stefan, ich bin schon lange registriert und es funktioniert auch beim Bezahlen in anderen Shops. Ich hatte vor Kurzem bei Shopware auch mit Visa eingekauft und da ging auch 3D-Secure auf! Da bin ich ja erst auf den Trichter gekommen, dass es bei mir nicht so ist. Keine Ahnung warum das nicht geht. Vielleicht testet Ihr das mal Montag und kauft einen Artikel über Karte. Kann ich ja danach stornieren. So, jetzt gehe ich ein paar leckere Schlüssel-Alt trinken! :wink: Ein schönes Wochenende allerseits!

Hi Petra, also meine Visacard, die ich am Freitag für die zusätzliche Codeeingabe registriert hatte, funktioniert mittlerweile inkl. Codeeingabe im Onlineshop perfekt. Sowohl in einer Shopware 3.0.5, als auch in einer aktuellen Shopware 3.5.3. Ich habe noch eine Vermutung… Schaue einmal bitte in den Chekcout bei Dir. Sieht der Checkout bei Dir so aus? oder so aus? Es müsste auf jeden Fall so aussehen, wie in Szenario 1. Kannst Du das einmal eben prüfen und mir eine Info geben. Dann hätte ich evtl. eine Idee, falls bei Dir das Szenario 2 aktiv ist. Stefan

1 Like

Guten Morgen Stefan, habe ich ja am Freitag ausprobiert und bei mir sieht es aus wie im Szenario 2!

Hi, okay dann hast Du bei Dir im Backend bestimmt auch noch PopUp auf 1 stehen in den EOS Einstellungen? Diese Einstellung gibt es nur noch aus Kompatibilitätsgründen in der 3.5.3. In einer 3.0.5 geht dann auch noch ein PopUp auf und die Zahlung geht mit 3D-Secure ohne Probleme. In einer 3.5.3 müsstest Du die Einstellung auf jeden Fall einmal auf 0 stellen und den Shopcache leeren. Das Interface wurde ja für 3.5.3 ein wenig umprogrammiert und PopUps werden hier so in der Form nicht mehr unterstützt. Ich gebe zu, das ist nicht perfekt dokumentiert im Zuge eines Updates (holen wir nach). Aber bei Dir dürfte ohnehin auch kein PopUp mehr aufgehen, sondern in einer 3.5.3 wird immer alles im iFrame geladen. Ich schätze einmal, dass ist dann auch die Ursache, warum diese Einstellung dann bei 3D-Secure Probleme macht in einer 3.5.3. Habe ich gerade getestet, dann wird Mastercard und Visa ohne Codeeingabe durch gebucht. In der Doku gibt es dafür auch einen entsprechenden Hinweis, allerdings fehlt dieser Hinweis bei einem Update von 3.0.x auf 3.5.x. Sorry dafür… Stelle das bitte bei Dir einmal um - das wird bei Dir sicherlich der Fall sein in den Einstellungen - , gebe mir dann kurz Feedback, ob Du nach Änderung und Cache leeren auch den Dialog wie in Szenario 1 siehst und zu einer Codeabfrage kommst. Ich werde dann die Doku noch einmal in Bezug auf das Update auf 3.5.3 etwas anpassen lassen. Ganz raus nehmen können wir den Punkt aber wohl nicht, da er u.U. bei einer 3.0.5 noch wichtig ist. Stefan

Habe es gerade getestet. Jetzt ist es aus wie in Szenario 1 und das 3D-Secure Fenster geht auf! Jipi Was so eine Zahl alles ausmacht! :money: Vielen lieben Dank!