Pupp3tm4st3rPupp3tm4st3r MemberComments: 1 Received thanks: 0 Member since: January 2016 edited January 2016
Hallo,

ich habe hier folgendes Problem:

Auf einem Entwicklungsserver ist Apache 2.4.17 und versch. PHP Versionen installiert.
Dort wurde nur eine Shopware 4.3.2 Instanz eingespielt, diese läuft auch soweit. Ioncube ist installiert und aktiviert (PHP 5.4.45, ionCube 5.0.19). PHPinfo zeigt an, dass ioncube aktiv ist.
Wenn ich ioncube deaktiviere, dann kann ich die Seite auch nicht aufrufen (weil ioncube verlangt wird), wenn es aktiviert ist erscheint jedoch unter Einstellungen - Systeminfo ganz groß und grün "No Encoder", ist das ein Bug?

Sonst scheint alles zu funktionieren.

Grüße
Simon

Comments

  • R4MR4M MemberComments: 2693 Received thanks: 428 Member since: April 2014

    Wir haben genau das selbe Problem, und ich kann der Kuriosität noch eins drauf setzen:

    Wie haben mehrere SW Shops auf einem Server laufen. Und haben exakt die selben PHP-Versionen (5.6.17); IonCube 5.0.18, die selben PHP-INI und Nginx Einstellungen. Bei den Shop auch die selben Webserver-Einstellungen. Tja aber Systeminfo sagt mir:

    - bei SW 4.3.6 = no encoder
    - bei SW 5.1.1 = Sie benutzen den IonCube Loader

    Wie kann das sein?

     

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 9369 Received thanks: 2822 Member since: September 2013

    Hallo,

    in den alten SW4-Versionen wurde der Ioncube-Loader nur bis Version 5 erkannt. Das wurde mit Shopware 5.0.1/5.0.2 behoben.

    Aber generell ist das nur ein falscher Hinweis, wenn Ioncube korrekt installiert ist, sollte auch alles funktionieren.

    Grüße

    Moritz

  • R4MR4M MemberComments: 2693 Received thanks: 428 Member since: April 2014

    Ah ok, Danke für das Feedback!

Sign In or Register to comment.