CiatronicalCiatronical MemberComments: 25 Received thanks: 4 Member since: February 2017 edited December 2019

Hallo Leute.

Ich komme mal wieder nicht weiter. Diesmal betrifft es den Versand in der Version 6.1.0 RC2. Ich habe mehrere Versandarten angelegt. Alle sind aktiv, alle dem Verkaufskankal zugeordnet. Mittels Rule Builder sind jeweilige Regeln erstellt, wann welche Versandart greifen soll.
Doch im Storefront greift immer nur die Versandart, die im Verkaufskanal als "Standard-Versandart" eingerichtet ist.
Wähle ich ein Produkt welches dieser Versandart zugeorndet ist, funktioniert der Bestellvorgang reibungslos. Wähle ich ein Produkt welches eine andere Versandart benötigt, kommt im Warenkorb die Fehlermeldung:

"Die Versandart ...... ist für Ihren aktuellen Warenkorb gesperrt"

Logt man sich mit seinem Kundenaccount ein und klickt den Button "Versandart ändern", werden die anderen Versandarten auch nicht angezeigt. (wenn es die Richtige wäre, soll auch keine andere ausgewählt werden können.)
Hat jemand eine Idee was ich übersehen oder vergessen haben könnte?

Danke im voraus.
Thomas

Comments

  • CiatronicalCiatronical MemberComments: 25 Received thanks: 4 Member since: February 2017

    Hallo.

    Ich habe die Lösung für dieses Problem selber gefunden. Auch nach ein Update auf Version 6.1.0 RC3 und nun RC4 bestand es vorerst weiterhin. Die Versandarten funktionierten wohl bei einzelnen Artikeln von Anfang an. Es lag mal wieder an den "Varianten-Artikeln"! Solche haben wir zu 95% im Shop.

    Erstellt man im Rule Builder eine Regel die einzelne Artikel bzw. in unserem Fall Artikel einer ganzen Kategorie betrifft, kann man zum einen unter "Bedingungen“ keine Kategorie, sondern nur einzelne "Positionen", "Positionen im Warenkorb" > "ist eine von", "ist keine von" wählen. Vielleicht bestände das Problem nicht, wenn man auch "Positionen der Kategorie" oder nur "Kategorie" als Auswahl im Rule Builder hätte.

    So werden im Rule Builder unter "Positionen" nur die Haupartikel angezeigt und viele leere Auswahlfelder. Und diese leeren Auswahlfelder sind die einzelnen Varianten! Setzt man hier (beim Richtigen!) kein Häckchen, sondern nur beim beschrifteten Hauptartikel, funktioniert die Versandart nicht. Das Schwierige bei der Angelegenheit ist........die leeren Felder/Varianten sind nicht direkt unter dem dazugehörigen Hauptartikel, sondern alle querbeet durcheinander! Man kann also nur probieren bis man das Puzzel zusammen hat. Zum Glück bestehen unsere Artikel nur aus 2 Farbvarianten. Auch hatte ich nach den ersten eingestellten Artikeln bereits begonnen Versandarten und dazugehörige Regeln zu generieren. Eröffnet man einen Shop und stellt als erstes hunderte Produkte mit 5 bis......Varianten ein, ist die Zuordnung der leeren Felder beinahe unmöglich.

    Beste Grüße an alle

    Thomas

Sign In or Register to comment.