aqua-FUNaqua-FUN MemberComments: 2 Received thanks: 0 Member since: November 2015 edited November 2015
Wir haben gestern das kostenlose Plugin gekauft und versucht über den Plugin Manager zu aktivieren. Weder die Aktivierung noch ein Update lässt sich durchführen.
Wir nutzen derzeit shopware 4.3.6, aber das sollte kompatibel sein.

Folgende Fehlermeldung erhalten wir: Fehler 503

Fatal error: Class 'Shopware\SwagDhl\Bootstrap\Update' not found in /home/aquafunc/public_html/shopware/engine/Shopware/Plugins/Community/Frontend/SwagDhl/Bootstrap.php on line 81 503 Service Unavailable Fatal error: Undefined class constant 'self::SELECT_WITHOUT_FROM_PART' in /home/aquafunc/public_html/shopware/engine/Library/Zend/Db/Table/Abstract.php on line 1016

Auch lässt sich das Plugin nicht deinstallieren.

Was können wir prüfen?

Hauschild

Comments

  • sschreiersschreier MemberComments: 3254 Received thanks: 894 Member since: August 2014
    aqua-FUN wrote:
    Wir haben gestern das kostenlose Plugin gekauft und versucht über den Plugin Manager zu aktivieren. Weder die Aktivierung noch ein Update lässt sich durchführen.
    Wir nutzen derzeit shopware 4.3.6, aber das sollte kompatibel sein.

    Folgende Fehlermeldung erhalten wir: Fehler 503

    Fatal error: Class 'Shopware\SwagDhl\Bootstrap\Update' not found in /home/aquafunc/public_html/shopware/engine/Shopware/Plugins/Community/Frontend/SwagDhl/Bootstrap.php on line 81 503 Service Unavailable Fatal error: Undefined class constant 'self::SELECT_WITHOUT_FROM_PART' in /home/aquafunc/public_html/shopware/engine/Library/Zend/Db/Table/Abstract.php on line 1016

    Auch lässt sich das Plugin nicht deinstallieren.

    Was können wir prüfen?

    Hauschild
    Hallo,

    gibt es nicht genau für dieses Plugin schon ein Thema, was sich unter diesem Thema hier befindet?

    Themenlink: post143543.html#p143543 (Themenname: "Plugin: DHL Integration").

    Ansich wäre da deine Frage doch eher aufgehoben, weil es dort ja schon ausführlich um das Plugin geht.

    Hast du einmal versucht, das Plugin über den FTP zu löschen?

    Beste Grüße

    Sebastian
  • aqua-FUNaqua-FUN MemberComments: 2 Received thanks: 0 Member since: November 2015
    Ich habe die Beiträge dort alle gelesen, aber hier geht es ja darum, das ich das Plugin gar nicht aktiviert bekomme, siehe Fehlermeldung.
    Deshalb habe ich diese Anfrage hier gestellt und auf Hilfe gehofft.

    Ralf
  • sschreiersschreier MemberComments: 3254 Received thanks: 894 Member since: August 2014
    aqua-FUN wrote:
    Ich habe die Beiträge dort alle gelesen, aber hier geht es ja darum, das ich das Plugin gar nicht aktiviert bekomme, siehe Fehlermeldung.
    Deshalb habe ich diese Anfrage hier gestellt und auf Hilfe gehofft.

    Ralf
    Hallo,

    trotzdem sollte man nicht für jedes einzelne Problem eines Plugins ein Thema aufmachen (vorallem wenn ein Thema des Plugins schon ganz oben in der Liste ist), da man am Ende sonst pro Plugin 10 Themen und gar keine Übersicht mehr hat.

    Sicherlich wird deine Fehlermeldung auch mit der im anderen Thema besprochenen API-Änderung zusammenhängen - deshalb wäre es sicher besser, wenn du dort mal dein Anliegen reinschreibst.

    Wie bereits im anderen Post erwähnt, hast du mal vesucht, das Plugin über den FTP zu löschen? Und es dann wieder neu zu laden/installieren?

    Scheinbar muss ja bei der Installation etwas schief gegangen sein, wenn er eine Klasse nicht findet. Hast du im Shopware-Account auch deine aktuelle Shopware-Version bei deinem Shop hinterlegt?

    Beste Grüße

    Sebastian
  • Dennis WahlDennis Wahl MemberComments: 500 Received thanks: 95 Member since: December 2012
    Hi aqua-FUN

    hast du das Plugin eventuell doppelt? Schaue einmal unter
    engine/Shopware/Plugins/Community/Frontend/SwagDhl/

    sowie unter: engine/Shopware/Plugins/default/Frontend/SwagDhl/

    Gruß
    Dennis
Sign In or Register to comment.