XXXXXXXXXXXX MemberComments: 638 Received thanks: 10 Member since: December 2010 edited September 2015
Hallo,

bekomme bei Paypal Express und bei Paypal aus dem Zahlungsmenü folgenden Fehler angezeigt:

support0002.jpg

Viele Grüße
Rainer

Comments

  • Stefan HamannStefan Hamann AdministratorsComments: 2473 Received thanks: 443 Member since: June 2010
    Hey,

    kannst du den fehler reproduzieren, tritt der also immer auf? Systemvoraussetzungen passen alle? Also entweder ist das ein temporärer Fehler seitens PayPal oder bei dir auf dem Server gibt es z.B. Probleme mit der DNS-Auflösung bzw. dem Connect zum PayPal-Server.
  • XXXXXXXXXXXX MemberComments: 638 Received thanks: 10 Member since: December 2010
    Hallo,

    vielen Dank für die schnelle Antwort.

    Ja, der Fehler tritt immer auf. Der Check der Systemvoraussetzungen ist OK.

    Läuft Paypal Express und Paypal (in der Checkoutprozedur) mit den gleichen Zugangsdaten?

    Ich versuche nochmal alles abzuchecken.

    Viele Grüße
    Rainer
  • Stefan HamannStefan Hamann AdministratorsComments: 2473 Received thanks: 443 Member since: June 2010
    Ja, das läuft über die selben Zugangsdaten.

    Dann hängt es mit einiger Sicherheit an einer Fehlerkonfiguration des Servers - kannst ja mal probieren, ob du via PHP die PayPal-Server erreichst - also Curl - Get auf
    https://www.paypal.com/cgi-bin/webscr?cmd=_express-checkout&token=
    https://api-3t.paypal.com/nvp
    
    Evtl. ist CURL auch ohne HTTPS Unterstützung kompiliiert - das würde das Verhalten auch erklären!
    Thanked by 1XXXXXX
  • XXXXXXXXXXXX MemberComments: 638 Received thanks: 10 Member since: December 2010
    Ich habe beim Provider (DF) nachgefragt und folgende Antwort bekommen:


    Curl ist bei uns mit SSL-Support installiert und kann von Ihnen verwendet werden um URL's mit https aufzurufen.
    Mit dem folgenden Befehl, sehen Sie die Ausgabe und den Header vom Aufruf:

    curl "https://www.paypal.com/cgi-bin/webscr?cmd=_express-checkout&token=" -v

    Die Ausgabe sieht dann z.B. wie folgt aus:
    * About to connect() to www.paypal.com port 443 (#0)
    * Trying 66.211.169.65... connected
    * Connected to www.paypal.com (66.211.169.65) port 443 (#0)
    * successfully set certificate verify locations:
    .....
    * SSL certificate verify ok.
    > GET /cgi-bin/webscr?cmd=_express-checkout&token= HTTP/1.1
    > User-Agent: curl/7.20.0 (i686-pc-linux-gnu) libcurl/7.20.0
    OpenSSL/0.9.8p zlib/1.2.3
    > Host: www.paypal.com
    > Accept: */*

    Viele Grüße
    Rainer
  • Stefan HamannStefan Hamann AdministratorsComments: 2473 Received thanks: 443 Member since: June 2010
    Hey,

    habe gerade nochmal nach der Fehlermeldun gegoogelt... Fordere mal einen neuen API-Key bei PayPal an und gebe die Zugangsdaten komplett neu ein, dann sollte es gehen.
    Thanked by 1XXXXXX
  • XXXXXXXXXXXX MemberComments: 638 Received thanks: 10 Member since: December 2010
    Hallo,

    Fehler bleibt.

    Viele Grüße
    Rainer
  • Stefan HamannStefan Hamann AdministratorsComments: 2473 Received thanks: 443 Member since: June 2010
    Okay, dann schick mal bitte das ganze Paket an Zugangsdaten an forum@shopware.de

    Also FTP + DB + Shopware Backend + PayPal-Backend-Login -

    Ich vermute aber fast, dass wir das Problem nicht auf Server-Ebene lösen können. Da ist vermutlich irgendeine Restriktion seitens PP aktiv.
  • XXXXXXXXXXXX MemberComments: 638 Received thanks: 10 Member since: December 2010
    @Stefan

    Vielen Dank für dir Unterstützung. In den Einstellungen war der Sandbox-Modus noch aktiv :oops:.

    Nun funktioniert alles.

    Viele Grüße
    Rainer
  • knoppknopp MemberComments: 15 Received thanks: 0 Member since: February 2011
    Hallo @ alle,

    habe das gleiche problem mit Fehlermeldung wie im ersten Post.

    Habe alles überprüft:

    Curl = aktiv
    API beantragt und eingefügt
    Sandbox-Modus = 0
    PayPal-Plugin = aktiv

    Trotzdem bekomme ich immer wieder die o.g. Fehlermeldung angezeigt.

    Was kann da noch immer nicht stimmen ?

    Benutze die Shopware-Version 3.5.3

    Danke im voraus für eine Antwort und oder Hilfe

    >>> Hat sich erledigt <<< Weiß nicht warum, aber nun geht es auf einmal. Villeicht braucht die Freischaltung der API-Daten so lange bei PayPal
    Aber trotzdem danke nochmals :thumbup:
  • doddndoddn MemberComments: 7 Received thanks: 0 Member since: April 2014
    Hallo zusammen,

    tut mir leid, dass ich dieses Thema wieder aus der Versenkung holen muss.

    Ich habe seit ca 3 Wochen in unregelmäßigen Abständen, folgenden Fehler:

    Screenshot_1.jpg

    Dieser Fehler tritt auf seit dem wir SSL haben und unter https:// erreichbar sind.

    Könnt ihr mir weiter helfen?

    Technische Information:

    shopware_version: 4.3.0
    php_version: 5.3.3-7+squeeze19

    Paypal Einstellungen:
    PayPal Pluginversion 3.3.3
    API Timeout = leer
    Curl verwenden = nein (egal was ich nehme, Fehler bleibt)
    SSL-Version = Default


    Wäre über eure Hilfe sehr dankbar.

    MFG
Sign In or Register to comment.