"We were not able to send the order confirmation by mail, please contact the shop owner"

When the testing checkout process we keep getting the same error “We were not able to send the order confirmation by mail, please contact the shop owner”

Tried all possible settings in Configuration > Basic Settings > Shop Settings > Mailers.   
Both through built-in mail function and external SMTP function, which works perfectly on other test device. 

Any ideas what we might be doing wrong still?

Maybe the mail of the customer is somehow blocked on your mailserver? What settings did you try? Did you try sending an email manually to the customer’s address using the same configuration as set in Shopware?

Regards

@simkli schrieb:

Maybe the mail of the customer is somehow blocked on your mailserver? What settings did you try? Did you try sending an email manually to the customer’s address using the same configuration as set in Shopware?

Regards

Thanks for contributing to my question.  However, I should have pointed out this is in the test fase setting up the store and sending test-emails to some of our own email addresses.

From the log file:

 

 

{
  „exception“: „[object] (Zend_Mail_Protocol_Exception(code: 0): Invalid type given. String expected at /engine/Library/Zend/Mail/Protocol/Abstract.php:142)“
}

Check this out: http://en.community.shopware.com/_detail_1841.html

 

1 Like

@NextMike schrieb:

Check this out: http://en.community.shopware.com/_detail_1841.html

 

Hey Mike, thanks for that.  We’re running Shopware as a Bitnami stack in Google cloud.  Should I worry some extensions aren’t properly installed?  (I have been checking that out earlier tonight - to no avail) 

Set everything back to localhost mail function, port 25 … so basic settings and tried the backend email templates test to see if this somehow gave different error message.

It did.  Now getting : "Email could not be sent. Error message: Unable to send mail. " for mail module in backend log.

OK … so the solution was found through Bitnami help pages… 

What I did was set it all back to PHP as described above.
Next I UNcommented the following line in php.in :

sendmail_path = “env -i /usr/sbin/sendmail -t -i”

After that rebooted the server, just to make sure the apache would pick up the edit… 

Et voila.  Magic.  

 Too fast to call it magic… Although shopware no longer produces any errors when sending, the emails don’t seem to arrive…  So back to the drawingboard.

I’m starting to think that Google instance/VM is blocking port 25 for some f-ing reason?! 

 

@Nimr0d schrieb:

OK … so the solution was found through Bitnami help pages… 

What I did was set it all back to PHP as described above.
Next I UNcommented the following line in php.in :

sendmail_path = „env -i /usr/sbin/sendmail -t -i“

After that rebooted the server, just to make sure the apache would pick up the edit… 

Et voila.  Magic.