Warenkorb geht nicht

Hallo zusammen,

 

ich bin bei shopware neu und habe von 4.2.1 auf 5.2.27 upgegradet. Der Shop läuft super nur der Warenkorb bzw. Account leidet auf Seite 500 weiter.

In der logdatei steht folgendes:

[[2017-07-23 13:42:56] core.ERROR: Enlight_Exception: BASKET-INSERT #01 No price acquired in /usr/www/shopware5/engine/Shopware/Core/sBasket.php:2722 Stack trace: #0 /usr/www/shopware5/engine/Shopware/Core/sBasket.php(1547): sBasket->getPriceForAddArticle(Array) #1 /usr/www/shopware5/engine/Shopware/Controllers/Frontend/Checkout.php(1430): sBasket->sAddArticle('Jako Katalog 20...', 1) #2 /usr/www/shopware5/engine/Library/Enlight/Controller/Action.php(159): Shopware_Controllers_Frontend_Checkout->ajaxAddArticleCartAction() #3 /usr/www/shopware5/engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight_Controller_Action->dispatch('ajaxAddArticleC...') #4 /usr/www/shopware5/engine/Library/Enlight/Controller/Front.php(223): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #5 /usr/www/shopware5/engine/Shopware/Kernel.php(182): Enlight_Controller_Front->dispatch() #6 /usr/www/shopware5/vendor/symfony/http-kernel/HttpCache/HttpCache.php(491): Shopware\Kernel->handle(Object(Enlight_Controller_Request_RequestHttp), 1, true) #7 /usr/www/shopware5/engine/Shopware/Components/HttpCache/AppCache.php(266): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #8 /usr/www/shopware5/vendor/symfony/http-kernel/HttpCache/HttpCache.php(448): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #9 /usr/www/shopware5/vendor/symfony/http-kernel/HttpCache/HttpCache.php(344): Symfony\Component\HttpKernel\HttpCache\HttpCache->fetch(Object(Symfony\Component\HttpFoundation\Request), true) #10 /usr/www/shopware5/engine/Shopware/Components/HttpCache/AppCache.php(187): Symfony\Component\HttpKernel\HttpCache\HttpCache->lookup(Object(Symfony\Component\HttpFoundation\Request), true) #11 /usr/www/shopware5/vendor/symfony/http-kernel/HttpCache/HttpCache.php(210): Shopware\Components\HttpCache\AppCache->lookup(Object(Symfony\Component\HttpFoundation\Request), true) #12 /usr/www/shopware5/engine/Shopware/Components/HttpCache/AppCache.php(114): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #13 /usr/www/shopware5/shopware.php(117): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #14 {main} [] {"uid":"cc7316c"}

habe das Upgrade in einem eigenen Verzeichnis mit eigener DB ubgegradet und diese Testseit läüft über eine Subdomain.

Kann es daran liegen?

Der Hauptshop der noch 4.2.1 ist und Online steht, ist unter der Domain im Host von Shopware angemeldet. Die neue Shopware5-Seite mit Subdomain überhaupt noch nicht.

Oder woran kann dies liegen?

 

VG

Fransiskaner

Kann das sein, dass das ein Artikel mit 0,00 Euro ist, den Du versuchst in den Warenkorb zu legen?

Ja, das hatte ich versucht aber auch die anderen sowie Account/Login geht nicht.

Was kommt da denn für ne Fehlermeldung? Weil die obere sieht erstmal so aus, als ob die zu dem 0,00 Euro Artikel gehört.

Bin gerade nicht am Rechner. Also bei 4.2.1 funktioniert noch alles. Nur bei der Subdomain shopware5 weder Account noch Warenkorb.

Am Hosteintrag bei Account.shopware kann es also nicht liegen? Wie gesagt da ist nur die Hauptdomain nicht die Subdomain hinterlegt.

versuche es mal selbst

test.cdcshop.de

Ne, daran kann es nicht liegen.
Sind alle Plugins aktualisiert worden?
Seh die Fehlermeldung nicht, die er auswirft, wenn ich in den Warenkorb gehe. Die wäre jetzt interessant.

sehe leider auch keine Fehlermeldung, habe es auch nochmals probiert aber es wird keine Fehlermeldung geschrieben.

Die Plugins die nicht kompatibel mit der 5.2.27 waren habe ich deinstalliert und aktualiseren habe ich noch nicht gekonnt da wegen dem HOST folgendes kommt.

Der übergebene Referenz Shop konnte vom SBP-Server nicht ermittelt werden.

Error code: PluginLicensesException-3

Wenn ich in den Pluginmager wechsele kommt übrigens…

The file /usr/www/shopware5/engine/Shopware/Plugins/Community/Frontend/sKUZOAutoBelege/Bootstrap.php was encoded by the ionCube Encoder for PHP 5.3 and cannot run under PHP 7.0. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6.

File:Unknown

 

Die Fehlermeldung steht in der Regel im Error Log des Servers.

Ja aktualisieren klappt auch erst, wenn du den Host und die Plugins im Shopware Account hinterlegt hast.

Der Fehler aus dem Plugin-Manager hat mit deinem Plugin “sKUZOAutoBelege” zu tun. Das ist noch ein Plugin welches unter PHP 5.3 verschlüsselt wurde.
Du verwendest aber PHP 7.0 - Das Plugin müsste auch auf jedenfall deinstalliert werden. Bzw. die aktuelle Version installiert werden.

ich habe es nun auf die PHP Version 5.6 abgespeckt und nun geht es :frowning:

Schade wollte eigentlich mit PHP7 arbeiten.

wie würdest Du vorgehen.

 

ich habe eine Domain mit 4.2.1 im Shopware Account.

Die neue Subdomain mit 5.2.27 soll die selbe Domain erhalten wie bisher. Ich kann aber im Account nicht auf 5.2.27 ändern sonst läuft der alte Shop nicht mehr.

Würdest Du einen 2. Account erstellen?

Wenn das mit PHP 5.6 läuft ist doch erst einmal gut.

Dann kannst Du den Shop soweit vorbereiten bis er live geht und dann aktualisierst Du später alle Plugins und damit auch die PHP Version.

1 Like

OK super. Danke Dir für Deine Tipps

Hallo zusammen!

mir ist klar, dass diese Diskussion schon länger her ist aber ich habe ein ähnliches Problem mit Shopware 5.5.2 :( 

Enlight_Exception: BASKET-INSERT
#01 No price acquired in /engine/Shopware/Core/sBasket.php:3043 Stack trace:
#0 /engine/Shopware/Core/sBasket.php(1842): sBasket->getPriceForAddArticle(Array)
#1 /engine/Shopware/Controllers/Frontend/Checkout.php(1551): sBasket->sAddArticle('THC89860', 1)
#2 /engine/Library/Enlight/Controller/Action.php(193): Shopware_Controllers_Frontend_Checkout->ajaxAddArticleCartAction()
#3 /engine/Library/Enlight/Controller/Dispatcher/Default.php(548): Enlight_Controller_Action->dispatch('ajaxAddArticleC...')
#4 /engine/Library/Enlight/Controller/Front.php(222): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp))
#5 /engine/Shopware/Kernel.php(202): Enlight_Controller_Front->dispatch()
#6 /vendor/symfony/http-kernel/HttpCache/SubRequestHandler.php(102): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#7 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(448): Symfony\Component\HttpKernel\HttpCache\SubRequestHandler::handle(Object(Shopware\Kernel), Object(Symfony\Component\HttpFoundation\Request), 1, true)
#8 /engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)
#9 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(238): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true)
#10 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true)
#11 /engine/Shopware/Components/HttpCache/AppCache.php(143): Symfony\Component\HttpKernel\HttpCache\HttpCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true)
#12 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(181): Shopware\Components\HttpCache\AppCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true)
#13 /engine/Shopware/Components/HttpCache/AppCache.php(116): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#14 /var/www/html/shop/shop/shopware.php(122): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request))
#15 {main}

 

Hat jemand von euch eine Ahnung?

Bei disem Artikel handelt es sich um einen 0Euro Artikel.

Hallo THCDev,

schau mal bei diesem Artikel - da steht der Lösungsweg mit 0,00 Euro Artikeln: Null-Euro-Artikel verwenden

Viele Grüße

Benjamin