Version der Platform

Hallo zusammen,

ich versuche mich gerade mit einer frischen lokalen installation und versuch das Paypal Plugin zu installieren. Leider bekomme ich dazu folgende Fehlermeldung:

  Could not install plugin, got 1 failure(s).
  Array
  (
      [0] => Required plugin/package “shopware/platform v6.0.0+dp1” does not match installed version 9999999-dev.
  )

Wie muss ich mit der Meldung umgehen? Sourcen sind alle aktualisiert. Installiert wurde über git

Der Store braucht eine fertige Version - das war in SW5 ja auch schon so.

Wenn du den Master einsetzt, hast du eine Entwicklungsversion, also eine die der Shopware-Store nicht kennt. Am besten holst du dir das Plugin auch per Git: GitHub - shopwareLabs/SwagPayPal: PayPal integration for shopware/platform

Moin.

Ich erhalte die Meldung beim Versuch, das Migrationsplugin zu installieren. Wo bekomme ich das her?

Gruß
Nils

Schau mal hier:

@DerNils schrieb:

Moin.

Ich erhalte die Meldung beim Versuch, das Migrationsplugin zu installieren. Wo bekomme ich das her?

Gruß
Nils

Kannst du im Store bekommen - im Anschluss einfach die Plugin ZIP über das Account herunterladen:

https://store.shopware.com/swag257162657297f/migrationsassistent.html?c=1069

LG Andre 

Hallo Andre,

das hilft leider nicht. Gleicher Fehler.

Uncaught PHP Exception Shopware\Core\Framework\Plugin\Requirement\Exception\RequirementStackException: "Could not install plugin, got 1 failure(s). Array ( [0] => Required plugin/package "shopware/platform v6.0.0+dp1" does not match installed version 9999999-dev. ) " at /var/kunden/K10399/development/vendor/shopware/platform/src/Core/Framework/Plugin/Requirement/RequirementExceptionStack.php line 25

 

Nachtrag: Version 0.9.0 konnte ich aus dem ZIP installieren, der Fehler kommt dann beim Update auf 0.9.1:

Uncaught PHP Exception Shopware\Core\Framework\Plugin\Requirement\Exception\RequirementStackException: "Could not update plugin, got 1 failure(s). Array ( [0] => Required plugin/package "shopware/platform v6.0.0+dp1" does not match installed version 9999999-dev. ) " at /var/kunden/K10399/development/vendor/shopware/platform/src/Core/Framework/Plugin/Requirement/RequirementExceptionStack.php line 25

 

Nachtrag: Version 0.9.0 konnte ich installieren, der Fehler kommt dann beim Update auf 0.9.1

Du setzt aktuell den Master ein und nicht eine releaste Version. Der Plugin Manager kennt deine Version nicht und lehnt den Download ab - nicht zuletzt weil die Versionen im Store ja auch nur für die jeweils releaste Version freigegeben und getestet sind. Ob das dann in anderen Versionen funktioniert, ist nicht geklärt.

Du hast vier Möglichkeiten:

  • Eine releaste Version einsetzen, bspw. den Branch 6.0-dp
  • Das Plugin nicht über den Store beziehen (bspw. Github), da sind natürlich nicht alle verfügbar
  • Das Plugin in deinem Account als Zip herunterladen und manuell installieren
  • Die Versionsnummer „faken“, so wie man es in SW5 machen musste

Viele Plugins werden auf dem Master nicht funktionieren, da der schlichtweg oftmals neuer ist, als die releaste Version. Wenn du also konkret etwas testen willst, solltest du auf den 6.0-dp zurückgreifen.

1 Like

Danke, bin auf 6.0-dp umgezogen, Migration läuft